HassOS Hanging on Boot: Stuck at "Wait Until Kernel Time Synchronized"

Running HassOS on an RPI 3. My HA was acting buggy and eventually none of the pages were loading properly/at all in my android app. Wasn’t able to reboot from the app or ssh to reboot, so I did a hard reset. Now during the boot process I’m stuck on a seemingly infinite wait for a start job to finish.

A start job is running for Wait Until Kernel Time Synchronized (1h 58min 55s / no limit)

I’ve tried hard resetting my pi 3 times now and it hangs right here. This is the longest I’ve let it run. Google results have not been very helpful, requiring to mess with or disable time sync settings that I can’t access or change because I can’t ssh yet through the boot process. No external keyboard either, but I’m not sure if I could even issue commands at this point in the boot process.

Have you tried to restore from a backup snapshot?

Dang I didn’t even think of that. Unfortunately I didn’t make any backups or snapshots to restore from. I’m not too deep into my setup that reflashing and starting from scratch is too big of a deal, but if there’s a fix I’d like to try it first

I recently had the same thing happen on my Pi 4 HA install. Everything was fine for weeks then I upgraded to 112 on July 3. Then today two days after upgrading my fiańce noticed it wasn’t working. Went and power cycled the Pi and it never came back after about 10 minutes of waiting. So I hooked it up to a monitor and keyboard and now it has been apparently trying to sync the time for about 5 minutes without success. So the boot process has just hung waiting for NTP. Although it looks like I have a link light on the Pi’s NIC but it doesn’t appear to be getting an IP address from the router even though it has never had this issue before and I haven’t changed any network settings lately.

Turns out my microSD card kicked the bucket. I tried erasing and reflashing it but no luck couldn’t even get it to erase using windows diskpart or macos disk utility. Swapped it out for another one and things seem fine for now. I make it a habit to take a snapshot and download it from the PI anytime I make any major changes to versions or configs so not too big of a deal, but just to give folks a heads up the Samsung EVO microSD cards are kind of crappy in terms of endurance. This latest one was even the Pro series which is supposed to have the best longevity and it didn’t even last 6 months in my HA pi with a relatively small number of devices and only a few addons. The highest write process on my HA setup is probably InfluxDB but there are only about 6 to 10 metrics getting dumped into that with I think 1 minute resolution or higher.

Same issue here in the same way. I used a Samsung SD Evo Plus card.
I had to buy another SD card, install a fresh new version of Hassio and restore a previous backup snapshot from my Google Drive.
I cannot figure out what happened. :sweat:

Same issue here on Raspberry Pi 3+ with Kingston SSD…it’s not possibile to restore backup…

could be a problem related to storage?

Just wanted to say, had the same thing happen. Stuck on “Wait until kernel time sychronized.” Was fine until this most recent update. Ill have to pull the card and see if I can use it or not I guess.

I suspect that what is happening is we are seeing symptoms caused by failing microSD cards. This is likely because microSD cards have a limited number of write cycles and we are exceeding that limit. There may be a bug in HA causing that to be exhausted too quickly, the cards we had were just crappy, or it is just a known issue that we will have t live with or work around with another storage mechanism that has more durability. Likely some people’s experience with this was brought about during an upgrade due to the larger number of file updates taking place just happened to coincide with the card life limit.

1 Like

I’m having this problem on a brand new SD card that I just flashed.

Similar issue here, although I am running rpi3 from external ssd.

Recently desided to upgrade and was running fine for a week or so. Just this afternoon I noticed the house was non-responsive. After a power cycle it shows the above Wait Until Kernel Time Sync for about 2-3 minutes, then boots on, but does not aquire an IP, so cannot connect

Something buggy?

Hey folks,

it happened to me in the early days of july too.

My Hardware:
Raspberry Pi 4, 2 GB
Samsung Evo Plus 32 GB

Is there anything to do to prevent it from similar situations in the future?
What SD cards are know for living long using hassio?

For the record in my case the data partition was gone on my ssd. Connected a monitor and notice below error message during a reboot. Not sure why and how this happend, but anyway, I reflashed the drive and re-stored ha with the latest backup. Thank god for google backup! But everthing is back to normal and fast as ever for now.

I’m seeing this behavior running HassIO in a VM on a Synology Disktation.

Ideas?!?

I am seeing this also on my Synology NAS VM, but only when there is no internet connection. Boot only works, if I have internet connectivity…

Same here. My router was offline this morning and HA was unresponsive.
Even once LAN was back up, I still couldn’t access HA. Showing as offline
I had to use the CLI to get access to re-activate the network instance.

Once it was started I could get into HA and in Settings | System | Network
I could see my IP4 had been set to “Disabled” ?
Reset it back to DHCP (reserved IP) and it rebooted back up normally again

In case you’re wondering about the CLI commands
From HA > type:

login
nmcli
nmcli connection show
nmcli con edit "Home Assistant OS default"  # or whatever your HA instance is called
activate

It should pop back up on the network allowing you to change the IPV4 settings back to DHCP again

Curious how you were able to type commands into the cli? My HA instance is no longer connecting to my home network, but it’s booting up and showing the cli. I tried plugging the pi into my laptop via ethernet, but still not able to interact with it at all.

I connected a keyboard and HDMI cable to the Pi.

Not sure if the terminal/display option would be available if it was on NAS/Docker. Should be available if VM tho.

Hi. I have this same problem suddenly. Rpi4 4gb. Using an SSD in supervised mode. Thanks for these commands, as I don’t have any under the hood knowledge. But, for others fyi, I needed to type

Save and then activate.

However, how do we fix the underlying root cause?
Thanks,
Neil

Update… I’ve opened this as an issue here: HassOS Hanging on Boot then no DHCP · Issue #1949 · home-assistant/operating-system (github.com)

No worries, I’m glad they were able to get you back up and running