Help with TCL WiFi Air conditioner integration

Hello, I have been trying to integrate my TCL Wifi AC with HA.

None of the current integrations work and I am trying to build a new one.

This AC works with the Intelligent AC app made by ACSmart, also makers of TFIAC. This app is similar to TFIAC but uses a different way in the backend to communicate with the AC.

So far, I have captured packets and have found the hex streams that turn the AC on and off.
Communication is UDP, port is 16385.

To turn AC on, send:


To turn AC off, send:


I can capture packets for all the functions but I have no idea how to integrate this to HA, hence the need for help.


I was looking for such integration for some time. I have now two TCL AC which rely on Intelligent AC app.

There was some offtopic around this app in TFIAC integration thread here:
[SOLVED: for local access]A/C app named TFIAC, anyone ever heard of it? - Configuration - Home Assistant Community (

Might be useful, in case you missed that. Some people there may have the knowledge how to implement the codes?

I’ll allow myself to call you guys, maybe you could chip in?
@lakis @fredrike

But anyway, well done you! Fingers crossed! I’d love to be able to control that AC directly. Both Intelligent AC app and SmartIR are not very reliable, also Google Home integration is very basic (only on/off).

Hello i couldn’t do anything and i gave up, i have 8 devices with intelligence ac but i cant make it work with home assistant… :frowning: I can run few teat if someone will provide any instructions. :slight_smile:

i see, thanks

@sotiris-bos how did you obtain those codes? did you verify they work? i’ve used packet sender but codes won’t do anything

Are there any dongles installed in your A/Cs? :slight_smile: Especially the OSK-102 or OSK-103?

Or could one of you check, what servers are called (via the app) to control your A/C.

I couldn’t ind out, if TCL is itself the manufacturer or just using a branded unit, eg. from Midea. If it would be a Midea unit, it should be possible to make it work. The best way to find out is one of the above or one of you is looking into the outdoor unit (tools needed), and search for something with a “Midea” logo… :smiley:

1 Like

I’ve been looking at indoor unit PCB on other occasion but what dongles do you mean? WiFi modules, USB, anything particular?

Anyway, tracked DNS request and so, app makes a request to:

The AC itself calls these domains on power restored:

Thanks for looking! :slight_smile: Unfortunately these aren’t any known Midea URLs, so I’d say this is not a branded Midea unit. Sorry!

But nonetheless good luck with getting the A/Cs into HA :+1: Sorry, that I can’t be of more help here. :frowning:

Hey any update on this, did you manage to get more hex streams from the app?

Hello. Any news about the progress? I am interested also to this. I bought a “TCL Miracle II” and I would like to be able to control it through HA.

I’ve also got one of these TCL Heat pumps, would love to integrate it into HASS!


It uses the “Intelligent AC” app, whose icon looks VERY similar to the “TFIAC” app, but it is different enough that it doesn’t work.

Here’s a link to the apple Apps store:

And to google app store

Edit - I found this thread [SOLVED: for local access]A/C app named TFIAC, anyone ever heard of it? - #7 by Joan_Palots

However it looks like Aircons controlled by “Intelligent AC” doesn’t work with this integration :frowning:

I’m also a lucky guy with 2 TCL ACs, one is working the old way (Tuya compatible), the other, newer one is controlled by the Intelligent AC app.

As the wifi module is way different in the new one (could not be flashed) I ordered the same module like in my older AC to replace it, and reflash the dump I’ve made from my first AC.
Without any luck, module is powered up, but AC cannot be found in the App.

Thats the module I’ve ordered to play around with:

@irqnet - did you have any luck with that new module?

Not at all. Flashing the module with the firmware backup from the other AC (Tuya) was successful, but I wasn’t able to pair the device in the App, it was not even discovered.

I’ve also tried flashing Tasmota with Tuya MCU as device type, but I don’t know how to investigate which commands could be send to the AC.

1 Like


Same issue here, does anyone could connect Intelligent AC app with HA?
I’ve been reading this topic [SOLVED: for local access]A/C app named TFIAC, anyone ever heard of it? - #67 by Macrisu but no conclution there


Any news here?

I have two TCL wifi ACs and i would love to integrate them into home assistant.

The TCL home app does integrate with Google Assistant, any chance down that road?

How about using like RM4C to control the aircon?
I’ve also 2 TLC (Be Vool 12000btu) units.
No time to try until now.

I use the Google assistant SDK intergation.
Works perfectly

Maybe it will help someone.
I have managed to connect my TCL AC unit via Tuya smart app. I was able to connect AC unit to Tuya smart app and then integrate it to HA via Tuya integration, it works with both Tuya Local and Tuya cloud

What AC model do you have?

I failed to add my TCL TAC-09CHSA/DSEI-W to Tuya App.

It is rebranded TCL - Vivax COOL ACP-12CH35REWI.
I noticed, when I was adding it to original app (Intelligent Air), that SSID of AC was tuya-xxxxx. After I put it in pairing mode I added it manually to Tuya app. Auto discovery was not working