[SOLVED: for local access]A/C app named TFIAC, anyone ever heard of it?

Weather better???
any update on this?

regards Remco

So, I have 9 AC units that work with TFIAC.
I can control them via LAN from HA, but I cannot control them remotely (I use reverse proxy to connect to my virtual machine hosted on Synology).

This is the log

Logger: homeassistant.helpers.entity
Source: components/tfiac/climate.py:102
First occurred: 10:43:32 (7 occurrences)
Last logged: 10:48:32

Update for climate.etaj_1_centru fails
Update for climate.etaj_2_fata fails
Update for climate.parter_centru fails
Update for climate.etaj_2_spate fails
Traceback (most recent call last):
  File "/usr/local/lib/python3.9/site-packages/tellsticknet/util.py", line 50, in sock_recvfrom
    await blocking.wait()
  File "/usr/local/lib/python3.9/asyncio/locks.py", line 226, in wait
    await fut

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/local/lib/python3.9/asyncio/tasks.py", line 492, in wait_for

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/entity.py", line 514, in async_update_ha_state
    await self.async_device_update()
  File "/usr/src/homeassistant/homeassistant/helpers/entity.py", line 742, in async_device_update
    raise exc
  File "/usr/src/homeassistant/homeassistant/components/tfiac/climate.py", line 102, in async_update
    await self._client.update()
  File "/usr/local/lib/python3.9/site-packages/pytfiac.py", line 113, in update
    response = await self._send(STATUS_MESSAGE.format(seq=self._seq))
  File "/usr/local/lib/python3.9/site-packages/pytfiac.py", line 96, in _send
    data, _ = await asyncio.wait_for(
  File "/usr/local/lib/python3.9/asyncio/tasks.py", line 494, in wait_for
    raise exceptions.TimeoutError() from exc

I have a new AC unit (2019 made) with this mac address[quote=“lakis, post:40, topic:58169”]

I had 10 units and now I’ve replaced one from storage.
I cannot add it as new to tfiac and my old units are gone from tfiac after iphone change, but are working in HA.
My problem now is How to add this old AC to WLAN?

Intelligent AC is not seeing the unit!

TFIAC is dead and you cant find it anymore. I happy that they are still working with you home assistant,

About the new device, if you cant with Intelligent AC, then try to use TCL HOME App ,

1 Like

Thank you, I’ll try TCL Home
If It’s not working, I’ll try this tomorrow:

I can confirm that the TCL Home app is not working, but this worked immediately after hitting enter. I saw PP on the LCD lights.

This sounds interesting! I have two 2021 model TCL wifi air conditioners running currently via TCL home app. Sadly i cannot find an integration for home assistant

After this method, is the AC only accessible through HA?

1 Like

I know this is an old topic, but I am trying to connect my TAC-12CHSD to my network. As known, this is not possible by any of the Chinese apps. I tried the broadlink script, I got it working under python i.s.o. python3, as this was failing on import broadlink. But I can’t use a windows machine to connect to the AC wifi. Are there any windows settings blocking this? I put the AC in AP mode by pressing display 8 times, it beeps and goes into CF, and appears sometimes on wifi list. Same goes when I press reset button on the wifi module. Any ideas how to set this up?

Do you have some progress with TAC-12CHSD and HA?

No progress, I also tried finding the TFIAC apk online, but found apps, that need too many permissions, so I left that idea, unless someone here can help me find the correct APK.

Anyone have any luck getting AC units with TCL Home into Home Assistant? I just picked one up and hoped it would work since it said it would with google. Should have known better. God I can’t wait until Matter starts actually getting used.

Link doesn’t work anymore :frowning:

Hi! Im setting up home assistant at home and I have 3 ACs that use Intelligent AC app. The ACs brand is Greenwind and they’re connected to the app, I have each AC IP address but im not being able to add it to Home Assitant.

I’ve already added the string to configuration.yaml like this:

platform: tfiac
    host: #Dormitorio

But im not being able to see it on entities or devices. Any help?

I have an EAS Electric brand air (I think it’s really TCL), it works with the Intelligent AC app, before it worked with the Tfiac app.

I had it integrated in HA with the Tfiac integration, it worked perfectly until one of the last updates, I think I’m not the only one with this problem:

any solution? Thank you!

Try the Intelligent AC application on Google Play store - worked for me

Unfortunately, TFIAC integration now broken, until fixed cannot integrate into Home Assistant.

The problem with the intelligent AC app is, that it requires some kind of activation. Wants me to scan a QR code, but not sure what code to scan. Manual input asks for a activation code, so I am stranded with the intelligent AC app.

My friend was able to find his manual, if anyone has issues with a 12CHSD or similar. Activate the app with activation code ‘tclkt’

Thanks to @fredrike for all the work for integrated the clima inside home assistant, i asking an update for the integration TFIAC, for working with new line guide of Home Assistant.
Best regards

What parts are we solving/accomplishing by implementing a configuration flow? I would guess that it would take somewhat 4-16h for me to build it and although it would be a fun summer activity I don’t see the big point in this (what’s in it for me).

As I’m quite slow in responding on integration issues and I’m the only one listed as codeowner I actually considering to withdraw the integration from HA and move it to HACS instead. This to make the main HA more stable without integrations that more or less are “abandonware”.

With integration from gui, we resolve the problem of recharge the device when home assistant reboot and the slow response from climate when HA recharge the configuration, not responding on time. Inside HA we have a service for recharge integration, but working only for integration or autodiscovery from gui, thx