History Graph component takes significant time to display

Since the latest 0.80.x versions, the history graph component takes a very long to display on my PCs (using chrome). It doesn’t even display on my macbook (using chrome). I think eventually times-out trying.

Just wondering if anyone else is seeing the same behaviour.

I am using the latest 0.80.3.

I just tried it using Windows & Chrome browser on HA V0.80.1 and it locked up my whole frontend. I had to close it out & re-open to get it working again.

I think it’s definitely broken.

None of my history graphs load since updating to 80.3.

Tried deleting the database. No change.

Mine seem to load albeit slowly…

I assume you mean 0.80.3 - if so this version fixes the history graphs.

Yeah I just dropped the redundant 0.

And it is far from fixed.

Edit 2: Actually some are loading, incredibly slowly as noted above.

I see no logs?

There is nothing relevant in the logs.

It takes more time to load, since 0.8.3

That’s an understatement. It takes for ever to load the simplest graphs. Some graphs with lots of sensors never load.

Yeah it is still definitely not right, even in 0.80.3. (I am surprised that someone is running 0.8.3, that must be ancient.)

it’s even worse in the 0.81.0b0

Out of interest, what DB are you all running? I’m just getting ready to upgrade from 0.80.1 to 0.80.3 I use the MariaDB addon as it made things faster in the past. Just wondering if this is impacting all DB types or just a subset.

1 Like

I am running the default sqlite database.

I confirm I have similar issues- history graph loads „sometimes” since the 0.80->0.80.3 update.

Cannot find anything Interesting in logs.

Using MariaDB on external host, dropping DB did not help.
Tried also the local SQLite with a new file, same negative result.

Downgrading to 0.80.1 helped.

I upgraded to 0.80.3 yesterday, advising to postpone your update.

(Used SQLite then switched to MariaDB to get the charts queries)

Issue https://github.com/home-assistant/home-assistant-polymer/issues/1829 refers please comment there

Linked topics

1 Like

For me the issue also remained in 0.80.3. Rolling back to 0.80.1 solved the issue for me so far…

Has this been fixed in 0.81.0?

Yes. (Well I hope I haven’t spoken to soon!)

1 Like