Home Assistant Add-on: ADS-B Multi-Portal Feeder (Flightradar24 and FlightAware)

I wrapped the awesome docker image from Thom-x as Home Assistant Add-On.

Just plugin some cheap ADS-B USB-Stick in and start feeding data towards Flightradar24 and FlightAware.

Works fine for me for a few days now.


  • Take a short USB-Extension if needed. Using long/cheap ones I got weird issues and errors

Any feedback is appreciated :slight_smile:



That sounds really good, but:

expected a URL @ data[‘addons_repositories’][5]. Got ‘my Home Assistant Add-on repository’

what did you enter in the dialog? The url: https://github.com/MaxWinterstein/homeassistant-addons/ ?

It should look like this:

(url is a little cropped at the end due the limited size)

My 10M USB cable will be delivered soon. I will check with it.
Have you tried using https://forum.flightradar24.com/forum/radar-forums/technical-matters-hardware/8806-3-easy-antennas-for-beginners

uh, 10 meters, pretty curious if this works :thinking:

I thought about building some antenna myself, but as my play-time is pretty limited I ended up buying some handmade from eBay (ADS-B Antenne, Mode-S Antenne für ADSB 1090 MHz. | eBay).

Hopefully it will be better than the bundled one, and maybe i will try to use some ‘window-get-through’ and place it outside.

As I live near Frankfurt International Airport the general ADS-B Coverage is pretty good already, so not sure how many nights I want to invest in optimizing it.

This is my status page. How do I know about the errors?

Just check the LOG of the Add-on:

First I have to stop the container in portanier. What is the default password of portainer? Bcz password was introduced in recent portainer update and I can’t get into it.:sleepy::sob::sob:

Just remove and reinstall portainer? then you should be able to setup a new password.

I stopped Portainer and setup your add-on. for me the steps were simple. Only CUPS (for printing) was running in portainer. If you could setup cups as add-on too it will solve it printing issue for many people.
copy sharing key from FR24 data sharing site (using laptop not available on mobile app) and paste in configuration.
Add my location latitude and longitude with 6 decimal places.
It is working partially one issue

2021-10-12 21:50:46 | [mlat][i]Stats 24/0
2021-10-12 21:50:49 | [mlat][i]No ADS-B time reference available (0/0)
2021-10-12 21:50:59 | [mlat][i]No ADS-B time reference available (0/0)
2021-10-12 21:51:06 | [feed][n]ping 2
2021-10-12 21:51:06 | [mlat][i]Pinging the server
2021-10-12 21:51:07 | [mlat][i]Stats 24/0
2021-10-12 21:51:07 | [feed][n]syncing stream result: 1
2021-10-12 21:51:09 | [mlat][i]No ADS-B time reference available (0/0)
2021-10-12 21:51:19 | [mlat][i]No ADS-B time reference available (0/0)
2021-10-12 21:51:26 | [mlat][i]Pinging the server
2021-10-12 21:51:26 | [mlat][i]Stats 24/0
2021-10-12 21:51:29 | [mlat][i]No ADS-B time reference available (0/0)
2021-10-12 21:51:36 | [feed][n]ping 3
2021-10-12 21:51:37 | [feed][n]syncing stream result: 1
2021-10-12 21:51:39 | [mlat][i]No ADS-B time reference available (0/0)
2021-10-12 21:51:46 | [mlat][i]Pinging the server
2021-10-12 21:51:46 | [mlat][i]Stats 24/0
2021-10-12 21:51:49 | [mlat][i]No ADS-B time reference available (0/0)

Edit: cups docker container can be found here Setting up local USB printer with CUPS via Portainer

@MaxW Getting this error since 2 days. core-2021.10.6 and supervisor-2021.10.4

21-10-22 15:03:54 INFO (SyncWorker_1) [supervisor.docker.interface] Cleaning addon_f1c878cb_adsb-multi-portal-feeder application

21-10-22 15:04:02 ERROR (SyncWorker_1) [supervisor.docker] Can't start addon_f1c878cb_adsb-multi-portal-feeder: 500 Server Error for http+docker://localhost/v1.41/containers/a2d56965a5fe912d4224e1ab395ce7387297c16710b59e141fdd20ea6f4f220a/start: Internal Server Error ("driver failed programming external connectivity on endpoint addon_f1c878cb_adsb-multi-portal-feeder (f937fe3e711c2a76bf97f6d604720f5fc53d60d4a85698c32df5989fb4fc73ae): Bind for failed: port is already allocated")

Is anyone else having the same issue?

1 Like


Seems like your device is not accessible.

what can be the reason? I have tried different ports, restarted the raspberry Pi 4 no luck.
Check rtl-sdr stick on a windows pc, was working fine, both for listening to radio and tracking a/c.
what fixed it for me, removed the SD-card, booted of a flash drive using raspbian bulleyes OS.
updated it

sudo apt update
sudo apt full-upgrade

booted again with Homeassistant sd card and boom everything is working fine again.

How to obtain FlightRadar24 ID. Is it possible to obtain it without docker?

@MaxW is it possible to link the position to the position of home assistant?
i am using it in a motorhome and the location i changing contantly.
I was looking for the configuration yaml file via samba share, but i could not find it.

ModeSBeast is not supported. I tried a SDR USB Stick, this works perfectly!

Is there a chance to update the JSON file with the LON/LAT of the HA Home?
As i have that thing installed in a Motorhome, my position changes regularly.
The source could be HA Home position or directly by modbus (there is an automation to update HOME position every 15min)

Technically possible I guess, but needs some coding to do the job. I guess there should be some API call available to get the location.

Veeeery low on my todo, but might have a look at some time.


@MaxW nice job on the Home Assistant Add-on thanks for the great work. Easy to install and configure :smiley:

I sent Flightradar24 an email at [email protected] and asked them for a sharing key which they sent me about 5hrs later :smiley:

Make sure you include your coordinates in the email and you should be good to go.