Homeassistent not be found on port 8123

Dear all.

I have finally managed to install homeassistent in a virtualbox VM.
The machine does start up and a lot of text is passing by.
After a while the screen comes black and askes for a home assistant login.
At that time I start up a browser (IE,Edge or Chrome) and type in :


This address is not reachable.

I’ve tried almost everything:
http://homeassistent(with and without .local):8123
even the IP-address from the VirtualBox-Host-only Network (

What can be the problem ??

Please please please help me ?

1 Like

You mentioned “host-only”?
that normally means what it says…a network shared with host only…

you’ll want Bridge mode…

(more info about network modes here)

Strange that it says “host only” because while installing (exactly as mentioned on the pages here)
I choose “bridge mode”.
What do you think I can do to solve this ?

Change to bridge mode


And no need to specify an IP; it should pick up an IP number from your DHCP server on your LAN network (normally your ISP router).
After that it is advisable to change that IP into an IP lease reservation, so it will always get the same IP :wink:


First, thanks for all your help and thinking with me.

This is how it’s setup now.
Strange is that the bridged adapter is my own network card (Realtek is the real network card in my compluter) and not the virtual network card.

Can I change this ?

Hallo Maarten,

The virtual network adaptor should be bridged to your real network card.
Also, on your real network card’s propertied, you should have the following item enabled:

If I remember correctly this adapter should be the right one. Where do you have the “VirtualBox-Host-only Network (” from? Did you look into your router if it appears there?

Hi Aceindy

This is exactly how it’s installed on my PC.
But what I can see (in your picture) is that Adapter 2 is also highlighted.
Do I have to use a second adapter?

Hi Syntox.

I don’t know where it’s coming from ? maybe since installing Virtual box ???
Do I have to portforward anything in my router , although I don’t go to my virtual server from outside.
I go to my virtual box server in a browser on the same computer as where the VM is working.

Hi Maarten,

I took a screenshot from another VBox; in that one I use 2 network cards…but it is not related to HA
So to answer your question…no…you use only one network adapter in bridgemode.

(actually, my HA runs in HyperV :stuck_out_tongue: )

If the network adapter is in bridge mode, it should get an IP in the same range as the rest of your network. You should be able to check which IP it got when logging in to your router and look up the MAC address from VBox

Hi Aceindy.

I got the Virtualbox NDIS6 Bridged Network driver installed.


I see that I have also a VMware bridge Protocol.
Can this be the issue that it’s going wrong?

Hallo Maarten,

Not sure if VMWare and VirtualBox bite each other…
For sure VMware and HyperV do bite each other…they cannot be run simultaneously.

Maybe it is enough to tick of ‘VMware Bridge protocol’, but I recommend to use just one and uninstall the other…

Uuuhhhmmmmm …

Now I’m getting confused.
What you tell me here ? is this for de static network adapter in the pc ? or for the virtual Vbox adapter ?
Because the static (real) adapter has as IP (so in my network range)
The “VB host only” adapter has as IP

  1. Sure the VirtualBox-Host-only Network Adapter comes from installing V-Box. Where did you read the IP from?
  2. If you only want to use and reach it in your local network you have to port forward nothing.
  3. The data should go from your VM to your PC’s Adaper, to your router, back to your PC’s adapter and to your browser. That’s why I asked if your VM connects to the router (the router assigns a IP to the VM) But I think the problem should be in V-Box as it doesn’t choose the right Adapter. For me the Adapter on the main page looks like this:

This sentence doesn’t make sense…the Vbox itself doesn’t get an IP, the virtual machine (HA) should get an IP.

You virtual network adapter only has a MAC address. When in bridge mode, the virtual machine (HA) will obtain an IP address from your dhcp server (which normally is on your router) using this MAC address.
Meaning, you should be able to check on your router which IP has been given to the HA’s MAC :wink:
So I have the same question as Syntox…
where do you get from???:thinking:

Hi all.

The situation is as below :

The Ethernet adapter has is own static IP address : 192-168-1-200
The VirtualBox Host-Only Network has static IP address : 192-168-56-1
Where this address is coming from I don’t know (I didn’'t set this up)

I changed the IP of VirtualBox Host-Only Network address into 192-168-1-199 and after done this when I go to home assistant in my browser I get the message that the connection is refused.

Dear Helpers on this forum.

I found the problem !!!

I looked in my router and found out that the IP address of my Home Assistent is
When I type this address (:8123) in my browser the Home Assistant is working.

Owwwwwhhhhh I feel so fine now.

Thank you all for your superb help in this.

I will never forget your help and patience.

Love you all !!

That’s why we asked. In this case you can fully ignore the VirtualBox Host-Only Network adapter as you are bridging your Ethernet adapter and don’t use the other one at all. Glad it works now