HomeBridge "Please wait while this integration is being setup"

Merry Christmas HA community!

New to HA. My original install was using Docker for both HA and one for Homebridge. However, I realized after the installation that I did not have all the features with using HA in a container, so I reinstalled (from scratch) using the hypervisor method. I currently have a VM on Proxmox for HA. I then have Homebridge running on another VM. However, I have also tried HomeBridge deployment in a Docker container (deployed using Portainer). Both instances are giving me this same problem.

We are getting a “Please wait while the integration is being setup” which just spins and spins.

Any ideas? I did find another thread which didn’t help much as i tried all methods proposed. (HACS installing problem via integration "error: Config flow could not be loaded" - #4 by justahuman33)

Thanks in advance!

Have you tried the HomeKit controller integration using bridge mode? You probably don’t need a separate container running homebridge since HA can do it for you.

@moto2000 I’m not quite sure I follow. Are you saying HomeKit should work natively? I’m trying to to do the Nest integration using HomeBridge (at least from the tutorials I’ve followed).

I have Nest integration completed within HomeBridge. When I did this using Portainer for both HA and HomeBridge, it worked fine. Just attempting with the VM version directly causing this issue. I’m sure it’s something simple, just not experienced enough (yet) with HA.

Do you see any errors in HA under Config–>log ?
I am assuming your VMs can see each others but to just check open HA terminal and ping
the homebridge vm

Also i am assuming you recycled everything via hard boot if not then try it

Hi @ALDIY . In checking the logs, I see this which happened about the same time as my last attempt.

Logger: homeassistant
Source: runner.py:98
First occurred: 3:22:54 PM (2 occurrences)
Last logged: 7:24:16 PM

Error doing job: Unclosed connection

I’m not 100% that is related, but it’s the only error I see in the log.

Edit: I have rebooted. I’ve also reinstalled both HomeBridge and HA during the troubleshooting process.

hI ,

did you ping homebridge from within HA terminal ?

Yes - I just pinged, success on that front.

is it possible to clear the log in HA and only restart homebridge and try again to add the integration in HA? see if the log has any new info .

Yes, will do that now and report back. Willing to try anything at this point. Several hours spent. While new to HA – not new to Linux, VM’s and the like. From what I’ve read, it looks to be quite a bit of trial and error on some fronts.

yes that is correct , it is a trial an error , that is why I have removed homebridge from my setup .
But I think your VMs are the issue here but do not give up .

I agree. When using Docker for both HomeBridge and HA I had no issue. However, I’m running a reverse proxy and couldn’t figure out the configuration.yaml on the docker version (couldn’t locate the file, but gave up quickly once I saw the lack of ability of the Docker version).

I also don’t give up easily. Appreciate the help as well!

Do you have to have your setup on VMs ? is a pi not an option ?

I could spin up another Pi. Don’t have any online that I’m not using in a production setting. I have a host (oldbear) that I run several VM’s on. Here is that setup as well as the stack configuration for the HomeBridge docker container.

VM on Proxmox = HA (
Docker Container = HomeBridge (

From HW point of view , your setup is great .However I think this add another layer of complexity which goes beyond HA . I had a friend who faced same issues using VMs and we could not solve it but I hope you can .

@ALDIY I just received this in the error log. Not giving me much information.

Logger: homeassistant
Source: runner.py:98
First occurred: 7:57:18 PM (1 occurrences)
Last logged: 7:57:18 PM

Error doing job: Unclosed connection

Could this be vmware issue and best we look to vmware support ?

for the error look at this

Edit :smile:
In the logger make it on debug , this way we can get a lot of info that might help

Well, I just spun up another container (Docker) with HA and was able to get HomeBridge connected instantly. So, it’s definitely an issue with Proxmox VM and the HomeBridge Docker container. Not sure where the problem exist. I’ll continue to play with it as I wanted to be able to utilize the full OS of HA.

You must make it work on VM . I think its a challenge but I have a felling you can do it

I’ll continue to prod and will report back.

EDIT: @ALDIY @moto2000

Sorry for the slow response. It’s not letting me create new posts because I’m still the “new guy”.

I’m not sure how to run Homebridge within HA instead of using the separate container. But I’ll do some research and see if I can wrap my head around it.

Check the first paragraph and tell me what do you actually want to do . It could be the case that you do not need a separate homebridge host