How to install HA on QNAP

I have a 671. The trouble with using a VM on it with Virtualization Station is you can’t easily get USB devices into the VM. Their Container Station was… not something I found comfortable to setup/use. The 671 is, at least, an Intel-based system, unlike some of the others.

Right now I have my initial attemp at using HA on a VM running on a separate Linux box. I can pass USB directly into it, but have not as yet made the effort as little of my automation requires a USB dongle. If/when I decide to make more use of HA my plan is to be ready to move it onto it’s own hardware, to avoid any virtualization headaches. The resource demands are pretty light for an automation controller. Any old refurbed ‘tiny pc’ would handle it easily. IBM/Lenovo’s Tiny series are good for this, especially if you run them with SSDs and no spinning disks. That or a fanless mini-pc.

So while I could run it on the QNAP… I don’t.

I am brand new to HA, I haven’t even installed it yet. But my plan is to set up a virtual machine on my QNAP server and run HA on there. If I need to connect a USB device down the road, am I able to set up a Raspberry Pi with HA to run the USB Devices? Can the Raspberry Pi talk to the main Home Assistant Server on my QNAP?

I am running supervisor on a TS453D with virtualization station and so far so good. Started with Container Station but prefer the totally integrated package so went this route instead. I even have my backup/testbed install running so anything sketchy I do it on my test setup and then move it over to my main system. Base hard drive size on the initial install was only 6GB so this filled up quickly - its worth increasing this right out of the gate - I had to do it later on and Virtualization Station made me delete all the snapshots I did before I could increase the hard drive space. I have 16GB ram upgrade coming as the 4 I currently have is not enough. I flip between 1 and 2 cores assigned to the machine depending on what I am doing. 1 core with 2gb ram is my baseline setting and seems to run ok. Most of the time the system is not over resourced but this is very lightweight hardware for how much it costs.My next step is USB stick for zigbee/zwave, hopefully that goes ok. Will report back when I get one if if I was able to get it running (Virtualization Station does state that there is USB support so hopefully no issues. I am noob linux guy.
my nas box is for corporate file backup but also run HA and plex media server and this seems to work ok.

I have been running my HA on an ubuntu server 18.0.4 with out any problems. I use the Husbzb zigbee/zwave stick to connect my xiaomi sensors. I noticed that during the automatic backups of the VM the usb device is getting disconnected and will not reconnect, I have to manually reconnect the device. I put in a ticket with qnap but so far no resolution. I recently upgrade my vm to version 20 and now I am getting a message - “You are running an unsupported version, HA needs to run in supervised mode”. Several forums are recommending either debian or docker. I am in the process of testing a docker install. I will post my steps and findings. If you already have HA make sure you use the google upload tool to save your backups to the google drive, if you want to migrate. Below are the screen shots of the errors

So have you managed to get the USB stick for zigbee/zwave going?
Also would be great to know which stick you would be using.

And just to compare notes:
I have also got the 16GB (+4GB existing) upgrade on my 253D, for total of 20GB. My HassOS VM baseline is 2 cores w/ 1GB.

Haven’t done a zigbee zway stick yet and not sure if this is possible to do with some sort of box external to the NAS. May have problems running my daily snapshot of the VM with the USB stick inserted - just saw a post somewhere about someone having issues with this on their synology.

upgrade to 16GB ram from 4gb was phenomenal - made a huge difference in performance of my nas. highly recommended upgrade.

I went the hassio ova way in the end and it runs much smoother than container (nas fan does not spin as much) also ended up choosing a external hooked up via switch zigbee/zwave hub.

Now that’s interesting. By “zigbee/zwave hub” do you mean something like SmartThings or Hubatat or Fibaro Home Center?

yes and it does not interfere with snapshots I am only a month into home assistant as I have been tasked in writing an article on smart home tech and systems that run it. Also might be worth looking into a tuya all in one now too though as the newer ones have a jumper pin to be run only local.

One thing a month in to home assistant (home assistant is taking long because I have ran it on a pie, a cheap nas via container, qnap via container, qnap via a app and now onto virtualization station. I have learned about home assistant is that it will pretty much through the qnap pick up anything zigbee/z wave device wise thats on the same network, eliminating the need for a direct input. I have tried the container way (on two different nas devices) and found that the qnap does not detect well or play nice through the container.

For example my ring cam would not show a feed on container on my qnap, but would on the cheapo terramaster through container, but all other items were fine on qnap, but I had to add a lot manually even with discovery added to the config. It also felt a bit slow on restarts and caused the fan to spin up on qnap on restart.

I even tried installing via the apache80/dedicated app way via qnapclub (which actually gives you a home assistant app in qnap) but that was pretty much the same and slow restarts and fan spinning up.

But set up through virtualisation station was the smoothest experience, I also got access to supervisor which meant I did not have to keep logging in via sftp to make config changes and It detected everything on boot, fan has not spun up once, google drive snap shots restore fine with no errors, unlike with the zwave stick method and the zwave zigbee hub is always there.

Still not finished on HA yet though as I will have to delete everything again soon as I move onto the mini pc installation to cover all bases for article lol…

Similar experience here, going through multiple install style. If your qnap (or any PC box, really) can do VM, that’s probably the smoothest IMHO.

So which hub are you using (or testing) for z-wave / zigbee, and how do you introduce those z devices into HA??

Sidenote: when your article is done do share with the forum.

i have a TS-251+ running Virtualisation station with supervized HA. i’m trying to connect a cc2531 USB dongle but so far i cannot connect to it.
so far i’ve tried this but do not get the two new devices: /dev/ttyUSB0 and /dev/ttyUSB1 to show up in Putty when i type this: ls -al /dev/ttyUSB.

i do get: crw------- 1 admin administrators 166, 0 2021-08-22 17:18 ttyACM0 but when i type:
serial:
port: /dev/ttyACM0
in the config of the zigbee 2mqtt i get loads of errors.

does anyone have any suggestions?
many thanks

2 Likes

Blockquote So which hub are you using (or testing) for z-wave / zigbee, and how do you introduce those z devices into HA??

Using the rebranded smarthings one, but I might switch to one of the new tuya ones soon (ones with the internal jumper to use local only) its pretty much like importing the hue stuff if using a hue hub. I will share it when done, lets just say from someone with one echo device and a few bulbs Its been an experiance. I started off with using just amazon eco system as a test, then moved onto smarthings with sharptools and then onto home assistant on two different NAS a cheap terramaster and and my pricey qnap on container and then on qnap on virtualisation station as well as a Pi, the next install is on a pico dedicated PC with 4gb and 32gb storage.

have learned a bit in this time, although my fav automation is the blinds auto closing at sunset and only opening at sunrise when a button is pressed, I also like the fact

I have worked out a way to have a fake switch in home assistant that gets detected by alexa as a contact sensor (done via smarthings) which means I can create switches to turn on alex only devices too.

I found it easier and more reliable than a bootlean command and the aws (I am just stating this as I am trying to make it easy for people to follow in article)

also adding the rm4 pro was a good idea too as that has enabled me to have a button that when I hit it turns on my soundbar and sub and alexa gets the command to pair if she is playing from music in the same room and auto switches over, also via this same rm4 it enables me to say alexa set theater mode which powers the switch and then switches sound bar from bluetooth to optical and then sets hue sync box to sync with whole living room lighting so whole room follows movie… (normal is just back of the tv.) with no sound bar…

I also have a robot hoover that is alexa only and not integrated and using the same switch method, made a switch that when a automation uses it, it starts my robot vacuum and of makes it return home to charger, yes no battery monitor or map, but yes it can start and stop it at what times I want.

I am loving this whole experience but its defo a rabbit hole I am waiting on my light switches to arrive (replacing the whole house with non dumb ones) 6 door sensors, and 6 temp sensors and also have drayton heating system to put in (thermostat and rad thermostats).

not loads really but getting there.

So An update on this for you, to be more extensive in testing I took the plunge and invested in a conbee 2 and tried it on both the qnap (under VM) and zotac pico install installed flawlessly and had no issues with the backup either. Remember I am still a noob and did not have no luck with the conbee through the zerocon, but did in the ZHA intergration

1 Like

Yep I’m off to do this now! Got it set up on Docker fine but then realised lots of missing functionality so going to redo it via virtualisation instead, otherwise no add-ons available and I’m wanting mqtt and Node Red!

EDIT: so in fairness really easy once I found that the OVA VM file is directly recognised by QNAP. I just downloaded it from Alternative - Home Assistant and then picked ‘import VM’ from Virtualisation Station, allocated 2 CPU and 2 GB RAM and then when I started it I was then able to browse to it and get HA up and running. Just as easy as a Docker container and now I’ve got the supervised version of HA installed :+1:

1 Like

defo the best way to do it, although in all fairness, I am now running on the dedicated os on a pico pc lol, (but its only because I am testing all different methods out for article).

1 Like

Leaving some reference points for users coming to this thread in the future:
I have a 453D, with HAOS in VM, and using the sonoff zigbee dongle

  1. Plug your dongle to one of those USB 2.0 ports, extension cable is recommended
  2. Open your Virtualization Station, and click the USB icon of your HA VM
    image
  3. Check the checkbox and click OK
    image
  4. And that’s it, you should be able to find your USB dongle ID / device path under ConfigurationAddon, Backup and Supervisor
    image
    … and then SystemHost → (3-dot menu) → Hardware
  5. And then I use that device path for zigbee2mqtt add-on.

== also / edits / other observations ==

  • (At least for me) for those steps above you don’t need to restart or reboot, or install any driver on QNAP nor on HAOS.
  • Tested: You can do manual or scheduled VM snapshots in your Virtualization Station… zigbee dongle will get disconnected for snapshot, but will come back automatically.
  • Tested: The dongle would still be there when you restart your HAOS. I went through multiple HAOS reboots, and have not (yet) seen any USB0 USB1 swap issue
  • If you reboot your QNAP, you might have to do step #3 again to re-introduce the dongle to the VM. I have rebooted my QNAP twice since - the first time I had to re-introduce the dongle; the 2nd time the dongle was still available in the VM and I didn’t have to do anything special.
  • Did a version update on the qnap Virtualization Station app. Had to power down all my VM, and then perform the app update. After the update, qnap would automatically start the Virtualization Station app, and subsequently VS would start the VM per your VM setup automatically also. Good news: the USB dongle is still there, available in the HAOS, after all this.
  • One month in. I have not (yet!) experienced any USB dongle dropping out unexpectedly…

how do you enable supervisor?

Based on your installation type, you can’t.

Either switch to VM install method, if you want supervisor. Or forget about the supervisor and install / manage whatever other containers you see fit, via QNAP’s Container Station.

Thanks. Is there a guide to install from Virtualisation station?

This thread (scroll up, see discussions around VM from around… Nov 2020)
And this other thread.