How to install Hassio specific version (includes downgrade)

Use the following code:

hassio homeassistant update --options "version=0.69.1"

Credits to @c727


Should this work in CLI for HassOS?

I get:
hassio > homeassistant update --options “version=0.76.2”


extra keys not allowed @ data['"version']. Got '0.76.2"'

to answer my own question…success with

homeassistant update --options version=0.76.2

so no quotes needed around version

1 Like

The quotes just mean put the version you want there :slight_smile:

tried this and I get ok but nothing happens. What am I doing wrong?

homeassistant update --options version=0.81.3

Probably because there isn’t an 81.3 :slight_smile:

This worked perfectly for me yesterday…

hassio ha update -o version=0.81.2

It’s the same, just the shorthand version.

1 Like

In my case i’ve to use

hassio ha update --version=0.84.6


Trying to downgrade here to 0.87 using
ha update --version=0.87
I get this as a result

If I look at the errors it shows this

Sorry I’m unable to copy and paste the terminal text as this is directly through the VM, had to do it with images.

If i start HA again I’m still on 0.88.1

Try including the full version number:

ha update --version=0.87.0

1 Like

Same result! I tried also with 0.87.1 and 0.88.0

current commands are:

hassio homeassistant update --version=0.92.2

Is this possible with PIP ?

not that I know of. Need to ssh into the docker container for hassio or ssh into hassos, whichever you use.

1 Like

hassio homeassistant update --version=0.99.0

Works on raspberry pi4 with hassio. The .100.2 update broke my google assistant link so no more voice control without subscribing to Nabu Casa.

Note, you have to add “.0” to make it work for the 0.99 downgrade.

EDIT: Turns out reverting did not fix my google assistant issue. Voice controls are broken for me, since I did the 100.2 update. Must be something not related to the update?

Just i case anyone reads this now, note the command homeassistant is now replaced with core

In the SSH prompt you will now use the following command:

ha core update

This works quite happily just in the SSH plugin via the webui window also.
The change in command represents the naming changes made by the Home Assistant team to differentiate full Home Assistant (previously and the core install, Home Assistant Core



trying to downgrade with

pi@raspberrypi:~ $ ha core update --version=0.114.4

and get

Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Get http://%2Fvar%2Frun%2Fdocker.sock/v1.40/containers/hassio_cli/json: dial unix /var/run/docker.sock: connect: permission denied

I am on PRI4 with docker

You can’t do it at the system level. It is a specific command for inside the Home Assistant container, not on your host system
You need to be inside the Home Assistant container at the ha> prompt

i can, just need to use

	sudo ha core update --version=0.114.4

So to downgrade to core 2021.9.5 I should be able to simply use

ha core update --version=2021.9.5 from the SSH plugin window?

I’m running Home Assistant on Oracle’s VirtualBox as a VM