I made a crappy Nest Thermostat integration that will work as a stopgap until alternatives come out

I strange. I’m using the Araines fork. All works. But after some hours it complains about login not valid. I do the login again and change the config with the new values. It work but only some hours.

Someone knows why my login goes invalid after some hours?

It happen to me also, using araines fork, all working well until couple hours later. If I restart HA it will work again until couple hours later. I tried going through the issue_token and cookie setup procedure, again it will last for couple hours.

I tried a different fork without luck. Same result. This only happens to us? For the rest of people is working ok?

mine stopped yesterday, and I have been unable to get it back up and running, the smoke detectors are also showing unavailable.

Same story. I’m not getting any errors, but the sensors are only available for an hour or so after a server restart. I’m using the issue_token/cookie method in my configuration file.

It’s been mentioned earlier in this thread but I would strongly recommend using GitHub - chrisjshull/homebridge-nest: Nest plugin for HomeBridge to bring the Nest data into Homekit (I use a HOOBS docker container) and then use Homekit controller integration to bring the Nest into home assistant. I made this change 6 months ago and have not had to touch my token/cookie data since. With badnest I was having to re-auth every month or 2.

Notes: You do NOT need any Apple products to use this, you are emulating a homekit bridge and bringing in the data from there.
There is one small bug in the Homekit integration with 2021.6 that brought a “.9” decimal point to Fahrenheit temperatures that is being fixed in 2021.7

Exactly, I don’t get the stubbornness with badnest, just let it die already. :rofl:

Just install HOOBS:

$ sudo docker pull hoobs/hoobs
$ sudo docker run -d -p 8080:8080 --name hoobs --restart always -v /var/run/docker.sock:/var/run/docker.sock -v hoobs_data:/data hoobs/hoobs:latest

If port 8080 is occupied by something already (like Unifi), just change the port in the command above and then access terminal of HOOBS container (e.g. via Portainer), modify the port in /hoobs/etc/config.json and restart container.

Then register/login to HOOBS via webinterface (IP of a host where you installed HOOBS and configured port), install Nest plugin(currently 4.5.3) via plugin section, configure it basically like badnest and you are done.

Then you only need to add HomeKit controller via Integrations in HA, if it wasn’t discovered already.

Thanks! I’ll look into it. I’m running Hassio on a Pi, do I start with the Portainer plugin and take it from there? I don’t have any experience with dockers or containers.

Seeing the same here as well.

It seems to me that it does not have an addon/custom-component for Home Assistant? So if we are at Home Assistant OS it seems we can’t use it in this way, right?

Thanks!

You can use the homebridge addon. Hoobs is the same thing with a fancy GUI added, but homebridge has added there own GUI so not much difference now.

1 Like

What’s the preferred fork these days? GitHub - araines/badnest: A bad Nest integration that uses the web api to work after Works with Nest was shut down. ?

I would switch to the new official integration but I have Protect devices which aren’t supported I think. Although the thermostat is important to me rather than the protects I admit.

It seems deprecated and I can’t find the hombridge addon in the repository. Maybe it was removed some time ago :frowning:

The homebridge addon appeared for me in my notifications as a new device found, without me doing anything? I installed it, and now have a QR code in my notifications for pairing it, and I dont know what to do next? As I am not an apple user (my wife is)

Sorry about that, didn’t realize it was deprecated.
You will have to install the Portainer addon, that will allow you to add any docker container you want.
I found a guide here for homebridge: Tutorial: add Homebridge to Hass.io using Portainer

1 Like

Thanks! I followed that guide and I have everything up and running again :+1:.

Thank you koconut !
I finally ditched the badnest and use the Portainer addon + follow the tutorial thread you quoted. Deployed the docker-compose onzu/homebridge:latest, and added The HomeBridge Nest Cam v7.4.0 plugin. since it uses the new google refreshToken instead of the issueToken, it’s 1000x easier and better. now my Nest Hello camera is finally staying up !

For what reason is the token better? Is it faster? Only downside right now: temperature readings are every half degree (*.5). With Badnest a reading of 22.3 was also possible. Does anyone know if this is also possible with the Homebridge Nest plugin?

Think of refreshToken as a long lived token, set-it-and-forget-it type. Less hassle is always better for me =)

1 Like

I think I’ve missed something… I’ve added the plugin in portainer (thanks @koconut for the link), I’ve added the Nest plugin with the issueToken and the cookie… my Home Assistant detected and added the Homebridge integration… but I don’t see anything of the Nest device.

I’m sure it must be some stupid thing that I don’t see…