Community Add-on: Homebridge

This add-on is provided by the Community Add-ons project.

GitHub Release GitLab CI Project Stage Project Maintenance

Supports armhf Architecture Supports aarch64 Architecture Supports amd64 Architecture Supports i386 Architecture


Homebridge is a server that emulates the iOS HomeKit API, allowing you to control your Home Assistant via Apple devices (including Siri).

Since Siri supports devices added through HomeKit, this means that with Homebridge you can ask Siri to control devices that don’t have any support for HomeKit at all. For instance, you could say:

  • Siri, unlock the back door.
  • Siri, open the garage door.
  • Siri, turn on the coffee maker.
  • Siri, turn on the living room lights.
  • Siri, good morning!

:warning: Deprecation warning

At this point, it is unsure how long this add-on keeps being available or updated.

This add-on was originally developed to add HomeKit support to Home Assistant. Meanwhile, Home Assistant gained native support for HomeKit.

Because of this, it is very likely that the plugins this add-on rely on, will no longer be developed or maintained.

We STRONGLY suggest to migrate to the Home Assistant HomeKit component.


The installation of this add-on is pretty straightforward and not different in comparison to installing any other add-on.

  1. Add our add-ons repository to your instance.
    Add the following URL:
  2. Install the “Homebridge” add-on.
  3. Start the “Homebridge” add-on.
  4. Check the logs of the “Homebridge” add-on to see if everything went well
    moreover, to find the pin code needed to add your Home Assistant instance to
    your iOS device

:books: Please read the documentation for more information about the use and configuration of this add-on.


You can always get support here at the Home Assistant community forums, join the conversation!

You have several options to get them answered:

You could also open an issue on GitHub, in case you ran into a bug, or maybe you have an idea on improving the addon:

We will do our best to help you out!

Repository on GitHub

Looking for more add-ons?

The primary goal of our add-ons project is to provide you (as an Hassio / Home Assistant user) with additional, high quality, add-ons that allow you to take your automated home to the next level.

Check out some of our other add-ons in our Community Add-ons project.


About the author of this add-on

Hi there!

I am Franck Nijhof, and I have 30 years of programming experience, in many languages. I am using this experience to work on the Home Assistant project by giving back my knowledge and time to the open source community.

The add-on you are currently looking at right now was developed/packaged by me. It is not the only add-on I have created; there are many many more :wink:

However, I have a problem… I am an addict. A :coffee: addict that is. Lucky for you, I turn that C8H10N4O2 (caffeine molecule) into code (and add-ons)!

If you want to show your appreciation, consider supporting me for buying a cup of high octane wakey juice via one of the platforms below! :heart:

Sponsor Frenck via GitHub Sponsors

Support Frenck on Patreon

Enjoy your add-on, while I enjoy the brain juice. :coffee:

Thanks for all the :two_hearts:


Join our Discord server Follow me on Twitter Flollow me on Instragram Follow me on GitHub Follow me on YouTube Follow me on Twitch patreon-icon

P.S.: In case you want to ask me a question: AMA (Ask Me Anything). Most of the time I am online at the Discord chat. (I go by @Frenck in there as well).

Sorry, posted on the wrong pool:

Hello guys!

Just a heads up: new version arrived:



Thanks for the update Schneider!
I’m currently in the process of creating a new add-on release as well (which fixes a Homebridge plugins issue).

Will report in as soon as it is released.


Good to know, suffered by this (most probably)…

:tada: Add-on: Homebridge v1.0.2

Full Changelog


  • Updated homebridge-homeassistant to version v2.3.0
  • Changed repository file structure
  • Changed/simplified build scripts
  • Updated the documentation to match recent changes


  • There was an error when installed the plugin #6

This update is now available via your Hassio panel.


Just updated and got this (no other plugins installed yet and plain vanilla config.json)

    starting version 3.2.2
    [ADD-ON] Ensuring old PID files are absent
    [ADD-ON] Ensuring D-Bus unique ID exists
    [ADD-ON] Starting D-Bus daemon
    [ADD-ON] Starting Avahi daemon
    Found user 'avahi' (UID 86) and group 'avahi' (GID 86).
    Successfully dropped root privileges.
    avahi-daemon 0.6.32 starting up.
    WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
    Successfully called chroot().
    Successfully dropped remaining capabilities.
    Loading service file /services/sftp-ssh.service.
    Loading service file /services/ssh.service.
    *** WARNING: Detected another IPv4 mDNS stack running on this host. This makes mDNS unreliable and is thus not recommended. ***
    Joining mDNS multicast group on interface docker0.IPv4 with address
    New relevant interface docker0.IPv4 for mDNS.
    Joining mDNS multicast group on interface eth0.IPv4 with address
    New relevant interface eth0.IPv4 for mDNS.
    Network interface enumeration completed.
    Registering new address record for fe80::24c5:e8ff:feab:30f6 on vethda155f2.*.
    Registering new address record for fe80::5835:7dff:fe50:6cf5 on veth9228230.*.
    Registering new address record for fe80::7033:93ff:fee3:1c5d on vethac8a5a2.*.
    Registering new address record for fe80::42:b7ff:fe71:db93 on docker0.*.
    Registering new address record for on docker0.IPv4.
    Registering new address record for fe80::1d9a:ebd5:97bf:40a7 on eth0.*.
    Registering new address record for on eth0.IPv4.
    Server startup complete. Host name is hassio.local. Local service cookie is 2943143647.
    [ADD-ON] Applying HAP NodeJS IPV6 HOTFIX
    patching file /usr/lib/node_modules/homebridge/node_modules/hap-nodejs/lib/util/eventedhttp.js
    [ADD-ON] Starting Homebridge
    / line 339:    25 Segmentation fault      (core dumped) homebridge -U /config/homebridge

@hblaschka Sorry to hear you have some problems with using the add-on.
I’m not sure what could go wrong here. Segmentation faults are pretty hard to debug.

What platform do you use? Rapberry Pi? Generic Linux install?

Latest Pi, which will not reboot now (was just trying to do that several times).

Had another Segmentation fault with your Web-Shell the night before - might therefore also be a non-SW-related thing.

Will hopefully find the time during next week to do some more analysis.

It is a playing machine trying to use HASS to interface with my commercial HA-Gateway in order to implement some missing functions (Presence, Sonos-Audio-Messages, Homekit) - so no hard feelings :wink:


It definitely could be a hardware thing. I’m testing the add-ons on a Pi 3 before releasing (since I figured out it will probably the most used device).

You could try building an add-on locally, by adding the add-on repository as a repository in your Hassio. One warning tho, building the Homebridge add-on cloud take up to 30 min.

I’ve just encountered an issue with the homebridge addon. Suddenly none of my devices showed up in Homekit anymore.

While checking the logs of the homebridge addon I found a line regarding the default device visibility. I’ve fixed the issue by adding

"default_visibility": "visible"

to the platform section in config.json:

"platforms": [
  "platform": "HomeAssistant",
  "name": "HomeAssistant",
  "host": "",
  "password": "",
  "default_visibility": "visible",
  "supported_types": [

Now the addon works fine again.

Has this visibility option just been introduced or why didn’t I encounter that problem before?


Seems that this has changed in the latest release of the homebridge-homeassistant plugin (which is included in this release).

You need to specify the default_visibility apparently.
I may need to modify the default template of the plugin in that case.

Maybe @Schneider or @schmittx can give a definitive answer on this?

1 Like

@SFAB @frenck You’re correct. You’ll need to specify default_visibility in the config with the latest release of homebridge-homeassistant.

If not specified, default_visibility will be set to hidden currently. However, I’ve submitted a PR which will set to visible if not specified (to mirror the old behavior).

My apologies for not making this new change more clear.


Hello @frenck!

I’m glad you mentioned me! I’m really sorry but I am still learning the basics on Home Assistant language and syntaxes. I’m not a programmer or very advanced user!

I would love to help you guys with but I lack the knowledge, sorry :frowning:

Thank you all for your efforts!

Since the log file included that advice directly it wasn’t that big of a problem to figure out the solution.

However, I think making visible the default would be a good decision.

:tada: Add-on: Homebridge v1.0.3

Full Changelog


  • Adds ‘default_visbility’ flag to the default configuration of Homebridge #2

This update is now available in your panel.


This release does not fix the configuration for existing users. If you upgrade and loose all your devices in HomeKit, then please add the default_visibility flag to your configuration. For more details read this post by @SFAB


Seems to have been an issue with the SD-card (probably too much R/W). Up and running again :wink:

1 Like

FYI, Homebridge-HomeAssistant has been updated to 2.3.1 which includes the patch for default_visibility not specified in config.

Hi, thx for the work.

I migrate my AIO installation to Hass.IO. Everything works fine.
Today I installed and setup Homebridge with the Community Repo.

Now I have a problem.
If I turn on a switch in the Homeassistant UI the Status did not change in homekit.
If I turn on a switch in homekit the status changed in the HA just fine.

After restarting Homebridge, I get one single update of all states.

What can cause this issue. I have no problems with AIO installer and manuell Homebridge installation.
I made an

my config.yaml

  "bridge": {
    "name": "Home Assistant",
    "username": "XX:XX:XX:XX:XX:XX",
    "port": 51826,
    "pin": "853-81-325"
  "description": "Homebridge for Home Assistant",
  "accessories": [],
  "platforms": [
      "platform": "HomeAssistant",
      "name": "HomeAssistant",
      "host": "",
      "password": "XXXXX",
      "verify_ssl": false,
      "default_visibility": "visible",
      "supported_types": [
      "logging": true
1 Like

Hello @kolossboss!

I am also facing this behavior. Is it like this?

It only works when I set my host to the public DNS domain…


1 Like