Issue Arming Alarm since most recent update with envisalink

Since the Most recent update when I try to alarm my code using the envisalink configuration I get the following error:

Failed to call service alarm_control_panel/alarm_arm_home. Validation error: Arming requires a code but none was given for alarm_control_panel.home_alarm

However the code is in my configuration just like the example Envisalink - Home Assistant

If I take the code out of the configuration I get the alarm pad in the GUI which allows me to type in the code. Typing in the exact code as in the configuration item previously does properly set the alarm.

I think something got messed up when using a preconfigured alarm code in your configuration but not exactly sure.

Here is my configuration:

host: !secret envisalink_ip 
  panel_type: DSC
  user_name: !secret envisalink_user 
  password: !secret envisalink_password 
  code: !secret alarm_code 
  port: 4025
  evl_version: 4
  keepalive_interval: 60
  zonedump_interval: 30
1 Like

If I go into Developer tools and manually set up this service with the following this works, but it still doesn’t fix my entities on my homescreen

service: alarm_control_panel.alarm_arm_home
data:
  entity_id: alarm_control_panel.home_alarm
  code: <CODE>

It turns out I was using the “rc” tag rather than “stable” I think this was due to some zwave issues years ago and I forgot to change it back. Rolling back to Stable fixed this issue for now.

I wonder if this change is the cause Add default code to alarm_control_panel (#112540) · home-assistant/core@6b7ff2b · GitHub

Opened a new Issue here: Issue Setting alarm with code in configuration.yaml · Issue #118668 · home-assistant/core · GitHub

I’m having the exact same issue…just started in the last few days.

I found the same issue. I used to be able to hit the arm buttons with no code and need the code to disarm (it’s not in the yaml). Now I need to enter the code to alarm the system. Started right after the 06 update.

I’m also getting the following error after updating. Reverting back a version does not help.

Failed to call service alarm_control_panel/alarm_arm_home. Validation error: Arming requires a code but none was given for alarm_control_panel.intrusion_alarm

I’m not understanding the rc vs. stable tags…is this referring to the version of HA?

Docker Tag, its irrelevant as its in stable now.

Same here.
Paradox SP6000 / IP150 module (PAI addon)
“Failed to call service alarm_control_panel/alarm_arm_###. Validation error: Arming requires a code but none was given for alarm_control_panel.partition_###”

I am also having this issue. Related threads:

In my case, I am using an Abode alarm system with HomeKit integration. I have never needed a code previously and not sure how to immediately fix.

Same here with 2024.6.1

I was able to arm without a code and now not anymore

Hope to see a solution or work around ASAP

Same issue here with 2024.6.1. I rolled back to 2024.5.4 and tested it resumes to work.

1 Like

I ran into a similar issue with my HA install and the “Manual Alarm” control panel. I added:

code_arm_required: false

into my YAML configuration and that fixed things. I am guessing that the default for code_arm_required changed from false to true.

Cheers!

1 Like

@iprowell, unfortunately, this is valid only if you create a manual, template or mqtt alarm.

if the alarm is generated directly from an integration or addon, you cannot manually add

1 Like

Solution is in this post:

https://community.home-assistant.io/t/community-hass-io-add-on-paradox-alarm-interface/154838/330

2 Likes

That solution doesn’t work for the Envisalink Integration - You can’t access the UI for the Partition because the Envisalink integration has not been upodated to create uniqe IDs

Therefore unfortunately none of the known workarounds that do not require code edits are valid.

I created this bug in Core:

Envisalink integration NOT FIXED by 2024.6.1 Alarm Code disarm issue still remains. · Issue #119340 · home-assistant/core (github.com)

I also never used a code for my Aqara M2 Hubs and with the latest HA updated it stopped to work. I entered a dummy code 0000 into the device settings and now its works, at least a temporary solution. There should be an option to say: no code

This option does not exist in Envisalink see note above. The setting is in the UI in a place that is not available in integrations that have not yet updated to support unique id’s…

Like envisalink…

Hi folks,

I just upgraded to 2024.6.2 and the issue is now fixed:

Thanks to @gjohansson on issue: Fix envisalink alarm by gjohansson-ST · Pull Request #119212 · home-assistant/core · GitHub

:pray:

1 Like