🌻 Lovelace UI • Minimalist

Thanks a lot. Understand the issue of several formats. I´ll check it out by myself. When I havce time :slight_smile:

When it comes to the “temperature_chip”: It worked in the morning withou adding the two lines you mentioned. It stopped working for a reason. I added then those two additional lines but still no success.
This is what it looks like:

  - type: 'custom:button-card'
            template: chip_temperature
            tap_action: "more-info"
            variables:
              ulm_chip_temperature_inside: sensor.temperatur_wohnzimmer
              ulm_chip_temperature_outside: sensor.temperatur_aussen
              ulm_chip_temperature_weather: weather.dark_sky

Another thing: We have the power_consumption chip. I try to get this working :slight_smile: I thought about it would be great to have the same for Gas. I thought of simply copying the Power template but I werent succesful. Can you or someone else assist here too?

I tried that, and it’s still not working. And yea, it’s called weather.dom

And now welcome card is showing me this error

I see.
Check this link Welcome Scenes Card (docs).
I wonder if you should fill the ui card with the other variable ‘ulm_card_welcome_scenes_collapse:’ and with the related input_boolean that is used to manage the collapse function.
Mine is working…

Hi all,

i managed now to get my views visible. Issue is that if I use a navigate chip i get always back to my “default-live-dashboard-home-view” instead for designated one.
This is how my folder looks like:

grafik

This is the code

 - type: "custom:button-card"
                template: chip_navigate
                label: 'Bad'
                variables:
                  ulm_chip_navigate_path: /ui_lovelace_minimalist/02_bad
                  ulm_chip_navigate_icon: mdi:shower            

It doesnt work neither when I write the full path.
The back button works. Following the code for this:

- type: 'custom:button-card'
                template: chip_back
                variables:
                  ulm_chip_back_path: /ui_lovelace_minimalist/01_home    

Any ideas?

Yes! April fools!

check this Is this some sort of weird april fools joke - crooked cards?

1 Like

If your frontend looks weird today Community Post

2 Likes

Any body developed a chip with icon only that can change icon based on the state of an entity (e.g. door open/close). Can you share your custom card/chip? Thanks!

1 Like

Never thought about that :joy: thank you. Removed the part from my post to not distract from my more important issue :slight_smile:

1 Like

Heads up for people with a ‘wonky’ April fools dashboard:

This is not the same as I mentioned :wink:

Also I did forget to mention the chip needs an entity if used with a tap_action. So it should be like this for you:

          - type: 'custom:button-card'
            template: chip_temperature
            entity: weather.dark_sky
            tap_action: 
              action: "more-info"
            variables:
              ulm_chip_temperature_inside: sensor.temperatur_wohnzimmer
              ulm_chip_temperature_outside: sensor.temperatur_aussen
              ulm_chip_temperature_weather: weather.dark_sky

The path of your view is not necessary the name of the yaml-file.
You can specify a path for a view with:

views:
  - title: lights
    path: lights ## this makes the path /ui_lovelace_minimalist/lights
    icon: "mdi:lightbulb-group-outline"

Or you can find the path by looking at the url
image

1 Like

Awesome. It´s working now. Thanks a lot.

Now to figure out how to make custom chips :slight_smile:

1 Like

Hi all, anyway to make the layout responsive, it wastes quite a bit of space on my desktop

V0.0.7-hotfix2 :rainbow_flag:

Happy April fools day!

As many of you have noticed card-mod introduced a joke where our dashboards began to look weird.

With this update we have updated the version of card-mod to fix this.

You only need to install this update if you have checked the box to let UI-Minimalist to install all the needed dependencies.
You can also wait to end this day. Card-mod will reset itself after today.

Please also reset your browser cache after installing this release and restarting HA.
This can be done on Windows by clicking CTRL + F5 or on Mac holding down shift and click the reload button :smiley:

:heart: Thank you so much for helping out to keep this UI awesome

@stokkie90

3 Likes

That looks amazing, I’m also interested for config files if you’re willing to share, even if code is dirty :smiley:

Hi together,

Is it right that I can’t run the dashboard in full width on e.g. iPad mini = 7 inch display?

Thanks and Greets
Dominik

The layout of the card is great and I would love to use it. Unfortunately I can’t get the version of the card to run. Have you continued working on the card in the meantime or will you make a new version available soon? Thanks for your work and great inspirations!

can you please share your UI code?
may be I can help!

Having issues trying to get the custom person card to work. Followed the directions in the main page but noticed that for the custom person card the template is missing. I found it on a github page but the name seems wrong. the template is showing ulm_custom_card_imswel_person_language_variable.
Any help with getting the custom person card to work would be grateful

So it´s me again :slight_smile:

Getting closer to a POC state which means i´ll be do nothing than building a new dashboard the next 3 weeks :slight_smile: Thanks a lot to @basbrus for helping with a ton of patience here

Before I can go to work another question:

Isn´t the power consumption chip supposed to show two sensors? Consumption AND cost? Or just one value?
This is what I have

grafik

- type: 'custom:button-card'
                template: chip_power_consumption
                variables:
                  ulm_chip_electric_consumption: sensor.stromverbrauch_tag_kwh
                  ulm_chip_electric_price: sensor.kosten_stromverbrauch_tag

Both sensors are template sensors showing the current daily consumption but this shouldnt be an issue, right?
If it´s not supposed two show two values, i assume I need to build a custom chip?