Lutron Caseta - invalid config

I’m willing to try, but I’m not sure how to run the version with your update. It’s after midnight here and I have to sleep. :slight_smile:

I can try tomorrow, if I can figure out how to update to the pre-release version. I may have to wait for the release as it is so simple to update a released version and I have limited time to work on this right now.

Either way, I’ll report back here on how it works for me.

I upgraded to version 0.43 today and lutron_caseta component is working great!

Thank you!


Awesome! I’m glad that worked for you. If you don’t mind can you tell me how many devices you are using with your hub and if they are all working as you expect with homeassistant.

I appreciate the help. Thanks!

i installed 4 dimmers and four remotes with one hub.

The dimmers were all discovered and work exactly as I expected they would.

Thanks for this!


1 Like

@gurumitts Have you seen that a few people (myself included) are having issues with their non-pro caseta hubs recently.

It looks like ssh is not accepting the credentials anymore. I wonder if you have any insight.


This really sucks… How did you get the previous key? Was it that you simply had access to it via the pro hubs?

I hate that I have to launch the caseta app to turn off my kitchen lights and my automations don’t work anymore. :frowning:

I found the Key in on another git hub project. I am really sorry that this happened. I liked the LEAP ssh integration as it did not require any additional files and worked with both pro and non-pro bridges.

I hope we can find an acceptable way forward.

I hope so too!

I’m using @jhn’s code because I have a “Pro” bridge and I like to be able to use Pico remotes for things other than Lutron switches/dimmers. But I’d love to see a common component that supports both bridges, even if there isn’t feature parity.

@gurumitts I don’t think you have anything to apologize for – your component worked great and this is just Lutron enforcing its market segmentation, unfortunately.

1 Like

Is there any chance you could do a simple write up of how you got @jhn code to work? I have a pro hub and spent some time today trying to get it going, but no luck. I put his components into custom_components and created the caseta_ip address.json, but I wasn’t successful. Perhaps it’s because I’m using

I’d be interested in that write up too!

My Pro hub should be here in a few days.

It’s not so much a writeup, but I’ll tell you this: I couldn’t get it to work in custom_components either. So I just copy the necessary files from the github repository (the caseta-0.40 branch specifically):

… to the appropriate directories in my home-assistant installation. On my system, which uses Docker, it looks like this:

docker exec -t home-assistant mkdir /usr/src/app/homeassistant/components/caseta
docker cp /data/hd/home-assistant/casetapro/ home-assistant:/usr/src/app/homeassistant/components/caseta/
docker cp /data/hd/home-assistant/casetapro/ home-assistant:/usr/src/app/homeassistant/components/caseta/
docker cp /data/hd/home-assistant/casetapro/ home-assistant:/usr/src/app/homeassistant/components/light/
docker cp /data/hd/home-assistant/casetapro/ home-assistant:/usr/src/app/homeassistant/components/sensor/
docker cp /data/hd/home-assistant/casetapro/ home-assistant:/usr/src/app/homeassistant/components/switch/

You only need those five files, and I just keep them on my local system in the casetapro directory and use a script to inject them into my docker container every time I upgrade Hass. There’s no need to edit any of the files; just copying them over is enough.

Then set up your configuration.yaml per this component’s requirements. In my case again:

    - host: 192.168.x.y
        - id: 2
          type: switch
        - id: 3
          type: switch
        - id: 4
          type: switch
        - id: 5
          type: switch

You have to manually identify your on/off switches as such or everything will be treated as as a dimmer.

Finally, you need to export an integration report from the iOS app (or equivalent) and put it in your home-assistant configuration directory as caseta_192.168.x.y.json

Then off you go!

I don’t use so I don’t know what the process would be there, and I also wonder if this component will stop working at some point. It doesn’t seem to be under development currently.

But it does work perfectly now, and it does make Pico remotes visible as sensors that can be used for any purpose, so big thumbs up from me.


Thanks so much. I’ll see if I can get it working in and will post if I do.

No need to apologize. It’s not your doing… :frowning:

1 Like

I hate not being able to control my lights with HA anymore, but I really only have one automation that used Caseta. It turned off my kitchen lights when i went to bed at night…

My interim solution is as follows:

  1. Create a Webhooks (formerly Maker) Applet on IFTTT.
  • If → Webhooks
  • then Caseta activate scene
  • Looks like this: If maker Event “kitchen_lights_off”, then activate scene called Kitchen Lights Off
  1. Setup IFTTT in HA
  2. Update automation action:
  - service: ifttt.trigger
    data: {"event":"kitchen_lights_off"}

My lights will now turn off automatically again…

Anyone else come up with anything? Also… Anyone know how IFTTT can talk to Caseta non-pro bridge? Is this something we can setup in HA?

You’ve got this working on 0.53.1 or are you running a previous version of home-assistant prior to the “official” Caseta integration? I’d previously been using his branch before the proper integration but can’t get this to work on 0.53.1.

Strange, because I’m currently on 0.54 and I have been using @jhn’s Caseta implementation since the early 0.4X series (not sure exactly) with no problems now or at any point in between.

To anyone else looking, disregard! Was an error on my part. This is still working just fine. Thanks for the reply.

1 Like

I’m still trying to get @jhn implementation to work without luck. I switched from to all in one (and tried hassbian too). I’m able to see all my lights and can turn them on once. After that I lose all control over them. Any ideas what could be wrong? Thanks for any help.