Mobile application startup is very slow since 2021.11.0

Since the upgrade of HA to 2021.11.0, the mobile application on iOS is very slow.
It is displaying the HA icon for at least 3 minutes with “loading data” turning again and again.

I assume that it is a side effect of the latest frontend that comes with that 2021.11.0 version.

Downgrading to 2021.10.7 is solving the issue instantly.

3 Likes

Hi,
can confrim, happens also for me on iOS
I also tried to Update the App to the newest version and also tried to reset the frontend cache multiple times.

Not solved in 2021.11.1
As a side effect(?), no notification anymore on phones.
This bug in the companion app is very anoying.
Going back to 2021.10.7 for now.

Screenshot of the app, started at 21:58, still spinning at 22:02 (and finally displaying data at 22:04)

I thought I was alone but this is really annoying! Same problem. Why upgrade when new problems to exchange old ones (last was crash for daylight saving )

1 Like

Hopefully this will be fixed before next switch in 6 months.

Same issue for me on iPhone SE with iOS 14.1 Very Very Very annoying :hot_face: I have restored to 2021.10.6 and now everything is working again

Startup is fine (under 2s cold start, usually even less - force-quit before) and unchanged here on iOS 15.1 but the issue that the UI eventually always stops communicating with the backend is still present.

As I reported in separate thread… for me it is the issue of network change between session. E.g. if I launch application in one place in my house it loads instantly. If I moved to other location (and switch to another AP), while app is working even if background, I get exactly the same problem as you reported. Refreshing view (swiping down content) resolves issue. Also disconnecting from WiFi and reconnecting (or even swithing to LTE) instantly solves the problem (this sends the signal that network changed and another session should be started/content refreshed?).

Home Coordinates is totally Crap after each HA Restart - also very Annoying

@mirekmal, in my case, I have only one network and one AP in my house.
After the loooong minutes waiting for the app to start, if I force quit (slide up) and restart, it will take again the 3-6 minutes.
That was not the case with 2021.10.7, which I’m using for now.

Do you observe similar issue with other applications? In my case good example is AppStore that can load extremely long unless network is restarted… If this is the case also for you, then perhaps this is related not to HA companion app, or netwrok, but someting wrong with iOS/iPhone itself… which would be scarry.

@mirekmal, no, not at all, only the companion app, and only since the 2021.11.x version.
As said in my first post, downgrading to 2021.10.7 is solving the issue instantly.
That’s why I’m locking my RPi to 2021.10.7 for now. I’ll wait for that issue to be solved.

Slow is one thing but not receiving notification is another, no more warning when my presence detectors are triggered is stressful.

I’m observing the same with HA 2021.9.7.
if I put HA app in the background and bring to front after a while, sometimes it reloads whole page (which is annoying too btw) but sometimes it does’t succeed. The k look latter requires pull down gesture in order to force reload.

To me it happens more often in local network (probably roaming between Unifi APs) than between wifi and LTE

so I had a few people in the android repo mention this issue happens in Chrome for android. Can you guys check Safari on iOS and Chrome on Android to see if the behavior matches?

I’m always using the external url. It is the only way for my certificate to be recognized by the companion app (otherwise it says that the certificate is for “external url” but the url is “internal url”)

It is up to my box to allow the nat pinning which it was doing succesfully until the 2021.10.7.
I believe that this part is still working in 2021.11.1, but something has changed, the DB? the frontend? something else?

P.S.: Rolling back to 2021.10.7 did not solve the notification issue, in the log, I see that the notification is sent but it never reach the mobile companion app.

Nov 07 16:07:55 hassbian hass[7537]: 2021-11-07 16:07:55 INFO (MainThread) [homeassistant.components.mobile_app.notify] mobile_app push notification rate limits for iPhone: 18 sent, 500 allowed, 0 errors, resets in 8:52:04

Checked on the phone and everything is still allowed, so the go to 2021.11.1 and back to 2021.10.7 broke something.

Hi, this topic was discussed also in the official update blog post.
The solution for now seems to be here:

Blog post in the official thread here

1 Like

Indeed, changing Europe/Brussels to Europe/Oslo is solving the issue.
They need to fix this in a future release, this is a weird workarround for sure.

For the notifications, I had to do the procedure in Correct way to reset app and start over?

It happened to me several times (mostly after app upgrade) that ios shows everything allowed while in fact it doesn’t work. I had to reinstall application. (maybe it’s enough to disable notifications and re-enable again)
Also check if you don’t have doubled devices in integration

As you said, did that, it was only mentioned once in HA integrations and everything was looking ok in the notification section of the settings app.
Did a re-install as in Correct way to reset app and start over?