Mosquitto MQTT 4.1 doesnt work after update

mqtt
Tags: #<Tag:0x00007fd073a03520>

#1

After yesterday’s the update of the Hassio to 0.89.1 and Mosquitto broker to 4.1, all MQTT traffic ceased. I cannot send or receive anything on any topic. In Add-ons log it states that all my devices are connected:

New client connected from x.x.x.x as yyyy (c1, k15).

entire log

[INFO] Setup mosquitto configuration
[WARN] SSL not enabled - No valid certs found!
[INFO] No local user available
[INFO] Initialize Hass.io Add-on services
[INFO] Initialize Home Assistant discovery
[INFO] Start Mosquitto daemon
1552303072: mosquitto version 1.5.6 starting
1552303072: Config loaded from /etc/mosquitto.conf.
1552303072: |-- *** auth-plug: startup
1552303072: |-- ** Configured order: http

1552303072: |-- with_tls=false
1552303072: |-- getuser_uri=/login
1552303072: |-- superuser_uri=/superuser
1552303072: |-- aclcheck_uri=/acl
1552303072: |-- getuser_params=(null)
1552303072: |-- superuser_params=(null)
1552303072: |-- aclcheck_params=(null)
1552303072: |-- retry_count=3
1552303072: Opening ipv4 listen socket on port 1883.
1552303072: Opening ipv6 listen socket on port 1883.
1552303072: Opening websockets listen socket on port 1884.
1552303072: Warning: Mosquitto should not be run as root/administrator.
1552303072: New connection from 192.168.0.50 on port 1883.
1552303072: New client connected from 192.168.0.50 as GarageV10.2b (c1, k15).
1552303073: New connection from 192.168.1.111 on port 1883.
1552303073: New client connected from 192.168.1.111 as Table (c1, k15).
1552303104: New connection from 172.30.32.1 on port 1883.
1552303104: New client connected from 172.30.32.1 as 65490544-7a8d-49ac-aed0-ecb169d2e78e (c1, k60).

But no messages can go through.
I don’t use user/password for MQTT as it is only in my local network, so my MQTT config looks like this

{
“logins”: [],
“anonymous”: true,
“customize”: {
“active”: false,
“folder”: “mosquitto”
},
“certfile”: “fullchain.pem”,
“keyfile”: “privkey.pem”
}

and in configuration.yaml

mqtt:
broker: core-mosquitto

Hassio is in Docker on RPI with Nginx as a reverse proxy.


#2

I’m seeing the same thing, I suspect ACL related changes in Mosquitto 1.5.6 might be causing this. I fixed it by rolling back to the previous version of the add on for now.


#3

How did you rollback? I’m going nuts here :triumph:


#4

I’m glad I’m not the first one to ask this :sweat_smile: because i have no idea how and google isn’t helping


Mosquito update 4.1 - ACL messages in logs
#5

I have done it in the past by restoring from a snapshot.


#6

Thankfully found and older snapshot with version 2.0, works like a charm again.


All my MQTT Tasmota devices unavailable in HASS (tasmota webserver works) ..?
#7

So, updated addon and my cou is now 25-30% usage from prevoius 10% on my RPI. Temp in rpi has gone up alot. So tried downgradeing addon to version 4 with partial snapshot but get the following error message.

19-03-11 12:41:30 ERROR (SyncWorker_2) [hassio.docker.interface] Can’t install homeassistant/armv7-addon-mosquitto:4 -> 404 Client Error: Not Found (“manifest for homeassistant/armv7-addon-mosquitto:4 not found”).

19-03-11 12:27:05 ERROR (SyncWorker_5) [hassio.docker] Can’t create container from addon_core_mosquitto: 404 Client Error: Not Found (“No such image: homeassistant/armv7-addon-mosquitto:latest”)

Anyone know how to dowmgrade? I cant use 4.1.


#8

Im having the exact same issue - im going truly mad:( Arghhh. How can we inform about this to get it fixed in a hurry?


#9

Same here, had to roll back and turn off auto-update


#10

if you have snapshot, roll back just the mqtt


MQTT Stoped Working
#11

Exactly what I did and worked


#12

I think I have the same issue. The problem is I do not have a snapshot. How do I downgrade?


#13

had the same problem. reverted to 4.0 with partial snapshot.


#14

well, I hope that the core HASS MQTT server will work well in the future, to not have to use external components, and have to maintain those too


#15

Just rolled back to 4.0 but it doesn’t work for me.
All sensors show unknown and none of my Zigbee switches can be triggered.

Any ideas? Till 11am it worked for me, after that (I think there was the auto update) it stopped working.


#16

same here, also backup to previous version


#17

Reverting back to Mosquitto broker 4.0 fixed the issue for me as well.

In the snapshot manager of hassio, you can simply deselect everything except the Mosquitto broker 4 addon, click “restore selected”. Wait a bit until it is restored, turn off automatic updates. Restart home assistant once more and then it should work again! :slight_smile:


#18

If you’re using an addon broker, report it as an issue is the addon’s github page.
All addons and HomeAssistant itself use github as the official issue tracker.


#19

I’ll ask the same question other people were asking before. Is there any way to go back to 4.0 without a snapshot?


#20

Seems that this is an issue with NOT having an ACL assigned for the user. Now I am using anonymous but from what I am reading it is the same for named users. The Default ACL is read only so you need to go set your acl to readwrite if you need to publish data.

I am using the Hass.IO core add-on and setup the ACL file as listed at the bottom of the page https://www.home-assistant.io/addons/mosquitto/

Then in the accesscontrollist file I placed the following (using spaces_

topic readwrite #

You can lock this down however you feel is appropriate

Then restart the mqtt add-on