Netatmo public - gone forever?

Tags: #<Tag:0x00007f7391780620>

I have tried but it won’t work.

What do you mean by that? What doesn’t work? What are your expectations?

Sorry for being unclear. I have tried adding the following to stations but I don’t get any data.
Link 1
Link 2

Sorry, I still don’t understand. You can’t add individual public stations. You have to choose an area to average/max over.

You need to enter the latitude and longitude geographical coordinates of the top right corner and bottom left corner of a square around the desired location… not links to specific stations

1 Like

I know, I will explain what I have done.

  1. On the Netatmo Weather Map I found two stations near my home.
  2. Found latitude and longitude for area that covers both stations.
  3. Entred the latitude and longitude in the integration.

However it is not working. I still get “No Stations available” in the log.

For me, so far working mostly great - thanks!

Observations:

  • The rain sensor is often “not available” but sometimes - I think mostly when it rains, but not sure whether this is always the case - it has a value. When there are sensors that do not report rain, I would expect to see 0, but then I don’t know if the API allows you to distinguish that.
  • When I rename an entity in the UI, it changes its name back to the default after a restart. I believe this is a bug: if your entity has a unique_id, then it shouldn’t change after a restart.

Thanks for the feedback. I’ll look into that ASAP.

I can report the exact same behaviour here. The rain sensor is indeed quite often not available…

image

Same here - I’ve connected to 2 local stations. Both have rain and wind sensors data on weathermap.netatmo.com. Only 1 of the wind sensors is showing data in HA, other is ‘unavailable’. Both rain sensors are ‘unavailable’.

Now, the wind sensor that is ‘unavailable’ is showing 0 km/h on the netatmo website. Also, both rain sensors have 0mm in the last hour. So, I guess the custom component shows sensors as ‘unavailable’ when the value of the sensor is 0.

Also, entities change the name back to original after the restart.

Neatmo public now working for me (almost). Temp and wind sensors ok, rain sensor broken.

@cgtobi PR is merged and rain sensor still broken. What’s wrong? I have same observation as @DavidMStraub - entity sometimes available (i think when it rains) and most of time Unavailable.

It was merged an hour ago. As far as I know there hasn’t been a release in the last hour. There won’t be one for another 2 weeks.

cgtobi merged commit 155a5f7 into home-assistant:dev 1 hour ago

1 Like

Let me comment this with a screenshot:

As @nickrout pointed out already, it is not released yet.

1 Like

If you want to go bleeding edge, hop on the pre release train. It now includes the public weather sensors.

1 Like

It finally is back! Check out 0.113.

3 Likes

Thanks, it was important for some.

Yeah, I know, I use(d) it myself, I felt the pain. Sorry about the inconvenience.

hi @cgtobi, thanks a million for the nice work done here! do you see ever happening to be able to point ton one specific location?
Also, I’m extremely interested in obtaining instant rain values. Could you advise on the best configuration for achieving that? should I go for avg or max?
thanks again!

Thanks for the kind feedback.

Instant feedback is not provided by the API. Values are only updated every 10 minutes.

For the other question, are you asking about picking a specific station?