No color picker with tuya bulbs

I have a couple of RGB Tuya bulbs, but I cannot get the color wheel/picker to show, in order to change the bulb colors.

After searching this is the only post I found about the same issue, but his would come up after waiting a few minutes, mine never shows.

I can change the color via the Tuya app, and via Google Assistant, just not via HA. Am I just missing something, I need to add to the Entity?



Same here :frowning:


I use the LSC smart bulbs from Dutch Action shop. They are rebranded Tuya bulbs. Same problem here. No color picker.
Maybe need to reflash them with tasmota to use the color picker.

Same here with Led strips from TECKIN (Smart Life). :roll_eyes:

I was hoping to not have to flash them, but maybe.

Flashing is easy if you got a spare RPi laying around. Tasmota is way better than sharing your wifi credentials with our Chinese friends.

it used to work, then about the middle of december it broke,…

no one has fixed it yet, unfortunately…

i flashed a merkury bulb earlier and the color picker and setup pretty much sucks.

much easier with native color wheel in ha… so untill its fixedl. i guess we wait.

I am also having this issue, and i thought it would be fixed with this last release. It appears some people are having luck fixing it themselves here:

thanks. thats teh fix i was using before the last major update. I tried to apply it and it didnt work.

tried it again, and it worked. the key to it working again was to stop HA before swapping the files.

So yeah. Still working

I will try that out.

More Specifically

1 Like

I’m using and cannot find a anywhere in the file system, which I can access.
I am trying the fix from this comment though:

@Dragonsys Has there been any fix to this for 108.6 and


No. still no official fix. You’d think more people would be raising the issue too, since its tuya related.

The ‘fix’ is working, but it isn’t the same as before it got broken. Every light has a color picker even white only bulbs.



Hello, same problem here. With upcoming Tuya - IFTTT split it can be expected that many people will migrate from IFTTT to Home-Assistant to control their Tuya devices. They will be disappointed to se it does not have enough functionality they had before.

Had this problem myself and looked through all the posts on this subject.

In the end I found a really straight forward solution (at least it worked for me)

Most of my bulbs are RGBWW so I did the following;

  1. Go to configuration > customisations
  2. Find the light you want to amend
  3. Check the Supported_features setting (it’s probably 2)
  4. For my bulbs to support all features I updated to 63

To figure this number out, look at the features list below and add up the numbers for the features you have,


It doesn’t resolve the issue of the current status being reported but at least I can control all the features.

Now if only I could get HomeKit to play nicely with this setting (it refuses to send the correct white value and just mixes RGB) I would be home free.


Saxo, this customization worked for me with SAUDIO LED RGB Color Changing Bulbs E26. Instead of overriding the Support_features setting (in my case it was 3) to 63 I used 191 to include SUPPORT_WHITE_VALUES. It added another adjustable control which doesn’t seem to do much for me, but it might for you. In my case, selecting the very center of the color wheel puts it in white mode and the temp adjustment then works. (note: Adjusting the warmth also puts it into the white mode.) Thank you so much for this. How did you find it?

1 Like

I found that some thing, 63 removed the extra slider but still allows me to control the white value.

It was just an observation that the supported features where being incorrectly identified. From there I started to investigate what values should be used.

Would be nice to get the status working too but does what I think what most of us need for now.

Glad it worked for you

@Saxo thank you for this quick fix!!! its working for me with my Teckin RGB lights!!

the only problem that I see is that I can’t select Red… because it goes to purple!!! but beside that it works!! thanks!

This worked for me!!!

Had to create a customize.yaml and add a

!include customize.yaml

in configuration.yaml