No IP address showing

Good afternoon all, I am new to home assistant and new to the forum so go gentle with me.
Yesterday afternoon I noticed that I could no longer dial into the web page for me home assistant after doing some research and playing around I noticed that I could no longer see it’s up address using fing or advanced IP scanner.
My home assistant is running on a virtual box remote pc and was all working fine. Using the command line console I have found that it doesn’t appear that my VM as an ip address. I am hoping that someone out there has a fix for me. I remember reading somewhere about how to set a static IP using the command line console but I can’t find it now. this is what I can see

By looking at your picture you might have disabled the network interface for your virtual machine which is running HA.
Try to check your network setting in Virtual Box.

Managed to sort it don’t know how permit the fix will be I changed the network adapter on the VM saved it then changed it back seems to have solved the issue don’t know how or y. Thank you for pointing me in the right direction

1 Like

Hi, can you explain more detail on how u fix the issue? I am new here, had to do home assistant for my grafana tools

Try to unplug and your network cable and plug in again. You now should get the IP address (You might want to use Fing to discover the IP of HomeAssistant)

1 Like

Hi, I have similar problem. I’m running Home Assistant on Raspberry pi for more the year, but since 2 months ago, when power cutoff and go back, my Home Assistant won’t get IP address. It is wired connection. So I have to hook up a monitor and keyboard and run from Home Assistant CLI command ‘network update’ (or similar) , to get an IP address. Do you have idea what could couse this bug?

I also just experienced the same issue. My Home Assistant is running in a VM on Proxmox. Two days ago, there was a power outage and when the power came back, my HA instant came back up and running but without an IP address assigned. I was troubleshooting with the VM and also my IP settings in my Unifi controller and could not resolved the issue. Luckily I found this thread and was able to fix the issue using the CLI command @ayordanov outlined above to have the IP assigned again. Thanks.

@skull29 @ayordanov

Hiya! I have the same issue. Would reinstalling HA fix it?

You do not need to reinstall anything. Just go to the console and run the command as in below screenshot. Change the “enp0s18” according to your card and also the ipv4 and v6 settings accordingly to your own settings. :slight_smile:

As to why this happens, I believed it is some kind of bug as @ayordanov mentioned too. Hopefully it will be fixed at some point.

5 Likes

Ok, I will remember that. Thanks!

I reinstalled and made sure to have the eth connected before startup which also worked but only ideal for a fresh install.

Hi Skull29,
the first time I used your fix it worked nicely. I then rebooted my PC and it’s back to missing local ip address and I get the following screen. Help?

2nd attempt

1 Like

Your help would be appeciated please. I am a novice of 1 week

Regards

I had to use a few commands to get the eth0 to get an IP Address.
ha network info
ha network eth0 disabled
ha network eth0 auto

1 Like

Sorry…Just saw the post. I am not an expert as well but merely searching and experimenting. :wink:

Your first attempt is just wrong syntax. As for your second attempt, looks like some processes failed. Googling gives…"the error ‘context deadline exceeded’ means that *we ran into a situation where a given action was not completed in an expected timeframe "

I would suggest that you also try out other network commands to make sure it is working first as mentioned by @s-e-t-h.

If it still does not work, then either someone with more knowledge can chip in or you would have to reinstall. :frowning:

1 Like

Thanks worked for me !

1 Like

Is that a bug in the current HA build?

I had a power outage this morning that resulted in my home assistant pi4 not showing up on my network. It’s connected through ethernet and as in the screenshot earlier in this thread, the ipv4 address is showing up empty in the pi 4 display (it seems to be running fine apart from that).

I tried typing in ‘network update’, ‘network update wlan0’ and a few other variations on the commands recommended above, but am getting ‘Unexpected Server Response’ in response.

it’s possible I miskeyed the command. I tried again just now and it worked. My little pi display is so small it’s hard for me to read it :rofl:

Screenshot 2022-06-14 at 22.55.49

The command for eth0 to be Disabled / auto makes more sense now I see this panel.
Enabled is not the opposite of disabled as On/Enabled can be DHCP (auto) or Static.

The command is turning IPv4 off and then on. The good old reboot :slight_smile:

I hope this helps others, I had to travel 4hrs round trip to fix this in person.