No longer a stable connection via duckdns domain

I want leave DUCKDNS, and I created a DYNU ddns account. but now I need ssl certificate… how can I create a free certificate like duckddns and let’s encrypt?

Letsencrypt will do it.

please can you post a guide?

The addon has instructions. There are plenty of threads on here.

sorry but I have HA core installation, so I do not have addons…

Thanks again everyone for providing input & help! I’ve decided to move to a Google Domain and the Cloudflare tunnel setup. I have used the walkthrough by Everything Smart Home as well for the Cloudflare tunnel. Some friendly advice when you start your migration to Cloudflare: Ensure that you have SSH access to your HA host machine, stop the DuckDNS add-on and remove or hash-out any code in your configuration.yaml related to DuckDNS (dont ask me how I know :see_no_evil:).

I have updated the last part of my initial post by adding more troubleshooting methods which have been suggested in this post. This might help others as well in the future. Cheers!

I also setup a new connection via Cloudflare with an own domain. But I can’t use Google Assistant anymore and yes Ibupdated everything with the url :slightly_smiling_face:. Does anyone have the same problem) solution?

Post 95 perhaps? No longer a stable connection via duckdns domain - #95 by N36

After having recurring issues with duckdns (lately, it used to work mostly fine before), and as I also didn’t want to keep a port open, I moved to cloudflare today with a domain I bought. All is working correctly, including the Alexa skill (once I edited the URL), but I do notice everything to be slower than it was with duckdns. It’s just me?

That is annoying when it is slower than before. I don’t have Alexa so we don’t have the same setup but for me the response time using Cloudflare is not slower than with DuckDNS.

Thanks for confirming. For me with duckdns it was as quick as local. With cloudflare it’s noticeable slower, not so much to be annoying, but it’s clearly slower. Now if I load HA with the local IP and via cloudflare on another tab, there’s a clear difference.

I switched from DuckDNS to Dynu and personaly I think it is faster than DuckDNS. No Problems with Dynu so far.

Is this still a problem for people continuing to use duckdns?
I am using SWAG Docker container with duckdns for NGINX reverse proxy and letsencrypt certificates, but it hasn’t worked since October 12. I get this error in my SWAG logs:

swag             | 2022-10-15T02:58:18.606725495Z Requesting a certificate for *
swag             | 2022-10-15T02:58:46.141458275Z The resolution lifetime expired after 5.402 seconds: Server UDP port 53 answered The DNS operation timed out.
swag             | 2022-10-15T02:58:46.142433516Z Ask for help or search for solutions at See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.
swag             | 2022-10-15T02:58:47.010070868Z ERROR: Cert does not exist! Please see the validation error above. Make sure you entered correct credentials into the /config/dns-conf/duckdns.ini file.

When I do nslookup, it shows my correct IP address.
So, it seems to be a problem with the cert. Many restarts have not helped. I’ve also tried to run certbot manually.
As far as you can tell… is my issue related to this thread, or something else? Any ideas are appreciated, thanks.

You can definitely run WireGuard through Cloudflared, that is what I am doing.

You need to Configure the setting for DNS in Cloudflare’s DNS settings (or elsewhere if you don’t host your dns there). Point a subdomain (e.g. towards your dynamic dns name. Granted, you need to update this if your dynamic ip changes, but at least where I live it has never changed since I moved here.

I have had a problems over the last few weeks, including this morning with no connection via DuckDNS.

A reboot of my HA Pi4 has cured the problem every time.

I tried stopping and restarting the DuckDNS add on, but that did not cure the problem.

Re Dave

Seems this issue is reoccurring as of now.

It’s happening again, I’ve just migrated to Dynu. Luckily I use CNAME for my HA subdomain, so I don’t need to change anything in HA or Google Home.

yep duckdns site has been going down a few times today

Got dynu up and running on a proxmox lxc container with account created. See where I go from here now

Got dynu and running yeahhh!!
3 of my local sites set up in nginx with dynu names and can be accessed.