NUE Home Bridge (Zigbee 3.0) Support


#1

NUE Home Bridge (Zigbee 3.0 compatible)
http://www.3asmarthome.com/nue-zigbee-bridge

Controls various lighthing, lamps, bulbs and wall plates
http://www.3asmarthome.com/zigbee-smart-dimmer-switch

Some information

  • IP Addressable device, can connect to a local IP and get service a web page (Fbee Cloud Gateway) with various configuration like network, cloud info etc
  • Ethernet connected
  • Links to “fecloud” via the app on a smart phone, links via QR code
  • Unsure if the cloud service has an API, have emailed them for details

Some more info


#2

yes would be a nice addition for us Aussie stuck with only 1 zigbee option for hardwired switches


#3

Would be great! As there’s a heap of AU compliant gear which links to this!


#4

Anyone have the “Hui Light” app working on Android. Just crashes on start up on my Samsung S8 and Tab S3. Works great on iPhone though.

This app appears to work better/faster than the “Hui Home” app and it does not require an internet connection because it interacts directly with the Nue bridge over local wifi.


#5

Ill give it a go on mine, i just use the HUI HOME

Good to see an app that works locally, means it should be even easier for homeassistant to integrate

EDIT: installed, ran ok, added my light switches, then it wouldnt control them, once i quit the app and tried to re run it i get the same as you

wish i knew how to work out what to do to make a component give we can talk local to the bridge


#6

I’m no expert but I’ll be getting some of these devices very shortly - here is something that may help??


#7

Hi have managed to do a packet trace on the communications between an iPad running HUI Light and the Nue bridge. The app appears to communicate directly with the Nue over TCP port 8001.

Apon initial connection the Nue transmits an enumerated list of the Custom Scenes, Groups and devices back to the iPad. The App then controls devices/groups/scenes by sending a single “command” packet which seems to get a single “status” response. None of this communication appears to be secured or encrypted. From the formatting of the TCP packets there is obviously some kind of rather basic API behind this communication that could be reverse engineered if someone was so inclined. Would be nice if they (fbee/fiebit) just published it though.

All that aside I still cannot get the Android app to work beyond the first run. I can tell that during the second & subsequent runs it never even gets to the point where it tries to communicate with the Nue (no transmission on network to the Nue) before it crashes. Also found the crash report on the Android phone that says error is related to a programming error "java.lang.NumberFormatException: For input string: “R01"”. I did find that by going in to settings / app / Hui Light / Storage and deleting all data it will run one more time (have to repeat this every time though). I am assuming the app is enumerating devices and saving to local storage to speed up subsequent runs but this is corrupted in some way causing crash unless you delete the saved data.

Again app works 100% all the time on an iPhone but really want it to work on my S8. There does not seem to be any official support channel for this app (not that I can find anyway). Given its last update date not sure if its been abandoned in favor of Hui Home - this would be unfortunate as I think its a much better app.


#8

@Sim69417 Mike, did you end up getting anywhere further with this? I am trying from another angle and trying to get the devices into HA via a different Zigbee dongle and Zigbee2MQTT, but not having a great deal of luck so far (possibly due to a lack of ability …). Here’s a link, hopefully this might help you or someone else?

NUE via ZIGBEE2MQTT

These devices are manufactured by Feibit, and the english website seems to be www.brimate.com - might help the process?


#9

@Lee_au no have not received any response from 3a smart home (the mob who I got all my stuff from) re issues with “local” app not working or API info so have not investigated much more at this stage and I am relying on Google home instead at this stage which is slow to respond but works fine, would prefer a “local” control option though. Would prefer my investment not to be totally useless if Feibit goes bust or turns off their servers which is the case at the moment.

Will research via the info in the link you provided when I get a chance and see if anything helpful there.

Steve.


#10

Has anyone tried these with Hue bridge or Lightify?
I have ordered few of the switches without the hub.


Australia - Electrically Certified Hardware
#11

I got their in ceiling controller working without NUE Bridge using zha


#12

I have the light switches (1,2,3 gangs) working with Hassio and Smart Things Hub.


(Used a mail forwader, ie https://www.shipito.com/en/ delivery cost via shipito was approx $45 aud from USA and yes, I know the smart things hub zwave is USA frequency and it’s been disabled).

Smarter things repo: https://github.com/adamfeldman/hassio-addons with setup instructions via the linked repo in readme.
MQTT Broker: https://www.home-assistant.io/addons/mosquitto/
Device handlers + Smart Apps: https://community.smartthings.com/t/help-with-new-dh-for-aust-3-gang-light-switch-catchall-included/
Hassio <> MQTT Broker <> Smart Things Bridge <> Smart Things

Also had it working via Hassio and REST if the MQTT bridge isn’t your thing: https://github.com/bradymholt/smartthings-rest-api
Hassio <> REST <> Smart Things

Both work alright, MQTT broker performs actions slightly faster and state information is reported better.


#13

I have similar setup as Kortex.

I also use a number of Xiaomi/Aqara sensors to trigger switch on/off. They work most of the time, except occasionally, the sending/receiving of motion sensor messages between MQTT and HA is inconsistent hence no trigger.

Any help to improve consistency will be good :slight_smile:


#14

Anyone got Scene switches working with this? very frustrating as I have about 5 of these switches installed now, I can control them with Alexa but no luck with scene switching via Alexa Echo, also the Echo inbuild Zigbee mesh does not seem to be able to control direct without the hub


#15

Another Aussie hoping to deck out future home with the only compliant gear. Subscribing :slight_smile:


#16

Aussie yes please


#17

I am still trying to get my switches imported into Hassio via Zigbee2MQTT, though it seems that in addition to the Smart Things hub, the Hubitat seems to support these devices as well. I’m still holding out on getting my CC2531 dongle working though!


#18

Update: I recently moved my HA from Mac to Rasp Pi running on HassIO and the MQTT interface has been consistent. Light switches are working with Xiaomi motion sensors reliably since and have been using for a month now.


#19

@y_c , Thanks for the update, happy it’s working for you but what has that go to do with the Nue branded switches and hub?


#20

My setup:
Nue switches>Smartthings hub>MQTT>HassIO

I added xiaomi sensors into HassIO as triggers to the Nue switches.