One-timer-installer fails on Raspberry Pi 3

One-time-installation fails with newest raspberry pi image (jessi, 2016-11-25) on a Raspberry PI 3:

_Checking for python-pip: install ok installed_
_Requirement already satisfied (use --upgrade to upgrade): fabric in /usr/local/lib/python2.7/dist-packages_
_Cleaning up..._
_fatal: destination path 'fabric-home-assistant' already exists and is not an empty directory._
_Traceback (most recent call last):_
_  File "/usr/local/lib/python2.7/dist-packages/fabric/", line 24, in <module>_
_    import paramiko as ssh_
_  File "/usr/local/lib/python2.7/dist-packages/paramiko/", line 30, in <module>_
_    from paramiko.transport import SecurityOptions, Transport_
_  File "/usr/local/lib/python2.7/dist-packages/paramiko/", line 32, in <module>_
_    from cryptography.hazmat.backends import default_backend_
_ImportError: No module named cryptography.hazmat.backends_

_There was a problem importing our SSH library (see traceback above)._
_Please make sure all dependencies are installed and importable._

Before the installation I did an apt-get update/upgrade.
Any suggestions???

1 Like

hello, i always use the all-in-one and its perfect with a fress jessi lite :slight_smile:

Exactly the same situation here. RPi 3, AIO installer, newest RPi Jessie image.

Same error shown an installation attempt. I had the error before I did an apt-get update/upgrade, and had the same error after.


Same case here. Fresh install, apt-get update/upgrade - crashing. Cryptography module, because libffi is not installed, and still crashing…

I’m very frustrated, mainly because of the lack of any support by anyone

Same problem. I gave up on the aio installer. Not sure who had to fix it but I’m convinced it does not work on the pi3, even though some people say it does.

Here is what I did. Made an image of Raspbian Jessie on SD card. Then booted up pi so it was a fresh install. Lastly followed this video ( and things with great. HA installed and turns on during startup

i have 3 pi3 and its work perfect. I use “RASPBIAN JESSIE LITE” dont khow if can affect but i always install on ethernet not wifi…

getting the same thing…glad this isn’t just me. Because I am questioning my sanity for the last few hours.

try it again…i doubt it will work…or something you’re doing isnt in the docs, ive followed them 3x for AIO

It’s not just you, it definitely is broken. After enough googling about the error messages it was giving, I did finally get it working.

After running the installer and letting it fail, run these commands:

rm -rf fabric-home-assistant
sudo apt-get install libffi-dev libssl-dev
sudo pip install cryptography --force-reinstall

After that, run the installer again and it seems to work.


Thanks Ken for your help on this.

After running your suggested commands the one-time-installer works properly (except for the wrong indented mqtt section in the configuration file which prevent tha HA to start.)

Thanks again :slight_smile:

Same here, thanks Ken for the solution! Installed AiO successfully on Raspbian Lite. Works like a charm. Same wrong indented line for mqtt in configuration.yaml, fixed right on the spot. Cheers!

There is an open issue for that

I’ve tried the comment from @ken but without any luck…
This is the new error:

Resolving deltas: 100% (125/125), done.
Checking connectivity… done.
Traceback (most recent call last):
File “/usr/local/bin/fab”, line 7, in
from fabric.main import main
ImportError: No module named fabric.main

Any ideas ?

Thanks Ken, I was have a similar issue with a fresh install on a Pi3. Got it fixed it in a similar way. And HA is now running on my Pi 3.

> cd
> rm
> rm -rf fabric-home-assistant
> sudo apt-get install build-essential libssl-dev libffi-dev python-dev
> sudo pip install cryptography

Then re-ran installer, ta-da.

1 Like

I’m working on AiO v2. Regardless of the new version, I’ll have a look and get the issue sorted. Standby.

1 Like

I’m okay now after manually installing fabric

I managed to get it installed with this thread thanks guys! However when i try connect to https://piadress:8123 i get connection refused, anyone else run into similar issues? i feel like my home assistant is not even running… does anyone know a command similiar to hass --open-ui but that applies to the AiO script? :slight_smile:

THANK YOU very much, for the last couple of days I was feeling like an idiot. I tried HASSBIAN and then I ran into all the z-wave issues and I was not able to make it work (for z-wave). Then I tried the all in one installer and the I ran into all the issues that you described, but thanks to your post I was able to make it run on my RPI-3 using the latest Raspbian version. What I did it was I installed the cryptography first and then I proceeded with the installation and to make it run I modified the MQTT inside the configuration.yaml.
Now I need to figure it out an easy way to rename all my z-wave devices, I am porting from version 0.28.2 running on a RPI-2 to version 0.34.4 on a RPI-3.

To modify the mqtt component, did you just delete the indentations or did you also change the broker and port? should the broker be your pi IP address?

Yes, I deleted the indentations and the IP address that I used was the address of my RPI. Or if you have any other MQTT broker point it to that one.

1 Like