Lightweight IOS version (for IOS 9.3.5

Just decided to brush the dust off my old iPad and turns out it’s iPad 3 iOS 9.3.5. Was excited to get it going as I used it a long time ago and now it’s not supported :frowning: any solution would be nice.

1 Like

I’m looking for a status only display for my kitchen and was thinking about running a standalone webserver and pushing HA data to it via MQTT. Haven’t worked out the details yet, but I think you could also control devices, or at the least, run automations with MQTT messages.

I’ll post back as I come up with more.

You could expose HA entities back to Homekit and then use an old Homekit app. Hesperus should still work on iOS9. The Elgato Eve app might work as well.

I have the same issue and instead of using Lovelace I use an Appdaemon dashboard. Not exactly the same but one can still do a lot on a iPad 3 with iOS 9.3.5.


1 Like

Same issue here.

1 Like

For an awesome workaround see this post: Options for Lovelace on older iPad (ios 9.3.5)

1 Like

Quick heads up on the problem: just saw this in the 0.117 announcement

We improved compatibility and Home Assistant is now usable on more, mostly older, devices.

I just updated and tried on my old iPad, and it works: Version 0.117 brings the iPad 3 compatbility back!
Many thanks to the HA team!


@nagubal thank you so much for posting this! I have RPI3b with latest HassOS that I’m playing with and I just tested it on my iPad 2 — worked flawlessly. Thank you HA Team, awesome job!

1 Like

@nagubal thank you for posting. Waiting for something like that for a long time

Already charging :wink: my old iPad :smile:

Greez from vienna

1 Like

@nagubal works better but not perfect - button card installed via HACS is not showing on the iPad 3 and saying Custom element doesn’t exist :frowning:

At least its connect which is a great start.


I have the same problem, my custom cards doesn’t show up, I hope it will be fixed soon.


Same here, seems lik a lot of custom scripts are not loaded.
Kiosk Mode also does not work on my old device

1 Like

:white_check_mark: :white_check_mark: :white_check_mark:
Hello, I have found a solution for this problem.
I have an iPhone 4S with IOS 9.3.6.
To reinstall it you need to get a device compatible with the current update and download on this device (iphone / ipad under ios 13 at least). You must invite in your family the non compatible device in question.
All you have to do is go to your old device in the family section and find the home assistant app and download it.
I hope it will work even for future updates.
French greetings. :smiley: :smiley: :smiley:



That is a great idea, I will try it!

it work for me

I can indeed download a Home Assistant app on the old iPad.
Great workaround, however custom cards do not work

Same with me for custom cards. So glad it’s back and working to some level.

How can I default HA home page on a specific device ? I’m going to need to create a page with no custom cards :confused:


  • some entities just don’t display, do people have this on a standard entity card?
  • some badges aren’t displaying, i tried reordering but same as entity card… only some work

Mine won’t login. iPad 2 with 9.3.5, tells me wrong username/password every time when I can login just fine on my phone. Anybody has this working for them?

Hi, I downloaded Home Assistant app to my parents Ipad 2 like in you’r post - but the app keeps crashing when I try to open it. Anybody alse with this problem?