Portainer v2.6.2 - unable to start containers

Not sure what the problem could be, but even since the portainer update to v2.6.2 ( integration v2.0.0 ) I’m unable to (re)start any of my previous working containers…

The failure I get is : Starting container with non-empty request body was deprecated since API v1.22 and removed in v1.24

Anyone any idea or tips?

2 Likes

Staff off Portainer have suggested not to update for now and they will investigate also.

I’m running the latest portainer without any issue, so unsure what is wrong at your end

Weird… the issue was logged by another user and even other users are reporting seeing the same problem.

sorry… I did not read correctly… you are using portainer-addon… my bad…

Are you running portainer stand alone on the same environment as Home Assistant? I’m just wondering if installing it manually myself would be a better flow than using the add-on.

Yesterday, I tried both the addon and installing directly on debian…neither worked. This morning, suddenly the addon is working. I haven’t changed anything overnight. It’s a mystery!!!

Wait the add-on does work in my instance, only since the latest add-on update, I can’t restart any container anymore…

just to be sure…

MiniPC and RPI both are running latest HA + addon

After some testing

  1. the community addon: Portainer starts and shows containers, but you can not start a container…message says that starting a non empty container (or something like that) has been depreciated).

  2. uninstalling the community addon and installing the Alex Belgium 2.6.2 addon: the web interface opens but I don’t get the first screen to create a userid/password…and trying the username/pw combination I used for the community addon is rejected. Perhaps just uninstalling the community addon doesn’t remove it completely???

Same issue here. Hassio, just installed portainer add-on on my and same errors
Failure
starting container with non-empty request body was deprecated since API v1.22 and removed in v1.24

Version core-2021.8.8
Installation Type Home Assistant OS

Interesting!! So the minipc one, are you able to restart your containers?
Because that is what is not working for most of us since the add-on upgraded to portainer 2.6.2.

Do note that I ony have 1 portainers instance, so I restart through the add-on portainer UI instead of an external one like you seem to be using and linking endpoints.

I have been running the version for a while… during the weekend I restart my proxmox and the portainer did restart all my docker without problem

Wondering what the difference could be. I’m not running proxmox so that is something of course. I converted my Intel NUC to debian and follow the community guide to have a supervised HA version on it ( with still access to the complete linux )

my RPI run the same thing… no problem so far. HA Core though not the Supervised like my proxmox

Glad you are not running into these issues… I hope somebody can pinpoint what is happening with our setups.

I uninstalled all portainer addons and installed portainer directly on Debian 11.
First I made sure that portainer was fully removed:

docker container ls -a

if you see a portainer container:

docker stop "container id"
docker container rm "container id"

check if there is a portainer image lying around:

docker image ls

if you see a portainer image:

docker image rm "image id"

Now install portainer:

docker run -d -p 8000:8000 -p 9000:9000 --name=portainer --restart=always -v /var/run/docker.sock:/var/run/docker.sock -v portainer_data:/data portainer/portainer-ce

Docker is now running and I can stop/start containers.

Note: you may need to also need to reset your password:

https://documentation.portainer.io/v2.0/users/reset-admin/

1 Like

Same problem. Big problem to be honest…

Same problem here… Tried to update portioner by installing Watchtower but that doesn’t install either…
Does someone know how to update this portainer docker image in the add-on manually?

Hi all; I also have the issue.
I cannot start container with portainer addon.
It seems that the container recreation / duplication is still working but portainer is not able to start them.

Error message:
" Failure starting container with non-empty request body was deprecated since API v1.22 and removed in v1.24"

My workaround is to start the container manually by ssh on the debian host system with → docker run XYZ. Once startet manually they are also restartet automatically.

I hope this issue can be fixed.

Portainer is running as addon on home assistant. System is a supervised installation on debian 10 host system on NUC.