Re-evaluate CCT with WLED and the HA WLED integration

Since 2022.2 HA’s WLED implementation has explicitly prevented any WLED devices reporting CCR capabilities from being used in HA.

I’ll be 100% honest and admit I don’t begin to understand everything that’s going on here. But I do know that myself and a ton of other Athom bulb owners (others as well) are being forced to cripple the functionality of their bulbs in order for them to be used in HA. All of the workarounds in WLED to allow HA integration prevent me from using the white channel in my bulbs.

I totally understand that there was an issue where some bulbs that had a white channel only were being displayed a color wheel, so it makes sense that the decision was made back in January to prevent them from being used in HA. However, it looks like most of the discussion between HA and WLED teams took place in Feb and March. On April 16th, Aircoookie/WLED#2500 (comment) shows that 0.13.0-b7 launched new functionality that may (or may not) give a pathway back to smooth integration between the two projects with regards to devices with CCT channels.

This feature request is to have the new WLED API functionality incorporated into the HA WLED integration and allow CCT LED’s to operate with HA again.

This pull request should add that support (work in progress at the time of writing this response)

2 Likes

Hi mate, what was the temporary solution to get the Athom bulbs working in HA? I just bought 3 without realising this issue existed

Anyone struggling with a workaround since the WLED UI: I was able to add a new WLED instance by changing the following setting.

image

Hey! Any news on this? Last night my WLED worked just fine. I woke up this morning to the same error message.