Rpi 4 installation

Do I really need the USB HUB? Is that because of only two USB 2 Ports or is there an additional reason? I intend to rebuild your setup but use the Cyrus USB Z-Wave Plus instead of the Aeotec. I currently have a Pi3 with the Razberry Z-Wave board and less then 10 Z-Wave devices and would like to switch to an USB Z-Wave with the new setup.

you only need the hub if you have Aeotec Zwave stick. The issue is described here. If you have any other zwave stick you don’t need a hub.

1 Like

looks like it’s running ok, can you see the homeassistant docker container running when you do sudo docker ps, try loging into it and running hassio ha start

30e381bcdd26        homeassistant/armv7-hassio-dns:1                  "coredns -conf /conf…"   30 hours ago        Up 30 hours                             hassio_dns
029c51b419c0        homeassistant/home-assistant                      "/bin/entry.sh pytho…"   30 hours ago        Up 30 hours                             home-assistant-homeassistant
59acb273274e        homeassistant/raspberrypi4-homeassistant:0.98.5   "/bin/entry.sh pytho…"   31 hours ago        Up 30 hours                             homeassistant
87103fd0abdc        homeassistant/armv7-hassio-supervisor             "/bin/entry.sh pytho…"   31 hours ago        Up 30 hours                             hassio_supervisor

i try login and type hassio ha start

(homeassistant) homeassistant@pi:/root $ hassio ha start
bash: hassio: command not found

Thank you very much. Thanks to your guide I’ve successfully transferred from rpi3 to rpi4 with all my zwave devices. Works like a charm :wink:

1 Like

I was on pi3 with HassOS + HAssIO and I move to pi4 with SSD and decide to use Rasberian as OS and install HassIO

How is the best way to manage Hass os configs?

here is how I did it from HassOS + HASSIO + SSH Add-on.

When SSD add-on is configured you put your SSH key and you can access your /config.

But for pi4 Hassio command is not working.

Any bits of advice about where to look ?
I want to be able to check and restart config from a console like that:
hassio ha check && hassio ha restart

UPDATE: It seems network-manager package is required for network between containers.

MAC address change fix ( NetworkManager): networking - Ubuntu GNOME 17.04: wi-fi not working -- mac address keeps changing? - Ask Ubuntu

sudo tee /etc/NetworkManager/conf.d/wifi.scan-rand-mac-address.conf > /dev/null <<EOF
sudo service network-manager restart

Now everything is working:

 » ssh [email protected] -p 2424                                                                                      
  _    _                 _
 | |  | |               (_)
 | |__| | __ _ ___ ___   _  ___
 |  __  |/ _` / __/ __| | |/ _ \
 | |  | | (_| \__ \__ \_| | (_) |
 |_|  |_|\__,_|___/___(_)_|\___/

Our Cli:
$ hassio help

core-ssh:~# has
hash    hassio
core-ssh:~# hassio info
arch: armv7
channel: stable
hassos: null
homeassistant: 0.99.3
hostname: pi4
logging: info
machine: raspberrypi4
supervisor: "189"
- armv7
- armhf
timezone: Europe/Sofia

I’m having issues doing a fresh install of hass.io on an existing rapsberry pi.
When running the supervisor docker I’m seeing:

Fails install landingpage, retry after 30sec
Pull image homeassistant/rapsberrypi4-homeassistant tag landingpage.

And indeed, when pulling manually this tag doesn’t exist.

Maybe some error in the script?

Any clues?

PS: just tried with rasperrypi3 as the -m option for the installer script → same result

I got close… but when i went to do the bash hassio_install.sh i come up with this error

[Warning] No NetworkManager support on host.
[Warning] No AppArmor support on host.
[ERROR] Please set machine for armv7l

any tips on setting machine for armv71 ?


To answer my own question, i used

sudo curl -sL https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh |sudo  bash -s -- -m raspberrypi3

and i now have it running nicely on a Pi4 :slight_smile:

Hello, i’m looking for an installation-method hassio or normale home-assistant to rpi4.
Have some problems and want some advise what is the best manner to do.

  • I have a shim-fan who needs drivers and service-script to install. Can’t get this done on HASSOS image for RPI4. Is/how is this possible?
  • What is the best procedure to install home assistant into docker (portainer-based) on an rpi4?

Read some messages that RAM will not fully used on v4. Is that only on HASSOS image?

Thank for your reply.

I would like also a step by step guide to install hassio on a rpi4 raspbian. The guide https://www.home-assistant.io/docs/installation/docker/ is outdated and for HA, not hassio.

How can you verify that it is using the SSD in Home Assistant? When I go to Hass.io --> System --> Hardware, it lists disk as


  • /dev/mmcblk0p2
  • /dev/mmcblk0p1
  • /dev/mmcblk0

I posted a guide in this thread if you scroll up, here is a link: Rpi 4 installation

Run findmnt -n -o SOURCE / (you must be sshd into rasbian and not hassio or HA)
it should say /dev/sda1 or sda2 if you are running of SSD.

I posted a link to Rpi4 + SSD guide above, if you followed it, it should work

For the fan to work you probably will need to run Rasspbian Lite + Hassio instead of HassOS+Hassio. If you install Rasspbian Lite you can just install docker then run Hassio script and it will do the rest.

So flash Raspbian Lite using BalenaEtcher

then (taken from my guide above)
Install docker (instructions taken from this thread on docker ) :
$ sudo curl -sL get.docker.com | sed 's/9)/10)/' | sh

Install hassio dependencies (instructions taken from here )
$ sudo apt-get install apparmor-utils apt-transport-https avahi-daemon ca-certificates curl dbus jq network-manager socat software-properties-common

Install hassio borrowed from here

  1. Save hassio installer to file: $ curl -sL "https://raw.githubusercontent.com/home-assistant/hassio-installer/master/hassio_install.sh" >> hassio_install.sh
  2. Run install script: `$ sudo bash hassio_install.sh -m raspberrypi4’
    or you can do raspberrypi4-64 if you are feeling adventures.

… and you are done, HA should be up and running
You can then install portrainer to manage it all if you want.
The 4GB issue only effected HassOS (Not Raspbian) but it’s already fixed so you are good to go

But that shows that Raspbian is using the SSD. Is there anyway to check is Hassio is using the SSD or is it just assumed that since Raspbian is using it, then Hassio must be? Thanks for this guide!

Not that i know off, but hassio is running from docker that’s installed on ssd, I would say you are pretty safe that it’s running on SSD as well. You can run a benchmark to see if you get high numbers to confirm

I found a way to verify it. I have the Glances addon for Hassio. For disk I/O it shows 0 read/write for mmcblk0/p1/p2 and it shows values for sda/sda1.

I’m running Home Assistant in a Python virtual environment (venv) on my Raspberry Pi 4. I’ve also installed an mSata SSD in a USB enclosure, and have migrated the /var and /home folders onto the SSD, so that most of the reading and writing is on the SSD rather than the microSD card. I’ve tried to record what I did here: https://newadventuresinwi-fi.blogspot.com/2019/11/using-usb-msata-ssd-with-raspberry-pi-4.html

I ended up doing a very similar thing to you, but I’m running Raspbian from SSD, I’m only using a 1GB Sd card as a small boot partition.

It does seem quite a bit faster than an SD card, rebooting takes less than 10 seconds.

1 Like