Supervisor Logs Extremely Slow to Open

I’m running HA OS

So it is on issue on both HA OS and HA Supervised.

I did find Supervisor issues 3014 and 3076 on Github

developing some addon currently and this drives me insane! Luckily i am not the only one…

Same problem here. Also Android app UI is extremely laggy.

I switched from hassio to debian 11 and it is fast as new :100:
Backup / Restore works great and took me nearly no work.

1 Like

After one week it is slow and unuseable again.

I’ve seen the same things since earlier this year on HASSOS. Here’s some example request timings when loading the logs:

endpoint time
/api/hassio/addons/core_check_config/logs 24.75s
/api/hassio/supervisor/logs 8.758s
/api/hassio/addons/a0d7b954_zwavejs2mqtt/logs 25.777s

I’m on a Pi4 + USB3 SSD. In the past, logs would load in no more than a couple seconds (not enough to notice or think about). My HA instance is generally snappy and responsive.

so, this drove me absolutely nuts, but i guess I found a solution this time!

After some reading I found that my USB3 SATA Adapter was not the one I thought I bought. Seems like send out different on the same name.

I bought this:
And it seems to exist as 174c:55aa and (like mine): 174c:235c

hdparm showed me extremely low values. After disabling UAS I now get this:

root@homeassistant:/usr/share/hassio/share# hdparm -t /dev/sda

 Timing buffered disk reads: 542 MB in  3.00 seconds = 180.64 MB/sec

And for a pretty cheap SSD with a full running system, this is totally fine.

Logs are fast as desired now <3

This helped me: STICKY: If you have a Raspberry Pi 4 and are getting bad speeds transferring data to/from USB3.0 SSDs, read this - Raspberry Pi Forums

I also have an SSD, and I checked the speeds with hdparm -t /dev/sda, I have not disabled UAS and I get the below:

Timing buffered disk reads:  637 MB in 3.15 seconds = 206.753 MB/s

My logs are all still extremely slow…

1 Like

give disabling UAS a try? :slight_smile:

This might be a total silly question, but it seems I don’t have hdparm at all on my installation (Raspberry 4).
Also, I don’t have e.g. apt-get to install it. How can I install hdparm?

I ran it by doing an SSH into the OS itself (port 22222).
Normal SSH goes into the HomeAssistant container.

Assuming you’re running HassOS…

This seems not to be possible on a Raspbian installation, at least remote. Might have to find an HDMI cable and boot it with keyboard & screen attached…

So booting with a screen & keyboard attached, I could run hdparm on the Raspberry installation. It says it read 716MB in 3 Seconds, which is ~250 MB/s. This should be more than sufficient, but as @Veldkornet wrote, it still feels much slower and less snappy than it did earlier…

Disabling UAS as @MaxW mentioned solved the issue with the logs for me. Also restarting the core and loading of the history is much faster, now. :+1:

You’re right, the logs are fast again. Weird that my speeds didn’t seem to change though:

Timing buffered disk reads:  636 MB in 3.00 seconds = 217.004 MB/s

FYI, I have an Argon One M.2 with a Samsung M.2 SATA SSD and my cmdline.txt ended up looking like the below:

usb-storage.quirks=174c:55aa:u dwc_otg.lpm_enable=0 console=tty1

I might be wrong with the speed thing as proof, but I can recommend everyone with issues to try the UAS disabling thing.

I’m also running Home Assistant OS on a SSD. Reading the info on the raspberrypi forum mentions unplugging the SSD, but isn’t that impossible because the OS is running from that thing?
Could somebody write a little howto on disabling UAS on Home Assistant?
Thanks in advance!

I also run only an SSD, so I also did it in-place. This is what I did:

  • SSH into HassOS, that’s port 22222 (not the HA container on port 22), I used this to enable 22222
  • run dmesg | usb And examine the Vendor ID (vid), Product ID (pid) As per the RPi forum post. Just have a look carefully here, my ConBee and ZStick were clearly marked as such on the usb1-1, so the only one left for me was the one on usb-2-2 (if you’re really unsure, maybe unplug all other usb devices and reboot the host, then check dmesg again). Example of mine:
[    1.990062] usb 2-2: new SuperSpeed Gen 1 USB device number 2 using xhci_hcd
[    2.011145] usb 2-2: New USB device found, idVendor=174c, idProduct=55aa, bcdDevice= 1.00
[    2.011179] usb 2-2: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[    2.011205] usb 2-2: Product: Forty
[    2.011228] usb 2-2: Manufacturer: Argon
[    2.011251] usb 2-2: SerialNumber: 0000000000XX
  • Edit the cmdline: vi /mnt/boot/cmdline.txt And add the storage quirk at the beginning of the line, mine looked like this: usb-storage.quirks=174c:55aa:u dwc_otg.lpm_enable=0 console=tty1
  • Save the file and reboot the host
  • finished, if you SSH to 22222 again and run dmesg | grep usb again, you should see something like the below
[    2.014012] usb 2-2: UAS is ignored for this device, using usb-storage instead
[    2.014137] usb 2-2: UAS is ignored for this device, using usb-storage instead
[    2.014169] usb-storage 2-2:1.0: USB Mass Storage device detected
[    2.014740] usb-storage 2-2:1.0: Quirks match for vid 174c pid 55aa: c00000