Time Zone Error while installing, need help

Tags: #<Tag:0x00007fc42f67b150>

I installed HASS on a clean android device. When setting up for the first time, it detects my location correctly, but displays this message:

2021-06-29 15:14:05 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection] [518230409952] Error handling message: Invalid time zone passed in. Valid options can be found here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones for dictionary value @ data['time_zone']. Got 'America/Santiago'


i have tried with all time zones available there, but no change
maybe i can skip the onboarding process, configuring it directly in the hass files?

1 Like

I didn’t even know HASS worked on android.

Exactly the same issue…

you need to install the tzdata package

use

pip install tzdata

to do that

3 Likes

Yes, found out after a while:

thanks , that’s great