Upload of yaml file not happening

I have installed the polulu CP2102 drivers on both windows 10 and 7, and tried to upload the yaml file.
The esp32dev board is connected by usb cable to the computer
The upload fails I did hold down the boot button while trying to flash the board, but still the same error about python files

UndefinedPackageVersion: Could not find a version that satisfies the requirement '1.1.1' for your system 'linux_aarch64':
LibraryManager: Installing id=12172 @ 1.1.1
  File "/usr/local/lib/python3.6/dist-packages/platformio/builder/main.py", line 168:
    env.SConscript("$BUILD_SCRIPT")

There are another 12 lines of this error relating to different python files

Is this because the python library is not installed , or because the syslabs CP2102 drivers are not installed.
Does a python library need to be installed.

Thanks

Weird because windows is not linux_aarch64. So what on earth are you actually doing?

easiest way to get software into tour esp devices:

  1. install esp-home addon in HA
  2. enter your yaml config save and hit install
  3. choose ‘manual download’ to download the bin file
  4. on your windows 10, use your CP2102 to upload the bin file to your esp device. You can use a tool like esphome-flasher, but there are many more around.

Once your device is up and running, ha should report a new device found and you’ll be able to add it.
Any further configuration change, you will be able to do straight from the add-on using OTA (OverTheAir)

We are assuming the device has a cp2102, yet we’re not even told what the device is.

@nickrout
I connected the esp32dev board by usb to my windows10 laptop, then I clicked on the upload button on the yaml file in esphome. I also pressed down the boot button the esp32dev board.
And yes I have the CP2102 drivers installed

When I select ‘Upload’ for the yaml file in esphome, It says that it is looking for AsyncTCP-esphome library in registry
Conflict: More than one library has been found by request (“name” : “AsyncTCP-esphome”, “requrements”: “1.1.1”): AsyncTCO-esphome

And esphome is running on a rpi, via the ha addon?

If so that error message is nothing to do with windows I think.

I edited my earlier reply above with more information.

Yes HA or esphome is running fine on a Pi3.

Also, what exactly are your versions of esphome and home assistant, including install methods. The reference to python 3.6 in the error message makes me think something is very very outdated.

Home Assistant on my computer is version 2021.8.2
In ESPhome, at the bottom it says [email protected] v1.15.3 Documentation

Ahh yes, that is probably the reason.

Any reason you haven’t updated?

Any reason why you didn’t answer all of my question? (eg Install methods). Please pay attention.

Apologies, I thought I did answer on the install method.
Plug esp32 board into usb port on my laptop
Open up esphome in HA, then select / click on ‘upload’ on the said yaml file.

that’s it??

No reason why I didn’t update, but how do I update esphome. Mistakenly I thought it was part of HA being as it is just a link in the left side menu

Clicking on the ESPhome addon in HA it says current version is 1.15.3, but I don’t see anyway of updating it.

Thanks

No I mean how did you install ha and esphome onto your pi?

Same as you update any addon. Go to the addons page, click esphome, click update.

The current version is 2022.12.3 :wink:
image

@nickrout
aah sorry.
Well, the best I can remember from 2 years ago, I flashed an sd card with the relevant img file, using balena etcher on a linux system.
HA is on my Pi3, and I’m not sure I put esphome on the Pi3??? To be honest I don’t remember, and if I had to start again I’d have to google it all

Do you mean the addons as in integrations in HA

No I mean addons, like here Open your Home Assistant instance and show your Supervisor dashboard.

Thanks for the clarification.
As there is no update icon / button for the addon ESPHome, I can’t update it directly. I noticed the Auto Update selection? was off, so I turned it on. Now it seems I have to wait until a new version of ESPHome is installed. Unless there is another way of doing so.

I know at some point they changed the repository URL,
You can also check this post.
If I understand correct, you can just delete the old addon, and the new version should become available, although some people have to add it manually by adding GitHub - esphome/home-assistant-addon: ESPHome Home Assistant Add-on ;maybe the ‘Add integration’ from here also works

In my case I had to add it manually using the Add-On page with the 3 dots:

@aceindy

I installed a new esphome addon , then uninstalled the old version.
Now when I look at my yaml file, at the bottom, with old version it said EDIT VALIDATE lOGS, with the new version, it now says UPDATE EDIT LOGS .
At the top right corner of the said file, it says OFFLINE in red letters.

Advice please.

What version do you have now?

Does it compile and upload?