Vimar - 14592.0 - Small switch with Zigbee and Bluetooth technology

Hi Guys, I wanna share with you this switch that I just bought for some test.

https://www.vimar.com/…/…/catalog/product/index/code/14592.0

It works as standard switch, plus you can choose to use it with bluetooth or zigbee.

It just arrived, I am trying it as zigbee: it is recognised in HA as light. I am using deCONZ+ conbee II.

I do not know if I will be able to control the led (it is multicolor), but with his propetary app in BT mode you can.

I already have all switches from the same vendor all around the house, this is the perfect solution for me as I can add it also in existing elecrical system without any issue.

I will make some test and keep you posted.


image

2 Likes

Hey @Andrea_Pasqualini, I also would be very interested to know if you made any progress with integrating that switch with HA. I am considering putting a bunch of those switches in my next home, and I would like to hear your experiences.

Hi All,

apologize for late reply.
Unfortunately I didn’t make any additional test since, when I put under load the switch, I broke it down. I will rebuy the same one but this time an electrician will assist me :smiley:

From the test I did (deCONZ+ conbee II) it recognised it as light, but when i press the phisical button HA do not show any change (probably because there weren’t any light attached to it), while activating from HA switch respond correctly.

I will make an uptdate once i will mount the new one. It will take a while since HA is not working anymore (probably sd error).

Ciao

Hi all,

I call my electrician and, unfortunatly, my electrical system do not allow this button.
I should replace every buttons even if they refer to the same lamp; it is not my intention to proceed in this way, so I am looking for another solution.
I my use it for the lamp that are commanded by a single button, in case I will update you.

Ciao a tutti,
I have been using the vimar smart switch 14592.0 (deviatore connesso) since last summer and I must say that it has always worked very well. I control it via deconz and conbee ii key. With the recent firmware update it no longer works as it should, instead of doing On or OFF it just TOGGLE the power. So, if in the group there is a light on and the others are off, the group state is ON, but if I try to turn off the group all the lights turn on and the one that was on turns off.
I can’t solve this problem. Help!

1 Like

I have the same problem, I noticed it when I inserted the switch in an automation.
The switch_on or switch_off commands is like toggle.
You have news ?
Was the problem always present with previous Conbee firmware?

Unfortunatly no news to report.
This bug is not related with conbee firmware.

Hi, any update about Vimar? I used with ConBee II and DeCONZ and it has been recognized as switch, now that I moved to ZHA as integration I cannot find it anymore. Someone is using correctly with ZHA? Thanks!

They just updated the app. It brings the new zigbee firmware. Later I’ll try to update to see if the behavior in Deconz is correct respect current “light” setup.

This the response from Vimar about the Zigbee limit:

Con riferimento alla richiesta di supporto tecnico inviataci siamo a comunicare che il prodotto è progettato e testato per lavorare specificamente con l’hub ZigBee integrato a bordo di alcuni assistenti vocali Amazon (es. Echo); possiamo tuttavia anticipare che stiamo già lavorando ad una nuova versione firmware per il deviatore connesso in questione che uscirà prossimamente, quindi consigliamo di attendere il nuovo aggiornamento che verrà reso disponibile nel relativo store per l’app VIEW Wireless: ad app aggiornata ed accedendo al suo menù Azioni → Gestisci dispositivo potrà applicare il nuovo firmware sull’apparecchiatura.
A disposizione per eventuali chiarimenti, porgiamo Cordiali Saluti.

UPDATE: Works as before (firmware Zigbee 2.0.1) so in a bad way with HA.
If you toggle from the button, HA is not updated in anyway, no status on/off and no toggle. If you toggle from HA it works just as a push button with no state, just toggle.
For me it’s useless, I expected it worked like a pushbutton in monostable relay, but as a switch in bistable. I’ll try using MQTT, but definely not the best solution.

UPDATE 2: This the response to my last mail.
Pur confermando che effettivamente il prodotto in questione a livello ZigBee è progettato principalmente per l’interfacciamento con l’hub ZigBee integrato a bordo di alcuni assistenti Amazon Alexa, possiamo consigliare di verificare il carico collegato al deviatore in questione: è infatti importante che il prodotto rilevi un assorbimento sulla propria uscita di almeno 2W per poter funzionare correttamente. Confermiamo che oltre a questa condizione, una volta aggiornato il firmware ZigBee alla versione 2.0.1, non vi sono altre verifiche da condurre.

Positive update, recognized as switch and it works perfectly with ZHA!!
Just for testing I moved back to BT using Vimar app, then moved again to Zigbee and there was a firmware update in the app…and from this moment found in ZHA as switch!

Guys you know that there is an integration for the “old” Vimar by-me via the web-server to HA, right?
I’m in any case interested. Are this switches fitting in “Eikon” or “Plana” slots? What they need to be powered?

Using HA on Raspi4, supervised
Sonoff Zigbee 3, firmware v 2022
Zigbee stack: ZHA

The vimar switch is detected, after pressig for 5 sencods the switch.
There are two yellow warning that canot understand…

BUT…
image

BUT when acting on the control on the HA dashboard, the feedback on the dashboard goes back to off in few seconds, even if the real switch is on

The documentation for the other Zigbee mqtt stack says that tha status of the switch is publisched in the state variable. Vimar 14592.0 control via MQTT | Zigbee2MQTT
In zha the status is non corretly reported in the dashboard. In the screenshot it is showed off, but it is on.
Still not tested in mqtt, because started using zha.

The device is reported to work both in ZHA and MQTT. For what I can see, it is not working correctly in ZHA Vimar 2-way Switch IoT Connected Mechanism (14592/16492/19592/20592) Zigbee compatibility

KINDLY ASK

  1. Have you tested if the state get updated corretly with a load of > 2W ?
  2. Any difference in using MQTT instead of ZHA ?

BR
Giuliano

In ZHA, the device is stated to report the status too… obviously it is not working, at least wit a led pilot lamp

Is it worth to give a try with MQTT ??

Just to highlight some IMPORTANT documentation:

CONTROLLABLE LOADS.
For correct load state signalling, connect a 2 W minimum load.

RESETTING THE DEVICE.
The reset restores the factory settings. Within the first 5 minutes from powering, press the
button for 30 s until the white LED flashes.

Set the actuator parameters.
press the button for 15 s; this way, you can select the relay operation - between one-po-
sition stable and two-position stable (the LED flashes green for the two-position stable setting
and amber for the one-position stable setting)…
you can set the one-position stable activation time.

Ciao a tutti! ho appena installato uno switch 14592 tramite zigbee2mqtt (Z2M), il controllo da homeassistant funziona correttamente (riesco ad accendere e spegnere il carico collegato), però se interagisco con lo switch direttamente non mi si aggiorna lo stato in homeassistant a meno che non vada nell’interfaccia grafica di Z2M e forzi il refresh.

Inoltre io ho collegato lo switch con un invertitore ed un deviatore in cascata (di fatto ho la necessità di controllare la luce da 3 interruttori) se cambio lo stato della luce da uno di questi dispositivi anche se forzo il refresh da Z2M non rilevo lo stato, voi avete avuto qualche esperienza a riguardo?


Hi everyone! I just installed a 14592 switch via zigbee2mqtt (Z2M), the control from homeassistant works correctly (I can turn on and off the connected load), but if I interact with the switch directly the status in homeassistant doesn’t update unless I go in the Z2M GUI and force the refresh.

Furthermore, I have connected the switch 2 multiway switches in cascade (in fact I need to control the light from 3 switches) if I change the status of the light from one of these switches the homeassistant status do not update, even if I force the refresh from Z2M.
Have you had any experience on this?

Hi, the 14592 switch works very well for me, but in my zigbee system some other devices just started blinking every 5-10 seconds. This is because I had the option “Activate the identification effect when devices join the network” active in ZHA. I have now temporarily switched this off and now everything works perfectly.
But does this mean that the switch reconnects to the network every 5-10 seconds? And is that bad for my network?

regards

Reminder this is an English language only forum. Getting help in languages other than English