Xiaomi Sherlock Smartlock

Now I see that you use only to unlock?

And you use the single signal to unlock?

I also use only unlock but use the default settings (so I guess double signal, and perhaps that’s the problem??

Need to check if single signal is more reliable

Unfortunately no, but it is fairly easy to program, I did not go for this solution, but I think is enough to apply ground to the connection of the key twice with 500ms delay with Arduino.

If you have someone who if familiar programming in C, you could use only 1 sonoff and just send the signal once when the relay is open and twice when it is closed.

Yes, I have the setup on the pics and use 1 click to open. You can change it in the app.

where is tis in the app, “Reverse Lock Direction”?

Yes, that is the one

Yes, that was it: doing OPEN with single signal it gets all the time. Now I have a doubt that my settings for CLOSE are not correct which do you use?
Below mine

  - platform: template
    name: "close_door"
    icon: "mdi:gate"
    - switch.turn_on: relay
    - delay: 500ms
    - switch.turn_off: relay
    - delay: 100ms
    - switch.turn_on: relay
    - delay: 500ms
    - switch.turn_off: relay

Ok, so you tried 700ms 200ms and 700ms and you reeached 90%, cool. Will try this.

Wonder if with higher values we get to 100%


Hi, you still satisfied with the result of the neodimium plus aqara sensor?

Hi Tamas,

can you post picture with BT key where you make connection on the switch and what resistor value you use?

BR, Dimitar

Device al ready bound, please reset the device

Eh enviado 7 correos a todas las direcciones encontradas aquí y en la pagina.
Xiaomi se ha ido a quiebra. No contestan, No responden,

Device al ready bound, please reset the device.
Alguna idea para resetear el apartato.
Nesecito ayuda, no me contestan los correos.
Me sale este mensaje: Device al ready bound, please reset the device.
LLevo 1 mes escribiendole por correo a sherlock xiaomi. No me contestan.
Pueden ayudarme. Gracias

hi i also have the same problems. my device stopped working and i tried to reset the device.
after reload the device, it failed to test and i can’t access it again neither to unbind the device.
have you solved this? thanks.


I have the same problem (test not completed, try to test > device must reinstalled) how you solve it?

Thanks in advance.

I had to contact the developers and they unlocked/untied it. Worked fine after that.

Thank you for your reply, can you share the contact of the developers ? please.

It’s in one of my earlier posts linked in a reply above… Here it is again.

Good morning,

Sherlock smart lock doesn’t work.

It was working ok, but yesterday the app doesn’t work, and it has disappeared from Google Play Store.

It has battery, the light is green, the bluetooth is working because we can find the lock with our phones.

We’re trying to pair the lock once again but it didn’t find the smart lock (device already bound, please delete it first), and it’s said that we have to delete the lock and pair it once again, but we’re trying to do this and the app don’t find it!

It’s said that be sure of have the latest update for the app, but we can’t find it in Google Play Store.

We’ll have to uninstall the smart lock because it doesn’t work and we can update the app.

Waiting for your reply as soon as possible.

No contestan a correos, la aplicación desapareció de play store.

1 Like

Doesn’t work for me

Hi, is this working? Which version of the app I have to install?

I’m currently using M1 version with a phone MiHome app controlled by adb, success rate is about 75%
Is it worth upgrading to S2 to improve success rate?