Yale Smart Lock

So i have a new smart lock, but HA doesn’t show hardly anything in its UI.

I’m still confused as to why HA has none of the configuration options that OZWCP has, the whole new “Zwave” section is supposed to replace the need to use OZWCP right?

The lock has many features that can show alarms, change pins etc etc, but only 2 sensors show in HA, so how do i go about adding all the other features?

1 Like

Which one do you have?

I plan to buy this…


…but not sure can it be controlled (lock/unlock) by HA or not. Has anyone used this? Please share your experience before I purchase this.

I have this on our front door https://www.safe.co.uk/products/yale-keyfree-with-remote-module-chrome.html

If you take a look at this link, Vera has tons of other options that HA doesn’t. I assume the lock has many other features there, so how do i get to them? I’m happy to do some scripting/programming if that’s what is needed but only higher level


Spoke to yale and they say they have partnered with smartthing, vera and others. Does this mean zwave can be partially proprietary or something? Surely they can’t lock down certain features to certain manufacturers?

Did you use “Add Node Secure” in Zwave? Locks and other secure devices typically need that. They typically have reduced functionality until you add them securely.

You typically need to generate an add a secure key to complete this procedure. Issues to securely add a zwave device

@BendedArrow I actually did consider that, because assumed that because it allowed me to add it insecure it wouldn’t be a problem.

I didn’t add secure because nothing else in my network is, so thought i would have to remove and readd everything again? Does it reduce the performance of the mesh?

I’ll add it as secure anyway and report back with results.

Where does options.xml need to reside? I edited this one with no joy:


Everytime i do this i have to remove the node and its sending my nodeIDs very high :smiley:

Does home assistant not use system libs anymore, should I be using this instead?


Sorry for the multiple questions but its all related so may as well keep it in this thread.

Ive noticed that HA loads an XML when it finds my device, but its called “Yale Touch Deadbolt”, I wen’t to this XML file and found two products listed here on the z-wave alliance website:

<Product xmlns='http://code.google.com/p/open-zwave/'>
<!-- Yale Touchscreen Deadbolt (YRD220)

This isn’t the model of my device, so i went to this website and found it, how do i get HA to use this XML instead, or does it not offer anything different?


Any update on this? I’ll be jumping in, in about 3 weeks time :wink: :smiley:

Locks require a secure addition for full functionality.

Did anyone get this to work it’s on sale today on Monoprice

Yes. I got it to work. It works flawlessly. I can unlock and lock the door from HA. It also reports back who lock/unlock it, the battery status, etc… I am really satisfied with this lock.

can you give instructions to get it working?

I am having a new door installed with this Monday and will no doubt need help :slight_smile:

Total noob here, but I just bought a similar lock lock (YRD 200) and after adding it to my network unsecure and being frustrated I finally followed instructions and added as a secure node (through Z-Wave config in HA) and it works great. The lock/unlock state on the HA launch screen doesnt work like you think it should, but the alarm type node (sensor.assa_abloy_unknown_type0002_idaa00_alarm_type) node reports a change for the different types of operation. (manual, key code, RF) Now I just need to connect the dots on what the alarm state codes mean what and figure out how to actually use HA to custom configure groups/nodes/actions/etc.

I have this lock, and have been able to activate the lock and unlock services using the hassio user interface. I had to add this lock securely (as per the above answers). I created a user code specifically for hassio, so that I could tell the difference between lock/unlock events commanded by automations and those that were entered by other users. Of note with this lock, it appears that a user code must be entered in the JSON.
For example: {"entity_id":"lock.front_door_lock_locked", "code":"1111"}

Here’s another Yale thread with some code sprinkled throughout. I got my locks working from this and learned a lot…

I’m a little newer to HA and have just got my Aeotec Gen 5 stick connected/configured. I have the Yale YRD210 and when “paired” using secure node, I see a funny item in the HA front-end. Seeing your comment makes me think there is a way to use the XML file found on the zwave alliance site.

Did you ever figure out how to get HA to do this?

Hi guys, I bought last year a Yale smartlock 25 YRD256 , originally bought with zigbee module, but after I bought a z-wave stick I bought the z-wave module and I’m trying to set it up with that.

The first time I didn’t set it up with the code because I’m a noob and of course wasn’t working, so I followed some posts here on the forum, I removed the node, add a key on configuration.yaml and added it as secure node but doesn’t open or close, it says it’s open also when it’s closed. It’s saying is Yale 446, I Don’t know why! Anyway doesn’t work, if I check the info, it says 43 cnd received and it never failed but still isn’t working. Somebody has an idea to how to fix it?

I have the same lock and it also shows as 446. After adding it as a secure node, everything works. Values update almost instant and config changes through zwave control panel have all worked. Using a template to display “human readable” status also works quite well.

I had problems at first not adding secure and then trying remove/add secure to get it to work. It might be holding on to old config somewhere. I found completely removing zwave devices tricky. I ended factory resetting zstick and devices and starting with a fresh install of hassio. Has worked flawlessly since. Good luck.

1 Like

Thank you so much bud!!!

I think I’ll do the same, I’m happy to know somebody has the same device and it worked!

It sucks I gotta reset the z-wave but whatever at least after everything will work!

Thank you so much! I appreciate that! I’ll let you know as soon as I have some time to do it.