ZHA - Lutron Aurora Dimmer Blueprint

I’ve been playing with this. Is there any way to tell if the button was pressed? I see the events coming from button pressing as identical to when you twist the dial. The difference is just in the args[0] value. Is there a way to interpret the args[1] value? Thanks again.

@deaton.dg - where do you see transition time and group? It would really help if you can share your automation.

Sorry to take so long here, just seeing this now.

My blueprint is for Zigbee2MQTT and not ZHA, but here it is:

blueprint:
  name: "Aurora Broker v0.1"
  description: 'Create lutron_aurora events from the state_changed of an Aurora.'
  domain: automation
  input:
    dimmer:
      name: Aurora
      selector:
        entity:
          domain: sensor
trigger:
- platform: event
  event_type: state_changed
  event_data:
    entity_id: !input dimmer
condition:
- condition: template
  value_template: >-
    {{
      trigger.event.data.new_state.state == "brightness_move_to_level" and
      trigger.event.data.new_state.attributes.action == "brightness_move_to_level"
    }}
action:
- choose:
  - conditions:
    - condition: template
      value_template: >-
        {{
          trigger.event.data.new_state.attributes.action_level > 0 and
          trigger.event.data.new_state.attributes.action_transition_time == 0.02
        }}
    sequence:
    - event: lutron_aurora
      event_data:
        entity_id: !input dimmer
        type: "level"
        level: '{{ trigger.event.data.new_state.attributes.action_level }}'
        attributes: '{{ trigger.event.data.new_state.attributes }}'
  default:
  - event: lutron_aurora
    event_data:
      entity_id: !input dimmer
      type: "toggle"
      attributes: '{{ trigger.event.data.new_state.attributes }}'
mode: queued
max: 10

In my experience, this is able to correctly distinguish between a press and a twist 100% of the time.

2 Likes

I was excited to give this Blueprint a go, but the Blueprint isn’t even allowing me to select the Aurora. I’ve got it paired directly to HA through ZHA, but I can’t create an automation with that switch. Any help would be appreciated!

@padlocked17 there are a couple of attributes that the blueprint looks for in order to select devices. Would you be able to look at the device page for this dimmer in HA and verify the Manufacturer is Lurton and Model is Z3-1BRL. Also, there should be one entity for their device, the battery.
Just want to make sure the there isn’t a slightly different model out there.
Thanks.

1 Like

@sorrygofish I missed this conversation earlier. My notifications weren’t making to my mailbox.
I haven’t found a real good description for what the second arg in the event is. But it appears to be set to 2 or 7 depending whether the button was pushed or the knob was turned. Sounds like that maps to the transition_time in @deaton.dg ‘s blueprint.

The value switching between 2 and 7 is the thing that zigbee2mqtt refers to as transition_time, and I believe that’s what it is intended to be. In my observations, the Aurora sends a transition time of 2ms any time that it thinks its sending something subtle, but a 7ms whenever it thinks dramatically changing the state of the light.

In particular: a knob turn always results in 2ms, a button press when the Aurora thinks the light is off always results in 7ms, and a button press when the Aurora thinks the light is on results 2ms if it thinks the brightness is around 15ish or below and 7ms otherwise.

Turning the knob always make the Aurora think the light is on, so you can test this by twisting the knob to the left for a bit, and then pushing the button. Since the Aurora thinks the light is on with brightness 2, it will send a 2ms transition time with the button press.

1 Like

Hi, with this bluprint I can use the Aurora with any light? Or just Hue brand? I have some Wiz Connected light that work with Wifi integrated in to HA. Thanks!

Hi @arielo61
This blueprint does not require hue lights. It works with other light brands and integrations and I would expect Wiz to work.

Thanks @deaton.dg (and @bjpetit !)

@bjpetit : your blueprint works just as many have said here - dimming works great, but button presses for power are rarely successful.

@deaton.dg : I’ve tried your code but it seems while creating an automation, I can only select the battery power entity of the Aurora; I can’t assign automation to it to handle any actual dimming or toggling of power. As you mentioned, It may be due to the fact I don’t use Zigbee2MQTT - just ZHA via the Nortek stick.

Is there some mashup of your codes that might yield a blueprint that handles the proper dimming and toggling on/off via ZHA? Pulling my hair out over here.

Thanks!

The issue is definitely the Nortek stick. I spent hours researching and troubleshooting this same issue. I added a Conbee II to my configuration and this blueprint now works flawlessly with ZHA.

1 Like

Did you find a solution to this issue? The automation works great, but I have the same sort of issue.

Another example is turning the light on via a motion automation. If you then press on the Lutron switch nothing happens, but if you press it again lights go off.
This may be more like pressing it once leaves the lights on permanently vs the motion activated timeout the first press, and then off the 2nd press.

I switched to a Conbee II, using zha instead of deCONZ. While the Aurora works with the blueprint…it’s inconsistent at best. Regardless of sensitivity settings (1-3), there is often a delay in the lights responding…if at all.

All lights are Hue (6 downlights) and most are within 10 feet of the Conbee II dongle, which is already on a USB extension cable.

2021.12.x (tried with various 2021.12.x revs). Conbee II firmware is current (can’t check version since deCONZ was uninstalled, but I did flash it before moving to zha)

This blueprint worked great with my CC2531 coordinator, but today I switched to the Sonoff Zigbee 3.0 coordinator and the Lutron dimmer is the only device I can’t get working. Flashed the newest firmware on the coordinator before migrating everything over. The Lutron is definitely showing up in ZHA, just no response to button press or dial. It seems like the only sub entity HA has is for the Aurora’s battery sensor.

1 Like

I had the same desire, I tweaked Brent’s great code to toggle instead of following the dimmer’s brightness settings. Try this: ZHA - Lutron Aurora Dimmer Blueprint - toggle button press

This is one of my frustrations with the Lutron Aurora. The issue is that it has its own local state on the device itself, which it treats as the source of truth, and there doesn’t seem to be any way to push updates to it to sync it with the Home Assistant state.

If you turn on a light in Home Assistant, the Aurora thinks that the light is still off. When you press it, it’s sending a “turn on light” message (in reality it actually sends a “set brightness to 255”) but the light is already on! That’s why it takes two presses — the second time, it actually knows that the light is on.

There’s a similar issue with dimming, in that the current dimmer value is stored on the device too, and brightness is sent as an absolute value (i.e. “set brightness to 150”) rather than a relative value (i.e. “decrease brightness by 30”). If you dim the light in Home Assistant, the Aurora still thinks that the brightness is the old value, so if you turn it to dim/brighten, it will start from the old brightness, as if you had never changed it in Home Assistant.

Other devices use a “toggle” event for press, and two separate brightness increase and brightness decrease events for dimming, which ends up being more flexible. The Aurora only sends “set brightness to x” events.

Not sure about ZHA but I use Zigbee2MQTT and there’s no way to differentiate button presses from brightness changes, as the payloads look the same :confused:

1 Like

Oddly your blueprint also doesn’t work for me. Are you using the SonOff v3 USB coordinator? Much appreciated!!

Did you ever get it working? I am having the same issue with the lutron dimmer and sonoff zigbee 3.0. I have been able to connect it to ZHA but the only thing it returns is the battery level. Nothing comes up on events when the button is clicked or dimmer rotated. Thank you!

I just got some of my un-used Auroras out last week when I found this blueprint. I was able to Pair the Auroras to ZHA and my Cnnbee II but automations I create only seem to work after i’ve toggled the aurora a few times, almost like they are asleep.

Two of the AUroras work right away and those are both about 2 feet away from the Conbee II stick but i have 4 others that are between 25 - 45 feet away that are non-responsive for a few seconds unless I tap or turn the dial a bunch.

Seems like its related to ZHA or the Conbee stick rather than the automation but does anyone have any tips on how to get it to be a bit more responsive. I have a few other devices paired via ZHA that are further away and work fine.

I just got this device and originally got it hooked up fine to my Nortek HUSBZB-1 and I tried bjpetit’s blueprint but it wasn’t reacting well to the button presses. I then realized I could pair it directly with my bulb which works great and no issues with the button presses or dimming.

I managed to keep this bulb pair and it appears I still have the device in Home Assistant as well, but I am not 100% sure the device is really connected…I can’t seem to test for any events in the Developer Events.

Anyway, has anyone utilized the direct bulb pairing and ZHA in Home Assistant? I would like to at least monitor the battery state (show’s it is there) in Home Assistant and maybe have the switch also do something else in the future when button is pressed or dimmer is used, along with controlling the paired bulb.