ZHA Zigbee Tested Devices...Please add your device results


#363

1st of all, Bosch ISW-ZPR1-WP13 is humongous.
2nd, i couldn’t get it working with 0.70. It joined the network fine, was properly detected by HA, but then for some reason in voluntarily leaves the ZigBee network.

2018-06-10 17:33:46 INFO (MainThread) [zigpy.application] Device 0x9f1b (00:15:5f:00:b4:4c:aa:c5) joined the network
2018-06-10 17:33:46 INFO (MainThread) [zigpy.device] [0x9f1b] Discovering endpoints
2018-06-10 17:33:46 ERROR (MainThread) [zigpy.device] Failed ZDO request during device initialization:
Traceback (most recent call last):
  File "/home/lex/lex/src/zigpy/zigpy/device.py", line 51, in _initialize
    epr = await self.zdo.request(0x0005, self.nwk, tries=3, delay=2)
  File "/home/lex/lex/src/zigpy/zigpy/util.py", line 52, in retry
    r = await func()
  File "/home/lex/lex/src/zigpy/zigpy/device.py", line 89, in request
    expect_reply=expect_reply,
  File "/home/lex/lex/src/bellows/bellows/zigbee/application.py", line 214, in request
    assert sequence not in self._pending
AssertionError
2018-06-10 17:33:46 INFO (MainThread) [zigpy.application] Device 0x9f1b (00:15:5f:00:b4:4c:aa:c5) joined the network
2018-06-10 17:33:46 INFO (MainThread) [zigpy.device] [0x9f1b] Discovering endpoints
2018-06-10 17:33:47 ERROR (MainThread) [homeassistant.core] Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/usr/lib/python3.5/asyncio/tasks.py", line 239, in _step
    result = coro.send(None)
  File "/home/lex/lex/src/bellows/bellows/zigbee/application.py", line 214, in request
    assert sequence not in self._pending
AssertionError
2018-06-10 17:33:57 INFO (MainThread) [zigpy.application] Device 0x9f1b (00:15:5f:00:b4:4c:aa:c5) left the network
2018-06-10 17:33:57 INFO (MainThread) [zigpy.application] Device 0x9f1b (00:15:5f:00:b4:4c:aa:c5) left the network


#364

If I recall that was the same issue from the past, it would be detected and then disappear or not work. Was hoping it might have been solved by now. When on sale the price is hard to beat unless of course it doesn’t work.


#365

Yes, that was the same problem I had.

I’m honestly amazed that with so much interest in these sensors that someone (who knows how to do such things…) hasn’t either added the functionality to the HA zigbee component or has come out and said that they will never be added and give the reason so people stop buying them and wasting time and money.

It’s just completely ignored by the powers that be.

Heck, seeing as I’ve got four of them sitting around completely useless I could even be open to donating one to the cause.


#366

I don’t know what is happening with Bosch motion sensor. I can see it getting successfully enrolled, but then it just leaves the network. I didn’t see too much difference in the code compared to the smartthings device handler.


#367

I also have 4 of the Visonic MCT-340 E door/window sensors and while all 4 work correctly for detecting open/close only 2 of them show the temperature while the other 2 show as unknown.


#368

I have 6 of them and all are showing temp
After I got them paired I opened and closed the door a couple
of times to trigger the tamper switch and then restarted hassio
and now all of them show temp all of the time.

If that does not work one I had to remove the batt and then
re insert and all was good.


Kwikset Zigbee Deadbolt
#369

Tried all that but still doesn’t show for those 2 :frowning:


#370

This is funny. I have three of the MCT-340 E sensors and NONE of them successfully show temperature. The entity is there, just no data: “- °F


#371

My 2 Visonic MCT-340 E have completely stopped working.


#372

As I stated above have 6 of these and they all report temp perfect
the one thing that was driving me crazy was that the temp was not
rounded and looked ugly, but that was fixed in 0.71.0

As I added new ones after doing ZHA permit and connecting the sensor
after that I put the sensor close to my ZHA stick and removed the battery and waited 30 seconds then replaced the battery and in a few
minutes each one showed the temp.

Not sure why they are not working for other people.


#373

Since it has been awhile I decided to try it again keeping my fingers crossed and lo and behold after taking the battery out, putting it back in and pressing the button a few times the temp is now showing for the 2 sensors I have that were not previously showing it.


#374

I can no longer get the Samsung outlets to work with zha. They pair ok, but after restarting HA, I get the following error and the device is no longer available.

2018-06-18 23:18:25 ERROR (MainThread) [homeassistant.components.switch] Error while setting up platform zha
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/helpers/entity_platform.py", line 129, in _async_setup_platform
    SLOW_SETUP_MAX_WAIT, loop=hass.loop)
  File "/usr/local/lib/python3.6/asyncio/tasks.py", line 358, in wait_for
    return fut.result()
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/switch/zha.py", line 27, in async_setup_platform
    await cluster.bind()
  File "/mnt/homeassistant/hass/deps/lib/python3.6/site-packages/zigpy/device.py", line 89, in request
    expect_reply=expect_reply,
  File "/mnt/homeassistant/hass/deps/lib/python3.6/site-packages/bellows/zigbee/application.py", line 238, in request
    raise DeliveryError("Message send failure %s" % (v[0], ))
zigpy.exceptions.DeliveryError: Message send failure EmberStatus.MAX_MESSAGE_LIMIT_REACHED

#375

I use hass 0.71.0 and zha component, Elelabs ZigBee RPi Shield and some xiaomi devices (door sensor). Zha component is loaded, zha.permit is started, device joined the network but not listed into HA (the zigbee.db is empty). I have temporarily resolved issuse as follows:

  • Downgrade Home Assistant to version 0.69.1
  • Delete zigbee.db
  • Restart HA for setup component zha again.
  • Call zha.permit service and pair xiaomi device again
  • Device joined the network but error: Message on unknown endpoint 1 (The zigbee.db looks as follows after the device has been joined. There is only an entry in the devices table since it does not respond to the endpoint discovery)
  • Manual create the endpoint entry and entries for the output clusters
    • INSERT INTO “endpoints” VALUES(‘xx:xx:xx:xx:xx:xx:xx:xx’,1,260,0,1);
    • INSERT INTO “output_clusters” VALUES(‘xx:xx:xx:xx:xx:xx:xx:xx’,1,4);
    • INSERT INTO “output_clusters” VALUES(‘xx:xx:xx:xx:xx:xx:xx:xx’,1,5);
    • INSERT INTO “output_clusters” VALUES(‘xx:xx:xx:xx:xx:xx:xx:xx’,1,6);
  • Restart HA and it working fine
  • Upgrade Home Assistant to version 0.71.0

But after a few hours not updated status, the device seems to have left the network (listed in HA but not responding)


#376

I just tested Keen smartvent and unfortunately they show up as switches (for which commands fail) with a temperature and pressure sensor. Is there anyway to make it a dimmer (analog output)?

the device has the following cluster IDs:
0 basic
1 power config
3 identify
4 groups
5 scene
6 on/off
8 level
32 polling control
1026 temperature sensing
1027 pressure sensing
2821 ??
64513 likely proprietary
64514 likely proprietary

Would be great to add a dimmer device to hass upon detection of cluster ID 8. This should make it functional.


#377

Banging my head wondering why a device which has clusters 4,5,6 and 8 shows up as a switch on Home assistant. It should be either a dimmable light or a level control switch. Anybody have an idea?


#378

Successful inclusion and fully functional, reliable use of Sengled Element Classic (Sengled E11-G13) bulbs, and OSRAM Lightify (A19 RGBW) bulbs directly to my HUSBZB-1. Can restart bulbs and HA without issues. Nice work!

Please let me know if you want more detailed info


#379

6 is on/off and 8 is level control. the handling of dimmers, remotes and buttons is a bit suspect at the moment. I am working on several fixes to clean this up. when you list clusters, can you include whether they are input or output clusters? That makes a big difference in how the device can be handled.


#380

What device is it? I mean is it an actual dimmable bulb/switch or is it a remote? And what do you get for the device type? Any chance you can get output of bellows devices ?

Currently, unless device type is not a DIMMABLE_LIGHT or similar, zha component will probe by clusters and since there’s on/off cluster present it would treat it as a “on/off switch”, regardless of the presence of the LevelControl cluster.
eg this “KingofFan” Zigbee device shown as

Device:
  NWK: 0x4e6b
  IEEE: 00:22:a3:00:00:16:d0:18
  Endpoints:
    1: profile=0x104, device_type=14
      Input Clusters:
        KofBasic (0)
        KofIdentify (3)
        KofGroups (4)
        KofScenes (5)
        On/Off (6)
        Level control (8)
        Fan Control (514)

will show as a “switch”, even though I’d prefer it to show up as a dimmable light.

If I’m reading the code correctly, there may be a way to override the device type. You need to know the IEEE address of the device and Enpoint # and then create the following config entry under zha configuration in your configuration.yaml
eg for IEEE address 7c:b0:3e:aa:00:a4:55:95 and endpoint #3 create the following:

zha:                                                                                                   
  baudrate: 57600                                                                                      
  usb_path: /dev/ttyS1                                                                               
  database_path: /zigbee.db                                                           
  device_config:                                                                                       
    7c:b0:3e:aa:00:a4:55:95-3:                                                                         
       type: 'light'

#381

Thank, that explains it. I thought the component would have been smart enough to see there is more than an on/off endpoint It is actually a motorized vent. It is setup on the vera as a dimmable light or as a window covering. See here:


#382

Attempting to manually configure did not work. Actually nothing changed…