Emulated Hue suddenly stopped working with Echo Dot V2

Running Hassbian 0.84.6
Echo dot V2 Software ver: 644580020

I’ve had emulated hue working with my amazon echo dot V2 for about 2 years now and never had an issue. Suddenly on Aug 23rd, it stopped working with all my stuff. I did not change the config file, did not change router, did not change or add anything. All I see now is “Server is unresponsive” on my Amazon Alexa app. If I delete the device and re-add it, it now says “Device is unresponsive”.

I know the emulated hue is working because it works on my logitech harmony hub and I have check via http://<HA IP Address>:8300/description.xml and http://<HA IP Address>:8300/api/pi/lights

Does anyone know if the Echo Dot V2 got a firmware upgrade that broke this?

Only error I see in HA for this is:

Mon Aug 26 2019 11:32:42 GMT-0400 (Eastern Daylight Time)

'emulated_hue' is deprecated. Please rename 'emulated_hue' to 'emulated_hue_hidden' in your configuration file.

Configuration.yaml file below:

  host_ip: !secret pi_wip
#  listen_port: 8300
#  listen_port: 80
    - script
    - scene
  expose_by_default: true
    - switch
#    - group
    - input_boolean
#    - media_player
    - light

So after posting this, I tried deleting a device and adding it back but this time, the Echo could not discover the device… :man_facepalming:t4:

This is driving me up the wall. :face_with_symbols_over_mouth:

1 Like

Restart your router. This most certainly is a network issue. Verify that your router didn’t change your home assistant IP as well.

I absolutely agree with you that I believe it’s a network issue as well. I tried moving the echo closer to the router yesterday and still it did not work.

I VPN’d back home and rebooted the router.

I was unable to ping the echo dot from the pi, I wasn’t able to ping the echo dot from my router either. The weird thing is I am able to use the echo for searching/weather information meaning it’s connected to the internet. :thinking:

I noticed the same thing happen to all my emulated hue devices over a week ago.
Logged into my Amazon Alexa dashboard and all my devices except the ones with skills were gone. Including two physical hue bridges. Reboots, discovery, add/remove, etc… nothing seems to bring them back.
Still searching for an answer here. If I find anything I’ll let you know.

Well I’m glad I’m not the only one :slight_smile:

Yes about a week ago this happened.

FYI, can’t ping echo dots, they do not have ICMP protocol built in so it does not support pinging.

I am still convinced the firmware got upgraded and broke the emulated hue bridge. Only my skilled apps and switches work (TP link switch/WeMo switch), anything related to emulated hue is dead/unresponsive.

whats your device software version?

I’m running 641575220 on both my v2 dots

Echo dot V2 Software ver: 644580020

Looks like mine got updated.

The stupid thing is on the website, it doesn’t even show my version… :man_facepalming:t4:


how is that possible… the current release is 641575220 for echo dots…

What software version is your echo dot V2?

Mine is 644580020 which is not listed on the Amazon website.


Maybe they are rolling it out? It didn’t even prompt me for an update - that, or I wasn’t home at the time.

tell it to update it’s firmware. Say “Alexa Check for updates”

I will try that when I get home today. Doesn’t work over the app and it was a bit shotty when I tried to do it via intercom over an IP camera nearby LOL.

Tried to update and responded that it was up to date already.

Hassbian 0.72.1
Echo dot V2 Software ver: 644580020

My emulated hue has been working for years until about 3 days ago. Before I saw forum discussion, I reset my router, changed to another raspberry pi, powered down echo dot and powered up, changed emulated hue port in my configuration file…all to no avail. I have about 40 devices in my home automation system. I made no changes to system immediately prior to the time emulated hue quit working.

Seems like the culprit is this new echo v2 firmware version that isn’t documented anywhere on amazon.

EDIT: Where are you guys located? Maybe this firmware is only rolled out in your countries?

Yup, so as initially suspected, firmware issue with Echo Dot V2.

I’m in Canada but the Echo Dot is a US version. I bought it in the US before it was released in Canada.

The firmware may be region specific, not the hardware itself. What is the URL that you go to when checking the firmware version on amazon’s website?

US site, but even if I check the .ca version it’s the same version firmware as what you have. Mine is not listed anywhere unless we are the guinea pigs.

Are you signed up for any beta testing? I’ve tried looking but I can’t find anything.