Hassio on unRaid!

Leaving notes here for setting up HassOS on unRaid using the vmdk file in case anyone else wants to try or add their knowledge and experience because I basically fumbled through this…but it works!

  1. Download a hassos vmdk
    https://github.com/home-assistant/hassos/releases/

  2. Place the vmdk file somewhere on your unRaid system.
    I used /domains

  3. Convert the vmdk to a qcow2 img
    To convert, open a terminal in unRaid (upper right in the toolbar) and use this command, making sure to use the correct directory if not using domains:

    qemu-img convert -f vmdk /mnt/user/domains/hassos_ova-1.6.vmdk -O qcow2 /mnt/user/domains/hassos_ova-1.6.qcow2
    
  4. Resize the disk before setting up the VM
    This is important to do now before starting up the VM. Give yourself at least 32GB.

    sudo qemu-img resize /mnt/user/domains/hassos_ova-1.6.qcow2 +32G
    
  5. Set up a new Linux VM (the generic Linux choice)

    VM settings I used:
    CPU Mode: Host Passthrough
    Memory: 2048
    Machine: Q35-2.11
    BIOS: OVMF
    Primary vDisk Location: Manual / hassos_ova-1.6.qcow2
    Primary vDisk Bus: SATA
    Network Bridge: br0

    Now hit update to save the edit and then start your VM. Connect via VNC.

    Hopefully you are seeing it boot at this point.
    I let it run for a short time until it paused, then I hit enter to login as “root”
    At the Hassio screen, enter ‘login’ to get to the host.

    Check your host’s connection with nmcli d.

    Find your IP address with ip addr show

    Connect to your_ip:8123 and you should see the splash screen with the “20 minute” warning. If you’re not fast enough you may miss it, however, as I was at the Home Assistant overview page within 3-4 minutes of arriving at the splash screen!!

Thanks to @dale3h and @rbflurry at github! https://github.com/home-assistant/hassos/issues/97

9 Likes

Thanks for the guide was easy to follow and worked just as you laid it out. I have been using docker version from community applications but I like the concept of the app store

Thanks for the guide as well as I know some folks want to do the VM thing for Hass.io on unRaid.

Running the regular HA container along with the Dev version on the side of it with the other 20 or so containers I have running. Can you still modify stuff easily on the setup and how’s the CPU usage and performance?

I also have the dev and regular HA containers, in addition to a debian VM with Hassio, and a pi3 with the newer HassOS. I haven’t had time to play much with this one since getting it to boot and connect, unfortunately, so I don’t have those details for you. So far you can modify “as usual” in Hassio.

Awesome, definitely going to try this out this weekend to toy around with and see how it all works out. Not sure I’ll run it as production but still cool to play around with and have a test “bench” of it so I can at least have some knowledge of the Hass.io limits/changes.

Was able to get this up and running without issue, however I cannot seem to get the Z-wave stick passed through properly. Is this something you were able to do?

EDIT: They release 1.8 today with the proper virtio drivers so you don’t need to change the nic settings via xml.

1 Like

I have messed with passing through USB devices and have been unsuccessful. That’s great to hear about 1.8! I was hoping it might fix the USB issue as well, though.

USB pass-through does not work for either I have checked the /dev and do not see any of the pass through devices I have tried

It appears there is a pull request to get the Aeotec device working. Hopefully that change will be merged soon so we can test it out.

@dragonpark It looks like the change was merged, and we just have to wait for the next release.

On a different topic, has anyone been able to map a share to the VM? I’d really like for it to store the data (config, logs, add-ons, etc) on a mapped share instead of inside the VM image itself.

So it looks like this works in hassOS 1.9. I’m using USB controller passthrough in unraid, not single device passthrough and I had to use controller mode 3.0 nec XHCI. I don’t know if that’s specific to my setup using controller passthrough or not.

I used these two videos to do the USB controller passthrough. I wouldn’t recommend doing that unless single device passthrough doesn’t work. I don’t really want to undo what I have working though, so I hope someone else can test single device passthrough.


@dale3h I’m going to be looking into mapping shares into the VM soon. In the meantime though you can resize the image by using the command sudo qemu-img resize hassos_ova-1.9.qcow2 +10G

2 Likes

Oh man I have been having a lot of trouble with my rpi3 hassio (failed sd card w/o backup and now hassos will just lock up and need a hard reset to come back). I have unRaid running all the time and hass is super snappy in the docker. I will be giving this a shot and may move to only this.

1 Like

I played with this over the weekend it was pretty easy to get going. I had some issues with a few add-on’s not running or starting but for the most part things worked. It does take a little more memory and CPU time being a VM compared to a docker container. Not sure if the pay-off is worth it for me at this point with the data saved inside the image instead of the appdata folder combined with the lessened troubleshooting and maintenance capabilities that docker containers just excel at. Will definitely leave it installed though as an option one day if I need it.

Can you passthrough USB devices like the z-stick with it running as a docker container? I didn’t think that was possible without running as a VM.

Yes, you just have to map the device in the config

image

Ah, but this isn’t hassio, it’s just home assistant running in a container.

Passing the USB device into the container is pretty simple as shown in the screenshot. Have the Zwave/Zigbee ports from the HUSBZB-1 passed in without issue.

I’ve been using HassOS 1.9 in an unraid VM with the z-stick for a little over a week now and I have to say that it’s pretty great. Everything is significantly more responsive, especially zwave. It’s also nice that a HA restart takes about 15 seconds now instead of 10 minutes.

2 Likes

I can not seem to pass through the Nortex HUSBZB-1 stick at all via unraid VM. In hassio the only devices I see are

/dev/ttyS0
/dev/ttyS1
/dev/ttyS2
/dev/ttyS3

EDIT:

I figured it out, I had to set the USB controller on the VM to 2.0 (EHCI)

EDIT:
This worked for a few hours and suddenly my USB stick gets dropped and requires a VM restart. Anyone else having this issue?

Hello, I got this HassIO to install and work on a VM in unraid thanks to your guide, however I’m not sure how to access any of the config or log files. Is there a way I can access the config files through a samba share? Thanks!