Installation of Hassio on Synology NAS

anyone tried to use from SynoCommunity ?

I wouldn’t waste my time on that one. It’s an ancient version from 2015, one initial release, never updated.

If your Synology is able to run docker and you want to run home assistant on it, the official home assistant docker image is the best way to go in my opinion.

Regarding the plugins: virtually every hassio addon is just a wrapped and preconfigured version of a native docker container providing the same functionality.

It’s just a bit more convenient to manage these addon containers completely inside HA, instead of switching to the Synology docker GUI. And you spare yourself a bit of manual editing the HA configuration.

Apart from that, I don’t see a great benefit in trying to get running on a synology nas instead of using the native docker containers.

Let’s take an example like the Lovelace Migration add-on. How do you install this add-on into HA on Docker on Synology NAS?

I’ve pulled down the Docker bits, mapped the config folder, but it fails on launch. There’s got to be more to it. So although multiple people have said how easy it is to manually install add-ons without using Hassio, I’m clearly doing something wrong because the only one that I’ve successfully set up this way was the HASS Configurator.

No, I didn’t write that you can use plugins without These are specialized docker containers only working in a environment.

What I meant is, that most of the addons are just rewrapped versions of regular docker containers.

For example I’m using a regular mosquitto docker container downloaded from the docker hub via the Synology docker GUI as my mqtt server instead of the addon providing the same service.

If there’s no regular docker container that provides the same functionality as the addon, you are out of luck, respectively need to install it manually.

Regarding the lovelace migration script: As this is a one-timer I manually installed it in my current home assistant docker container and it worked fine. It will be gone with the next update of the container, but that’s ok, as I won’t need this script ever again.

Regarding the lovelace migration script: As this is a one-timer I manually installed it in my current home assistant docker container and it worked fine. It will be gone with the next update of the container, but that’s ok, as I won’t need this script ever again.

How did you run the lovelace conversion script manually on a DS918+ ?


I don’t use a DS918+, but a DS216+II. But using the script in a docker container should be the same for all Synology models.

I downloaded the migration script from here and I put it in the HA config dir:

I opened a ssh session on the nas and ran a shell inside the running HA docker container with

docker exec -i -t homeassistant /bin/bash

I followed the instruction on the GitHub page, i.e. running a pip3 install -U homeassistant before running the migration script.

I’m not entirely sure, if the pip install is really necessary when the script is used directly in the HA docker container. But it didn’t break anything and whatever got installed will be gone, when I delete and recreate the HA container the next time.

The attempt to update SynoCommunity’s HomeAssistant spk it is in Pull-Request: … the result might be a bit stale when it lands, but the next update should be a bit less work.

(It’s my PR)

Is there any way to install it now?

I’ll try to write up a guide, perhaps even create a spk.

Does your NAS support Docker (this is a must to get support) and which CPU do you have (uname -m)?

然,支持docker。CPU是Intel J1900。

What does that mean? Please provide the arch (by running uname -m)

Edit: here is a short instruction on how to run hassio on Synology on Synology · GitHub

That looks easy enough to do. I’ll give that a try when I find some time. No other requirements needed before running this? (Given that the arch is good etc.)

This still runs Docker images that are visible in the Docker app I assume? Is there anything that would make this unstable for daily use? I’ve been looking to use Hassio instead of regular Docker install for a while now, but I don’t want to trade in performance or stability for example.

@everyone, please post if you’re trying or using this, looking forward to experiences from others.

Yes it is supposed to be easy but currently is it not working fully. I can get the hassio supervisor to run and start homeassistant but I can’t access from there.

See my post as a proof of concept so far. It needs some more testing and I’ve already submitted a patch to (there might be more that is needed).

I’ll keep you updated with my progress but I’m hopeful to get close to full functionality into intel_64 arch with native docker support.

Also, the docker instances will still be seen in Synology’s docker app.

In terms of performance it should be the same as for the Docker version of home-assistant on Synology. I hope stability will be the same once I figure out what is causing the connection issue.


Sounds great. Amazing work! Looking forward to try it soon!

1 Like

x86_64 :微笑:

I’m hoping that we get somewhere to easily install hassio on Synology. That would make life much easier.
Good luck experts

1 Like

Continuous attention…

1 Like

Hello Fredrik,

I am really interested if you got it running. I am now using home assistant via docker and testing via virtualbox on synology. Having on synology docker will be perfect!


1 Like

Any updates on getting this working?

It’s been some really crazy weeks so I’ve not had time to look at it more, perhaps in mid June.