IPAD 3 IOS 9.3.5 support or not?

Hi all,
I’m trying to get a ipad 3 to work with HA. Ipad is fine and fast enough for some web pages.!
I have chrome/safari and the latest supported app from HA installed on it. But for some reason next thing is happening:

I get the login page but after i click next i see: error something whent wrong?

Does someone knows / can help me with this or is it a lost case?
I dont get it why it wont work because the HA works on a website i dont care about the app browser is fine…
Hope someone knows where it goes wrong.


1 Like

same problem here. i understand if the app is not supported, but the webpage should work?

1 Like

No doesnt work. I tryed all the browsers available and jailbreak etc. No go. I even tryed to change to user agent but no go. I really would like to see on a website my HA. those old ipads are nice to see and fast enough.

1 Like

Totally agree

Same here. Really want this back.
It was working until I recently logged out…

I’m new to home assistant and forums but I have a workaround that I am using currently. Its clunky but it works well for me.

Just saw this in the 0.117 announcement

We improved compatibility and Home Assistant is now usable on more, mostly older, devices.

I just updated and tried on my old iPad, and it works: Version 0.117 brings the iPad 3 compatbility back!
Many thanks to the HA team!

wow, That is great.
Cant wait to check if it works on a legacy ios :wink:

My iPad 3 is on iOS 9.3.5, so legacy iOS.
Only small problem is that my custom cards are not loaded (such as the slider-entity-row). I made a simple dashboard for the iPad to solve this problem


I checked with the home assistant app on 9.3.5.
Yes it works, and custom card doesn’t load for me either.
Very slow, but it makes my old ipad great again :wink:
With some exception of devices that needs to be new, it feels good
to run home IOT with old, repurposed devices.

Guys how did you get this to work? I’m on iOS 9.3.5 also on an ipad2 and can’t seem to login. Tried legacy authentication too but that throws a security error. I installed home assistant on the iPad by downloading on a newer ipad with the same apple id, it’s there but upon launching safari everything goes to hell. Tried chrome and Firefox too, the latest supported versions but no luck. Any ideas anyone?

Which browser are you using? Safari, chrome and Firefox won’t let me login. I have the companion app installed, it launches the login page and then I get a wrong user pass error. My home assistant instance is exposed to Google for what is worth so I’m using SSL with no way to access internally (is there a fallback?). Really want to mount that ipad2, even bought a mounting pad lol. Played around with tileboard but I guess in my case I have to run it as a standalone server right? Any help would be greatly appreciated.

1 Like

I have an old ipad2 with iOS 9.3.5 and I finally GOT IT TO WORK! :wink:

Came across this post, because I was struggling with the same issue. Authentication via the UI gives me a wrong username of password error.


There is an option within HA to bypass to login screen, explained here:

Note that the userId is not the username, but the ID. this can be retrieved via the users config screen (http://homeassistant.local:8123/config/users)

After making this change, you can access HA with safari (or any other Kiosk browser app) by clicking trusted networks option below the login/password box :


I’ll give this a try asap and report back! If it works you’ll be my hero haha :muscle:

I tried but i am not seeing the Trusted Networks button. What am i doing wrong? i added in configuration.yaml as follows:

    - type: homeassistant 
    - type: trusted_networks
        - ## your device IP
      trusted_users: MYIDFROMUSERS ### the user id
      allow_bypass_login: true

Thanks in advance to all!!!

Same here; I added the trusted networks and trusted users updated with my own information. The user ID is not the name, but the actual ID of the user account in Home Assistant, got that. Also read the on-line help on this topic: Authentication Providers - Home Assistant
I understand that there should appear a list of users below the part where you can enter login credentials, but I don’t see this on the login page. Are there some prerequisites that I need to set to enable this? Maybe someone has some trouble shooting tips, as I can’t see anything related to this in the logs.

Ok, this works for me now(had a config error which I fixed). I can login, but because I have multiple users I don’t use the allow_bypass_login.

I’m trying to do this with an iPad Mini 1…can’t download any new browsers so I guess I’m stuck with the older version of Safari. I’ve added this ipad as a trusted user and the option to login as trusted user appears…but then it just says “logging in with trusted networks” followed by “login aborted” with the option to “start over” :confused:

…would be great if we could find a way to keep these older devices from making it to the landfill…especially given apple’s red tape is the only thing keeping them from being useful.

I’ve also jailbroken the device but can’t find any useful browsers…any suggestions would greatly appreciated.

1 Like

After I got the login working, the safari browser was not able to display any Lovelace dashboard. So the login isn’t the only hurdle to take…


Hello Community,

i have posted my solution in