Newbie stuck on Home Assistant onboarding screen

Hi there! I’m a newb and after installing on virtual box after initial startup saying it will take 20 minutes it gets stuck on this screen with just the Home Assistant logo.

any tips would be appreciated, I followed the install instructions on the HA website.

Firstly, in VirtualBox I would “show” the VM to see what’s going on there. If that doesn’t provide useful info, post the settings of your VM - like networking details, memory, storage, which image you’re using etc.

I got this too on latest image to Raspberry Pi 3+. Everything went smoothly until HA start finding my integrations. Instead of clicking next, I clicked show more. Resulted dimmed page. After refresh it was stuck to the onboarding page just like above.

1 Like

Same here on brand new Docker install. Although it worked fine to reload page, login and then press Finish instead. So maybe this is partly fixed.

First a virtual box, then a docker, and me with qemu/kvm same issue, hmmmmm.

On my end it is/was operator error. Too smart by 1/2.
I told noScript addon in Firefox to TRUST the Home Assistant url and it works as advertised.

Exactly same problem. Clean install on Raspberry Pi 4, clicked on more and it hung on a dimmed page. After refresh was stuck here. Did you find a solution?

The solution for me was to open a different browser and click the ‘Finish’. You could try emptying your browser cache too.


I had the same issue with HA in Docker, thank you @thargy as opening an inprivate session worked for me!

Thanks. This worked well. It seems that the dimming window after clicking “More” is a common issue

Stuck here too in 2022-05-01, installed core and did initial startup. After first login attempt it gets stuck on onboarding.

Tried to

  • flush browser cache
  • change different browsers: falkon, firefox, chrome
  • removed the content of config/.storage dir
  • restarted everything

Nothing helped. I put back the storage dir content.

There are ‘official instructions’ for this, but it doesn’t help.


There is a config/.storage/onboarding file which contains the steps of finished onboarding phases. Finished, running system has:

  "version": 4,
  "minor_version": 1,
  "key": "onboarding",
  "data": {
    "done": [

My hanging (git clone core installed) instance has proceeded into analytics and integration is missing. Adding it manually allows me get by that initial integrations initializations and actually log in.

When running with --debug flag, I get

ERROR (MainThread) [] Platform met does not generate unique IDs. ID home already exists - ignoring weather.forecast_home

Not sure if that’s the culprit. It does show up into integrations thou.

Based on cases where a lot of people have got stuck with onboarding this clearly needs some more verbose console messages to give a hint what it was doing and what it’s trying next - now there is nothing.



This may be a bug in 2023.05/stable. I had the same issue and no suggested fix worked. Instead I downgraded from
and I can get past onboarding now.

EDIT: After using the 2023.4 image to pass onboarding, I could successfully return to :stable without issue.


Hey there! Where did you change that?

I just installed two VMs, Proxmox and ESXi, both with the HA 10.1 version image available on the website. The same problem with the “” screen and that’s it. Unable to access the system. Does anyone have the solution?

In both cases, the installation is new from the images obtained for download from the official website.

Similar situation: Win 10, Virtual Box, both 7.x and 6.1, HA 8.2 (which I had working on an old version of VirtualBox) and HA 10.1 (latest). I’m thinking it is a problem with Windows, since I have tried all four combinations of VM and HA with the same effect. Right after setting location, then diagnostics it flips to the empty screen with the “homeassistant” badge (OP image).

Boot seems normal, internet seems Ok, I can go to different machines (in my house) and open “homeassistant.local:8123” so networking is fine. Just no joy after diagnostics: stuck in /onboarding.html Tried different browsers (edge & chrome) with same results.

This all works just fine on an RPi 3 (not in a VM, of course) and I had it running on a Win 10 PC about a year ago so I am mystified what the issue is.

I’m similarly stuck. Ran 10.1 and 10.0 in hyper-V windows pro 10 (22H2) today and hit the wall on /onboarding.html

Good to know it works on Pi, may just get the pi2 out and stop this troubleshooting

Wanted to post this here for anyone setting up a new VM with Windows Hyper-V. If you use the out of the box Network “vEthernet (Default Switch)” this is not external or said another way it’s not using your physical NIC. So, you need to go into your Switch Manager of the server and create a new Virtual Switch that uses your Physical Network Adapter and then update your VM to use said switch.

TLDR; My issue seemed to be similar to what was all posted above with regards to using windows Hyper-V and my issue was resolved with connecting to the internet.

Hyper-V default switch NATS by default so it should have internet connectivity. That said I did switch my VM to an external address where it was on my ‘physical’ network and no dice on it resolving the issue.

I issued the command dns logs and saw a lot of nxdomain errors. likely the culprit but being less than 12 hrs into this I’m not sure how to crack through the cli to uncover more…

Same problem here, tried:

  • homeassistant/home-assistant:stable and :dev
  • homeassistant/generic-x86-64-homeassistant:stable and :dev
  • VirtualBox VM from the download link
  • QEMU qcow2 image from the download link

No joy with any, am able to create account and set locale but then blank…