Updated, entire network crashing (Draytek routers)

Running haos on Proxmox

OS Version: Home Assistant OS 10.2
Home Assistant Core: 2023.6.0

Updated to 2023.6.0 last night and it took down my network and internet connection (Draytek),

I am able to start the VM with the network disabled, but as soon as the network is enabled everything goes down.

Any suggestions on how I can debug this? I’m guessing it might be an addon as not seen reported elsewhere. How can I access logs from CLI?

I have the same problem:

Same issue here. also with a Draytek router

Just to add, I too have a Draytek router. I didn’t think that was too important, but all three of us with this issue all have Draytek routers. Odd.

How did you restore a backup? For me that’s failing if I try from the UI at the moment.

It doesn’t help that with my router continually restarting, HA is taking a long time to startup due to failing name resolution.

Hi Liam,

I understand your problem. I have not found a way of viewing the GUI on the computer running HA, so even when I tried to restore from the backup via another PC, it never worked as the HA computer was never visible long enough.

I was lucky as I run a full backup of the computer every day (using Macrium), so I was able to restore from the Macrium backup. Without a PC backup, the only way possible, I guess is if you are able to restore from the CLI, but I am not sure you can.

Maybe an answer would be to connect your HA computer with another computer using a network switch (I think for that you would need both the HA PC and the other PC to have fixed IP addresses on the same network). Neither machine would have Internet access, but you might be able to get to the GUI of HA and restore from the backup.

I have opened an issue:

1 Like

This actually causes my Vigor 2862 to reboot, so it’s go to be doing something nasty to the network, but as it’s causing a reboot it’s difficult to capture what’s actually happening.
I’m running HA in docker on Ubuntu and have disabled all the Add-Ons and it’s still happening. I’ve started working through disabling lots of integrations to see if I can narrow it down.

1 Like

I too have the Vigor 2862 router. My router was not rebooting, but somehow, all devices attached to the router, such as my PC and my Wi-Fi mesh were disconnecting and reconnecting every few seconds. As soon as the computer running Home Assistant was physically disconnected from the network, the network would work normally. When I did a ping test from my normal PC, I would get 15 or 16 successful pings to the router, followed by around 10 failed pings and then 15 or 16 successful pings again etc.

Same here, VMWare on windows 11 , draytek router 2860ac, fire up HA, dsl drops etc …

No joy restoring any backups, as every time I try says can’t run due to Supervisor having no internet connection sigh!

I’ve disabled all add-ons, now disabled (almost) all integrations and still a problem. But only when HA core is running, stop that and the network / router recovers.

I’ve got some HACS integrations, but without a working internet connection it appears you can’t modify those through the UI.

If I try and restore from a backup from the HA UI or HA CLI, nothing appears to happen and no error messages I can find:
sudo ha backups restore adfcb3bb
Command completed successfully.

I’m now trying to wade through all the posts about HA backups not working to work out an alternate method.

My solution to get up and running again:
sudo ha core stop
ha core update --version 2023.5.4
sudo ha core start

Then use the UI to restore a backup


I am running HA 2023.6 on a pi4, the 10.2 OS update didn’t cause any issues but as soon as 2023.6.0 core was updated i started to have network issues and i am using a draytek router too.

Luckily i have a test pi to perform updates on before applying them to my production pi, so here are the things i have tried.

I have wiped HA from my test and downloaded a new 10.2 OS, which went well up until 2023.6.0 core was installed, as soon as i get to the login to enter my login details etc, the network started to go crazy, so is not an add-on causing this issue, as is a fresh install. I also tried to syslog to see what happened before the rotuer reboots (which it does every 30 seconds or so constantly) but due to the network issues i was unable to pull anything from this. However i can get a debug log for the incident (Troubleshooting an unexpected router reboot) 3 - View Router’s Debug Log, but is meaningless. I have also made several alterations to the draytek like turning off DoS defence and disabling several things but the router will just reboot as soon as my test HA is at the login screen.

I cannot imagine what HA is doing to cause the router to reboot every 30 seconds, it takes about 10 seconds for my draytek to boot, so within 20 seconds of the router being active it reboots again and i also have intermittent communication on the network even being hardwired.

I’m trying to think what could possibly be singling out Draytek routers. Could it be a specific port being used by Draytek?

i have made progress
HA is up and router is stable, bear with me while i narrow down the cause

You can reboot them remotely using telnet / ssh / web UI, however that needs a password which HA core wouldn’t have. I wonder if it’s some device discovery that the new core is doing that’s over aggressive and flooding the Vigor with data it can’t cope with. Perhaps the new Mater 1.1 discovery or something related to other speed optimisations that are included in 2023.6.0?

Yes, I can replicate this on a fresh install too

If people are able to replicate it, could you disable zeroconf integration (you will need to remove default config for that).

1 Like

is anybody able to test my findings and let me know if it works for you too

after changing several things disabling IPv6, disable HW acceleration, disable UPNP and enable IGMP, it seems 2023.6.0 works with these enabled HW acceleration (can be disabled), UPNP enabled on 2860 but not 2862 (can also be disabled), IPv6 disabled (not using it anyway) but IGMP was disabled on my router

if i enable IGMP Proxy IGMP Snooping and Enable IGMP Fast Leave it is stable, please confirm while i narrow this down a little further

Ok Narrowed down to just enabling IGMP Proxy seems to prevent a router reboot (actually It stopped a reboot for about 5 minutes)

will report back shortly

@WAJWAJ Yes can confirm enabling IGMP Proxy seems to work - thanks

1 Like