WallPanel for Android [Formerly HomeDash]


#1

WallPanel is an browser app to display ‘dashboard’ type webpages such as HADashboard or HASS on a device, which may make good use of older tablets/devices you want to use for home automation dashboards. The difference between this and kiosk apps or pinning a web page is the app is providing remote control/home automation features (eg, you can remotely control the URL that’s being displayed, or get feedback on motion on the camera). P.S. An iOS version is in development with the same API

This project will be considered stable at 1.0, and some formal HASS support is planned for then.

DOWNLOAD HERE: 0.6 Releases Download on Github
WallPanel API (MQTT/REST): https://github.com/WallPanel-Project/wallpanel-api/blob/master/README.md
Quick Readme: https://github.com/WallPanel-Project/wallpanel-android/blob/master/README.md
Issues/Feature Requests: https://github.com/WallPanel-Project/wallpanel-android/issues

Major Changes in 0.5:

  • Rebranding to WallPanel
  • Alignment to WallPanel Common API
    • [Breaking] Configurations will be lost
  • Added REST support
  • App starts to browser always

Major Changes in 0.6:

  • MJPEG Streaming
  • QR code detection
  • Face detection

Home assistant wall mounted tablet
HomeDash for Android 0.4 - Dashboard Browser with Sensors
Floorplan for Home Assistant
Announcement: HADasboard beta4 - Release Candidate!
Problem starting embedded MQTT broker
HADashboard Tablet Hardware Options
Append password to URL? - HADashboard Appdaemon 3
#2

I have an old Acer Iconia running 4.0.3 - I keep getting “parse error – there is an error parsing the package”. Is this too old to be compatible?


#3

Right now we are targeting API19 (4.4) but a lot of the work to support 4.4 will probably cover going back to 4.0? I’ll give it a try in the next round

EDIT: Ok it seems we’re stuck at API16 as a minimum, which is 4.1. Crosswalk is not a dependency I think we can move on. I’ll look a little bit more.


#4

It’s all good, more curious than anything. I marked this unit out of use a few weeks ago because it struggles so much.


#5

What a shame. I just dusted off my old iconia and tried to install this. Would have been nice. Unfortunately I got the same error as you.
I gave up a long time ago trying to flash it to something newer.

Ah well, it can go back into the cabinet…


#6

Well, Im trying to build an API14 right now, despite Crosswalk claiming it needs API16. We’ll see what happens. What version is yours running? (API16 is 4.1)


#7

@datamonkey @Corey_Johnson Check out the releases page, there’s a API14-TESTONLY APK there, give it a shot.


#8

I do not think it worked. I downloaded and installed but when I run it shows a blank white screen for about 3 or 4 seconds the exits back to the Android home screen.

I added the sensors and setup the embedded MQTT. I see them in HA but they are blank:


#9

Unfortunately same outcome here
The file download, parsed and installed. But when I start it I get a white screen, then it stops and closes back down.
Is there any way to debug or get a log file?


#10

You have to turn on MQTT in the first place within the app, so if we cant get that far then you’re not going to get any data :confused:


#11

If it’s plugged into a computer via USB its possible to use adb to view all the system output

But really, the first thing that happens is it runs the browser. If the browser is bombing out, I would guess you’re also lower than 4.1 on that tablet. The minimum API the browser supports is API16 even though I let the app go to API14 (4.0), and I overrode that requirement. Apparently that requirement matters…

sigh


#12

Yes, we are on 4.0.3

Look, I don’t think it is worth your time making this old thing work. Even acer has given up on it years ago.


#13

Yeah it was a quick attempt, but I do have to throw up my hands at some point. I am not digging into the Crosswalk web browser component to figure out why it’s API16 and fixing that. Anyhow I guess for 0.6 I can say we have rolled back to 4.1 instead of 4.4 which may be useful to somebody, but 4.0.3 is painful. Heck, I couldnt even get 4.0.3 to boot in my emulator without crashing like crazy (it never appeared for debugging)

It looks like if I go back many versions of Crosswalk, they supported API14 once upon a time, but probably at the sacrifice of browser features that will matter.

EDIT: Kind of a similar thing with iOS as well. I think iOS 8 might be as low as I can go because of similar reasons, but, that at least covers the earliest iPads in that world…


#14

Had another thought that’s not too much trouble to try, the ‘browser’ thats on your device, does it browse to whatever you want to display and work? I’m guessing probably not… I can forgive having a modern browser and probably get it to work but at that point you’d just go crazy that the pages are broken :slight_smile:


#15

To be fair, I haven’t used that tablet in a long time. But it has chrome installed… Not sure if all pages would work.


#16

Chrome is a separate app really. Your best bet is probably full screen Chrome browser if you want to use that tablet for something.


#17

I can use Chrome and Firefox to get to HA on it but it is sluggish. No worries and thank you for trying!


#18

Worth a shot! Oh well. Maybe we will make someone with a 4.1 tablet happy at least.


#19

Not sure if I did something wrong or not as I am not very familiar with mqtt. I ‘believe’ I have it set up and can manually trigger the sensors in HA through CloudMQTT Websocket but I am not getting anything from my tablet.

I think this error is from it (from CloudMqtt serverlog):

1493169710: OpenSSL Error: error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol
1493169711: Client connection from 99.64.165.182 failed: error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol.

I guess it was the port. I had it set on 28507 but changed to 18507 and it is reporting the battery (only).


#20

Currently SSL is not working, so duh, Ill make an issue to get a toggle for SSL

Second, it only posts sensors that actually work. I have other sensors I need to add. That’s going to be very hardware specific. Right now it tries battery (pretty much always going to work), brightness (not all devices have a sensor), and pressure (I’m assuming the original author’s device had that one!)

My device only has the battery too

But, basically, you have it working!!! So the YAML in HASS for battery should get you something, assuming HASS Is pointing at that MQTT