[New Addon] Snap-Shipper - Webdav and S3 backups (and probably other ways to later on)

Tags: #<Tag:0x00007fc4234b6a38> #<Tag:0x00007fc4234b5fe8>

Hi i have just create a little addon to help me get my snap shots of my home assistant machine and up into my Nextcloud Using webdav.

It’s still a bit rough but i thought that there might be some people out there that would enjoy a way to get your snapshots of your devices without having to rely on google or drop box.

I plan on adding support for other ways of transferring the snapshots in the future.

the github project is structured so you should be able to add it as a repository in home assistant.

edit:

  • 2021/01/10: Robin came along and added a S3 sink to this, so from 0.0.1rc3 and onwards AWS s3 and compatibles (like minio) are supported
5 Likes

I highly appreciate your effort, I have been looking for this for a long time!

I am getting an unknown error while installing so.

Hmm,what are you running it on? (Pi, nuc, ??).
And are you running the most recent version of the supervisor?

Same here, can’t install the addon. Running on RPI4 (HA 116.2).

Ok, is there any errors in the log under the system tab in the supervisor?
I will make some time and try and fix it in this weekend, and any info would be appreciated.

1 Like

This is what the log shows as error:

20-10-14 06:09:54 ERROR (SyncWorker_4) [supervisor.docker.addon] Can't build b64ada70/armv7-addon-snapshipper:0.01: The command '/bin/sh -c pip install --trusted-host pypi.python.org -r requirements.txt' returned a non-zero code: 1
20-10-14 06:09:54 ERROR (MainThread) [asyncio] Task exception was never retrieved
future: <Task finished name='Task-1252447' coro=<AddonManager.install() done, defined at /usr/src/supervisor/supervisor/addons/__init__.py:143> exception=AddonsError()>

Thanks…
I will hook up a spare pi and fix this…

1 Like

@ASNNetworks and @duesseldorferjung
yeah i got the same error when i tried on a pi, but it is fixed now and installing should be significantly faster for everyone.

the install page should show 0.0.1rc0 (or higher if i get some more work done this weekend) as version when install (if it doesn’t you need to go back to the addon store page and press reload the same place you add the repo)

if anyone out there already have the add on installed then you might need to uninstall it and re install it as mentioned in the changelog.

i hope this fixes thing for you.

1 Like

Got to install, thanks! Gonna set it up soon :slight_smile:

works great with transip.nl stackstorage cloud provider using webdav

just wish that it could auto synch the backups without having to start the backup manually

Yeah I’m thinking about adding that, just not completely sure how I want to do it.

1 Like

Installation is working now, so thanks for the quick fix.
For me using Nextcloud the upload seems not to be working, the log shows uploading and after a while the Addon Itself stops.
2020-10-27 09:25:46,929 - INFO: Starting Snap-Shipper
2020-10-27 09:25:46,930 - WARNING: Dry run so we son’t ship anything
2020-10-27 09:25:47,272 - INFO: Processing: /backup/23a5538f.tar
2020-10-27 09:25:47,273 - INFO: uploading: 23a5538f.tar To: Your Webdav

Will more input be helpful and do you want the bugs reported in Github?

Not sure it’s a bug but yeah if you want any help I’ll need more info, and yes github is the place for issues.

I know my nextcloud some times has a file size limit. What happens if you place a txt file called in the backup folder?

Please do :slight_smile: I’d love if this webDAV implementation works like the Google Drive Backup add-on. I’s really robust (0 issues with backupping) and has lot of options to set.

I would choose this over Google Drive every day. Except, I need auto backups, which is most important for home automation in my eyes.

Just tried your addon to sync a hassio install to a remote Synology server with webdav. I can access it fine via WinSCP, but can’t seem to manage to get it working with this remote. This is all I got:

2020-11-28 21:57:46,907 - INFO: Starting Snap-Shipper
2020-11-28 21:57:46,908 - WARNING: Dry run so we son't ship anything

I had my password wrong before and it told me the auth was wrong, but now I get nothing… Any idea what might be wrong?

besides the embarrassing typo in the log?
well i didn’t make the documentation clear enough (or you didn’t read it).

DryRun : if true no files will be uploaded, set to false when you know that everything is configured right

Haha I didn’t even see the typo.

I know what the dryrun is, but I expect it to do more, or say more in the log. Also when I set the dryrun to false it also just says ‘starting’. I get no feedback whatsoever on what’s happening. I see nothing appearing in my share that I selected.

did you change the Folder?
and if not is there any files in the /backup folder on you hassio machine?

Is this still active?