Home Assistant Community

Bwalarm (akasma74 edition)

#1

This is actually a fork intended to maintain the original bwalarm custom component until its author is back.
Feel free to post your question here or create a new issue or pull request at GitHub if you downloaded code from my repo.
Please include versions of your component (from custom_components/bwalarm/alarm_control_panel.py) and its frontend (from panels/alarm.html) when enquiring here - it can be found also if you go to Settings of the component:

GitHub repo

10 Likes
YET another take on an alarm system
Bwalarm stopped working
#2

Thanks , i has set up success full.how to translate this component

#3

I have had good success with the BWAlarm install and the branch corrections. I am somewhat new to HA, but have all of my Alarm components configured and working via the Konnected boards. At this point I am working on my UI and have started playing with a custom Lovelace UI. I have added an iFrame card (in the ui-lovelace.yaml)

cards:
      - type: iframe
        url: http://hassio.local:8123/alarm
        aspect_ratio: 100%

The BWAlarm displays fine via the Lovelace UI from my Mac (Firefox) and iPhone, but I get ERR_NAME_NOT_RESOLVED on the Fire Tablet, which will be my main display. It still works from the left menu. I realize this is somewhat off topic. But if I can get the Fire Tablet to work, I was intending on looking at the CSS to update since the current version does not quite fit into the iFrame card. If anyone has any ideas why I am getting the error I would appreciate the help.

1 Like
#4

Automation for panic mode --> show error : Configuration invalidCHECK CONFIG

Invalid config for [automation]: [value_template] is an invalid option for [automation]. Check: automation->trigger->0->value_template. (See ?, line ?). Please check the docs at https://home-assistant.io/components/automation/

                  - alias: '[Alarm] Panic Mode'
                    trigger:
                      platform: state
                      entity_id: alarm_control_panel.house
                      value_template: '{{ state.attributes.panic_mode }}'
                      to: 'ACTIVE'
                    action:
                    - data:
                        message: 'Tôi đang gặp nguy hiểm hãy về nhà ngay'
                      service: notify.thongbao
#5

In future please format your post correctly.

You have the wrong trigger platform. You want:

platform: template

#6
  • alias: ‘[Alarm] Panic Mode’
    trigger:
    platform: template
    entity_id: alarm_control_panel.house
    value_template: ‘{{ state.attributes.panic_mode }}’
    to: ‘ACTIVE’
    action:
    • data:
      message: ‘Tôi đang gặp nguy hiểm hãy về nhà ngay’
      service: notify.thongbao

This still show err
Configuration invalid

Sorry the format code of this forum sometime not work correct

#7

Please format your code correctly in the forum. Don’t post an image. The gif shows step by step how to do this. Posting an image makes it difficult for people to copy and amend your code in a reply to help you.

trigger:
- platform: template
  value_template: "{{ states.alarm_control_panel.house.attributes.panic_mode == 'ACTIVE' }}"
1 Like
#8

Yes, It worked. Thanks for your support

#9

No worries. This is a better format to use:

trigger:
- platform: template
  value_template: "{{ is_state_attr('alarm_control_panel.house', 'panic_mode') == 'ACTIVE' }}"

It won’t produce an error if the alarm panel is unavailable.

You still have not got the formatting right. Press the </> button after highlighting your pasted text. Not the quote button.

1 Like
#10

Hi,

Thanks for making a fork and progressing this great component. I have a problem where on the sensors page when I select a sensor it ticks it then unticks it. All other setting seem to save ok.

Thanks,

Ben

#11

I’ve never heard about things like that. Have you tried a different OS/browser?
If that doesn’t help, please create a new issue on Github indicating versions of your component and OS/browser you’re using.

#12

New error: “Integration bwalarm not found when trying to verify its alarm_control_panel platform. Integration not found: introduction”

Just upgraded to HA 0.92.1.

Anyone seeing this, resolved?

#13

What did you upgrade from

#14

I was back a few releases. Not sure, maybe 0.91.1.

#15

Have you copied the manifest.json and__init__.py file from the repository?

#17

I copied them to config\custom_components\bwalarm. This worked.

#18

MQTT integration looks to be broken with 0.92.1. Taking a working bwalarm (v1.1.4_ak74) confguration and enabling MQTT produces no alarm component upon a restart. The logs show the following message:

“Signature of MQTT msg_callback ‘custom_components.bwalarm.alarm_control_panel.message_received’ is deprecated”

I’ve logged the issue at https://github.com/akasma74/Hass-Custom-Alarm/issues/1

Anyone else seeing this?

#19

hi, thanks for the effort to maintain this add-on, have you also incorporated this code changes ?

i have replaced all files from your repo and i get this
https://xxx.xxx.xxx/local/lib/jscolor.js:532:50 TypeError: undefined is not an object (evaluating ‘e.path[0]’)

also the alarm panel do not show up at all instead i get a blank page, i have tired with and without frontend:
javascript_version: latest

#20

I most likely haven’t because I personally haven’t seen any issues with jscolor.js… when does that error happen?

could you create a new issue here?

#21

appears in the log if you use an iPhone to access the Home Assistant iOS app and view the alarm panels AND your code is unpatched.